From 1e88c7f9805fe83d28952f3a3c2df2b5f03fb8f8 Mon Sep 17 00:00:00 2001
From: Seemant Kulleen <seemant@gentoo.org>
Date: Sun, 14 Apr 2002 08:29:15 +0000
Subject: Ebuild cleanup and libpng recompile

---
 x11-libs/wxGTK/ChangeLog                   |   8 ++-
 x11-libs/wxGTK/files/digest-wxGTK-2.3.2-r1 |   1 +
 x11-libs/wxGTK/wxGTK-2.3.2-r1.ebuild       | 103 +++++++++++++++++++++++++++++
 3 files changed, 111 insertions(+), 1 deletion(-)
 create mode 100644 x11-libs/wxGTK/files/digest-wxGTK-2.3.2-r1
 create mode 100644 x11-libs/wxGTK/wxGTK-2.3.2-r1.ebuild

(limited to 'x11-libs/wxGTK')

diff --git a/x11-libs/wxGTK/ChangeLog b/x11-libs/wxGTK/ChangeLog
index 916a9e548d96..7a0e870bd3eb 100644
--- a/x11-libs/wxGTK/ChangeLog
+++ b/x11-libs/wxGTK/ChangeLog
@@ -1,6 +1,12 @@
 # ChangeLog for x11-libs/wxGTK
 # Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/ChangeLog,v 1.3 2002/04/13 08:20:31 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/ChangeLog,v 1.4 2002/04/14 08:29:15 seemant Exp $
+
+*wxGTK-2.3.2-r1 (14 Apr 2002)
+
+  14 Apr 2002; Seemant Kulleen <seemant@gentoo.org> wxGTK-2.3.2-r1.ebuild :
+
+  Cleaned up the ebuild a little bit and needs recompiling against newer libpng.
 
 *wxGTK-2.2.9 (28 Mar 2002)
   28 Mar 2002; Spider <spider@gentoo.org>; wxGTK-2.2.9.ebuild
diff --git a/x11-libs/wxGTK/files/digest-wxGTK-2.3.2-r1 b/x11-libs/wxGTK/files/digest-wxGTK-2.3.2-r1
new file mode 100644
index 000000000000..f6631916d46b
--- /dev/null
+++ b/x11-libs/wxGTK/files/digest-wxGTK-2.3.2-r1
@@ -0,0 +1 @@
+MD5 197e08767cde58ebc3996dd4b6fed905 wxGTK-2.3.2.tar.bz2 4710189
diff --git a/x11-libs/wxGTK/wxGTK-2.3.2-r1.ebuild b/x11-libs/wxGTK/wxGTK-2.3.2-r1.ebuild
new file mode 100644
index 000000000000..cf35cfa73831
--- /dev/null
+++ b/x11-libs/wxGTK/wxGTK-2.3.2-r1.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Tod Neidt <tneidt@fidnet.com>
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.3.2-r1.ebuild,v 1.1 2002/04/14 08:29:15 seemant Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="GTK+ version of wxWindows, a cross-platform C++ GUI toolkit."
+
+SRC_URI="http://prdownloads.sourceforge.net/wxwindows/${P}.tar.bz2"
+
+HOMEPAGE="http://www.wxwindows.org/"
+
+DEPEND="dev-libs/libunicode
+	media-libs/netpbm
+	gif? ( media-libs/giflib )
+	png? ( media-libs/libpng )
+	jpeg? ( media-libs/jpeg )
+	tiff? ( media-libs/tiff )
+	odbc? ( dev-db/unixODBC  )
+	opengl? ( virtual/opengl )"
+
+use gtk		\
+	&& DEPEND="${DEPEND} >=x11-libs/gtk+-1.2.3"	\
+	|| DEPEND="${DEPEND} x11-libs/openmotif"
+
+RDEPEND="nls? ( sys-devel/gettext )"
+	
+
+src_compile() {
+
+	
+	local myconf
+	#--with-gtk enabled by default, if you want to build against motif,
+	#replace --with-gtk with --with-motif and --without-gtk. You will
+	#also need openmotif installed.	Unfortunately, the package build tools
+	#only support installation of one currently.
+	
+	use gtk	\
+		&& myconf="--with-gtk"	\
+		|| myconf="--with-motif --without-gtk"
+
+	
+	#Build static library too, shared library is enabled by default.
+	#Enable useful config options that don't have USE flags
+	myconf="${myconf} --enable-static --with-zlib --with-unicode"
+	
+	#Note: pcx image support enabled by default if found.
+	#Also, all wxWindows gui features are enabled by default. If you
+	#want to build a smaller library you can disable features by adding
+	#the appropriate flags to myconf (see INSTALL.txt).
+
+	#The build tools include a --with-freetype option, however it doesn't
+	#seem to be implemented in the source yet.
+	
+	#confiure options that have corresponding USE variable.
+	
+	use odbc 	\
+		&& myconf="${myconf} --with-odbc"	\
+		|| myconf="${myconf} --without-odbc"
+
+	use opengl 	\
+		&& myconf="${myconf} --with-opengl"	\
+		|| myconf="${myconf} --without-opengl"
+
+	use gif 	\
+		&& myconf="${myconf} --enable-gif"	\
+		|| myconf="${myconf} --disable-gif"
+
+	use png 	\
+		&& myconf="${myconf} --with-libpng --enable-pnm"	\
+		|| myconf="${myconf} --without-libpng --disable-pnm"
+	
+	use jpeg	\
+		&& myconf="${myconf} --with-libjpeg"	\
+		|| myconf="${myconf} --without-libjpeg"
+
+	use tiff	\
+		&& myconf="${myconf} --with-libtiff"	\
+		|| myconf="${myconf} --without-libtiff"
+    
+	./configure 	\
+		--infodir=/usr/share/info \
+		--mandir=/usr/share/man \
+		--prefix=/usr \
+		--host=${CHOST} \
+		${myconf}|| die
+	
+	emake || die
+
+}
+
+src_install () {
+	
+	make 	\
+		infodir=${D}/usr/share/info \
+		mandir=${D}/usr/share/man \
+		prefix=${D}/usr \
+		install || die
+
+	dodoc *.txt
+}
+
-- 
cgit v1.2.3-65-gdbad