summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/Apache-Gallery')
-rw-r--r--www-apps/Apache-Gallery/Apache-Gallery-0.9.1.ebuild61
-rw-r--r--www-apps/Apache-Gallery/ChangeLog9
-rw-r--r--www-apps/Apache-Gallery/Manifest26
-rw-r--r--www-apps/Apache-Gallery/files/76_apache1-gallery.conf20
-rw-r--r--www-apps/Apache-Gallery/files/76_apache2-gallery.conf40
-rw-r--r--www-apps/Apache-Gallery/files/digest-Apache-Gallery-0.9.11
6 files changed, 145 insertions, 12 deletions
diff --git a/www-apps/Apache-Gallery/Apache-Gallery-0.9.1.ebuild b/www-apps/Apache-Gallery/Apache-Gallery-0.9.1.ebuild
new file mode 100644
index 000000000000..819aa78ce0c9
--- /dev/null
+++ b/www-apps/Apache-Gallery/Apache-Gallery-0.9.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/Apache-Gallery/Apache-Gallery-0.9.1.ebuild,v 1.1 2005/08/02 20:41:53 rl03 Exp $
+
+inherit depend.apache perl-module webapp
+
+DESCRIPTION="Apache gallery for mod_perl"
+SRC_URI="http://apachegallery.dk/download/${P}.tar.gz"
+HOMEPAGE="http://apachegallery.dk/"
+
+LICENSE="|| ( Artistic GPL-2 )"
+KEYWORDS="~x86 ~amd64 ~ppc ~alpha ~sparc"
+IUSE="apache2"
+
+DEPEND="${DEPEND}
+ =dev-lang/perl-5*
+ >=media-libs/imlib2-1.0.6-r1
+ >=dev-perl/ImageInfo-1.04-r2
+ >=dev-perl/ImageSize-2.99-r1
+ dev-perl/Image-Imlib2
+ >=perl-core/CGI-2.93
+ >=dev-perl/CGI-FastTemplate-1.09
+ >=dev-perl/Parse-RecDescent-1.80-r3
+ dev-perl/URI
+ dev-perl/text-template
+ >=dev-perl/Inline-0.43-r1
+ virtual/x11
+ >=www-apache/libapreq-1.0
+ !apache2? ( >=net-www/apache-1.3.26-r2
+ =www-apache/mod_perl-1* )
+ apache2? ( >=net-www/apache-2.0.43-r1
+ >=www-apache/mod_perl-1.99 ) "
+
+src_install() {
+ webapp_src_preinst
+ mydoc="INSTALL"
+
+ perl-module_src_install
+
+ insinto ${MY_ICONSDIR}/gallery
+ doins htdocs/*.png
+
+ dodir ${MY_HOSTROOTDIR}/${PN}/templates/default
+ dodir ${MY_HOSTROOTDIR}/${PN}/templates/new
+
+ insinto ${MY_HOSTROOTDIR}/${PN}/templates/default
+ doins templates/default/*
+ insinto ${MY_HOSTROOTDIR}/${PN}/templates/new
+ doins templates/new/*
+
+ if use apache2; then
+ insinto ${APACHE2_VHOSTDIR}
+ doins ${FILESDIR}/76_apache2-gallery.conf
+ else
+ insinto ${APACHE1_VHOSTDIR}
+ doins ${FILESDIR}/76_apache1-gallery.conf
+ fi
+
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+ webapp_src_install
+}
diff --git a/www-apps/Apache-Gallery/ChangeLog b/www-apps/Apache-Gallery/ChangeLog
index e567867309d2..8f79a71f522a 100644
--- a/www-apps/Apache-Gallery/ChangeLog
+++ b/www-apps/Apache-Gallery/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-apps/Apache-Gallery
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/Apache-Gallery/ChangeLog,v 1.9 2005/05/24 14:38:40 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/Apache-Gallery/ChangeLog,v 1.10 2005/08/02 20:41:53 rl03 Exp $
+
+*Apache-Gallery-0.9.1 (02 Aug 2005)
+
+ 02 Aug 2005; Renat Lumpau <rl03@gentoo.org>
+ +files/76_apache1-gallery.conf, +files/76_apache2-gallery.conf,
+ +Apache-Gallery-0.9.1.ebuild:
+ Version bump (#97231). Fixed Apache paths (#79432).
24 May 2005; Michael Cummings <mcummings@gentoo.org>
Apache-Gallery-0.6.ebuild, Apache-Gallery-0.8-r1.ebuild,
diff --git a/www-apps/Apache-Gallery/Manifest b/www-apps/Apache-Gallery/Manifest
index ca96e95bc5f3..fa09ea02b100 100644
--- a/www-apps/Apache-Gallery/Manifest
+++ b/www-apps/Apache-Gallery/Manifest
@@ -1,22 +1,26 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 bf6743164883be655e68641a09339bd6 Apache-Gallery-0.6.ebuild 1461
-MD5 d2ffb46253b5ea9e00e990ec8a90904f Apache-Gallery-0.8-r1.ebuild 2125
MD5 b5db9e0472430724adea6de9580b41c5 Apache-Gallery-0.8-r2.ebuild 2125
+MD5 bf6743164883be655e68641a09339bd6 Apache-Gallery-0.6.ebuild 1461
MD5 5600ad85428bca4898ea3db305ba3dcc Apache-Gallery-0.8.ebuild 1525
-MD5 ffb6e1964b48936580b5d006756acde3 ChangeLog 2696
+MD5 d2ffb46253b5ea9e00e990ec8a90904f Apache-Gallery-0.8-r1.ebuild 2125
+MD5 bfe3863e28c5e78990d9d713ec9c8298 Apache-Gallery-0.9.1.ebuild 1622
+MD5 db46d88d61d90957f8ca7f0357da70e4 ChangeLog 2928
MD5 2a5bdc93be7720976d88be5034a17df2 metadata.xml 444
-MD5 862b7db14e194f66c345bdaee71e0d00 files/76_apache-gallery.conf 1461
-MD5 d9a1361f6d0f1dac9def27a0b57cf30c files/apache-gallery.conf 757
-MD5 f372bf3342f63c4d3a680051e80b5571 files/digest-Apache-Gallery-0.6 69
-MD5 3c77fe3e38d06f53fca962becfe10d81 files/digest-Apache-Gallery-0.8 69
MD5 3c77fe3e38d06f53fca962becfe10d81 files/digest-Apache-Gallery-0.8-r1 69
MD5 3c77fe3e38d06f53fca962becfe10d81 files/digest-Apache-Gallery-0.8-r2 69
+MD5 f372bf3342f63c4d3a680051e80b5571 files/digest-Apache-Gallery-0.6 69
+MD5 3c77fe3e38d06f53fca962becfe10d81 files/digest-Apache-Gallery-0.8 69
+MD5 004b7af7fb9d52598cf9ed7db91697c6 files/76_apache2-gallery.conf 1442
+MD5 d9a1361f6d0f1dac9def27a0b57cf30c files/apache-gallery.conf 757
+MD5 9e0a44b67c66dc689a3769827946f3f8 files/76_apache1-gallery.conf 738
+MD5 f946c05f08e4b517465f3a09639a5fe7 files/digest-Apache-Gallery-0.9.1 71
+MD5 862b7db14e194f66c345bdaee71e0d00 files/76_apache-gallery.conf 1461
-----BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.0 (GNU/Linux)
+Version: GnuPG v1.4.1 (GNU/Linux)
-iD4DBQFCkzyFtG5z4I8BtQoRAjNsAJ4jdU5DDMCOs5z/1j9j0hBk06XVrQCYnhrn
-4amcCD1FWjHode8V98m/OQ==
-=JDvR
+iD8DBQFC79qrEzitwsaoONoRApdgAKC0gJTS0nOTlw+TdFRiAkFjOBJBEQCfbGR3
+RJ1uN1nVNoGDz61+t+D2IRQ=
+=oyBl
-----END PGP SIGNATURE-----
diff --git a/www-apps/Apache-Gallery/files/76_apache1-gallery.conf b/www-apps/Apache-Gallery/files/76_apache1-gallery.conf
new file mode 100644
index 000000000000..1a23f1fdfdff
--- /dev/null
+++ b/www-apps/Apache-Gallery/files/76_apache1-gallery.conf
@@ -0,0 +1,20 @@
+##### Apache::Gallery configuration
+#
+# This is actually a virtual host definition with mod_perl directives
+#
+
+#<VirtualHost localhost>
+# ServerName localhost
+# DocumentRoot /var/www/localhost/htdocs/data/pictures/
+# ErrorLog /var/log/gallery-error_log
+# TransferLog /var/log/gallery-access_log
+# PerlSetVar GalleryTemplateDir '/var/www/localhost/Apache-Gallery/templates'
+# PerlSetVar GalleryInfo 'Picture Taken => DateTimeOriginal, Flash => Flash'
+# PerlSetVar GallerySizes '640 1024 1600 2272'
+# PerlSetVar GalleryThumbnailSize '100x75'
+# PerlSetVar GalleryCopyrightImage 'htdocs/c.png'
+# <Location />
+# SetHandler perl-script
+# PerlHandler Apache::Gallery
+# </Location>
+#</VirtualHost>
diff --git a/www-apps/Apache-Gallery/files/76_apache2-gallery.conf b/www-apps/Apache-Gallery/files/76_apache2-gallery.conf
new file mode 100644
index 000000000000..34dd36dbdbbc
--- /dev/null
+++ b/www-apps/Apache-Gallery/files/76_apache2-gallery.conf
@@ -0,0 +1,40 @@
+##### Apache::Gallery configuration
+#
+# This is actually a virtual host definition with mod_perl directives
+# It might be a very good idea to disable mod_autoindex in apache[2].conf
+#
+
+#<VirtualHost localhost>
+# ServerName localhost
+# DocumentRoot /var/www/localhost/htdocs/data/pictures/
+# ErrorLog /var/log/gallery-error_log
+# TransferLog /var/log/gallery-access_log
+# <IfDefine MODPERL2>
+# PerlSetVar GalleryTemplateDir '/var/www/localhost/Apache-Gallery/templates/default'
+# PerlSetVar GalleryInfo 'Picture Taken => DateTimeOriginal, Flash => Flash'
+# PerlSetVar GallerySizes '640 1024 1600 2272'
+# PerlSetVar GalleryThumbnailSize '100x75'
+## If you have a copyright overlay image set the location of it
+# PerlSetVar GalleryCopyrightImage 'htdocs/c.png'
+## If you use Apache2 set the following "PerlOptions" too
+# PerlOptions +GlobalRequest
+# <Location />
+# SetHandler modperl
+# PerlResponseHandler Apache::Gallery
+# Options -Indexes
+# AllowOverride AuthConfig
+# Order deny,allow
+# Allow from all
+# </Location>
+# </IfDefine>
+## Allow access to cache
+# <Directory /var/tmp/Apache-Gallery>
+# Options -ALL
+# AllowOverride None
+# Order deny,allow
+# Allow from all
+# </Directory>
+## Give Apache an idea of where to find icons and css
+# Alias /icons /var/www/localhost/icons
+# Alias /gallery.css /var/www/localhost/Apache-Gallery/templates/default/gallery.css
+#</VirtualHost>
diff --git a/www-apps/Apache-Gallery/files/digest-Apache-Gallery-0.9.1 b/www-apps/Apache-Gallery/files/digest-Apache-Gallery-0.9.1
new file mode 100644
index 000000000000..b3649f88c1f4
--- /dev/null
+++ b/www-apps/Apache-Gallery/files/digest-Apache-Gallery-0.9.1
@@ -0,0 +1 @@
+MD5 882e650e6fc3f059e84eca1564b5f32f Apache-Gallery-0.9.1.tar.gz 82230