summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/sparc-sources')
-rw-r--r--sys-kernel/sparc-sources/ChangeLog8
-rw-r--r--sys-kernel/sparc-sources/Manifest4
-rw-r--r--sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.282
-rw-r--r--sys-kernel/sparc-sources/sparc-sources-2.4.28.ebuild63
4 files changed, 75 insertions, 2 deletions
diff --git a/sys-kernel/sparc-sources/ChangeLog b/sys-kernel/sparc-sources/ChangeLog
index af30e540ba8a..4ed6b9c2e59d 100644
--- a/sys-kernel/sparc-sources/ChangeLog
+++ b/sys-kernel/sparc-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/sparc-sources
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/ChangeLog,v 1.66 2004/11/12 22:20:22 joker Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/ChangeLog,v 1.67 2004/11/23 17:23:46 joker Exp $
+
+*sparc-sources-2.4.28 (23 Nov 2004)
+
+ 23 Nov 2004; Christian Birchinger <joker@gentoo.org>
+ +sparc-sources-2.4.28.ebuild:
+ Version bump and squashfs 2.0 included
*sparc-sources-2.4.27-r3 (12 Nov 2004)
diff --git a/sys-kernel/sparc-sources/Manifest b/sys-kernel/sparc-sources/Manifest
index d0afdb9dcf9e..785b42b5d835 100644
--- a/sys-kernel/sparc-sources/Manifest
+++ b/sys-kernel/sparc-sources/Manifest
@@ -1,12 +1,14 @@
-MD5 aaa04af1a2f601a5e65ea26fbb17e270 ChangeLog 11213
+MD5 56baef2f4b85fad4e4cb4efc062e9267 ChangeLog 11379
MD5 6706a601c155869440dcb544e3759a04 metadata.xml 381
MD5 4cc47f39aea73c1cab1cb654d18388fd sparc-sources-2.4.27-r1.ebuild 2326
MD5 b9282567aca4fa6e33b416a61b7b39e5 sparc-sources-2.4.27.ebuild 2193
MD5 3bc17d498758e48554c5c330353c2724 sparc-sources-2.4.27-r2.ebuild 2325
MD5 e5d672d5e467217a7985bc07021759a4 sparc-sources-2.4.27-r3.ebuild 2458
+MD5 e2caf35475066dcecb5a0d9b75226c9b sparc-sources-2.4.28.ebuild 2194
MD5 258fd76f2e16645d1b67490aa7ca05ae files/digest-sparc-sources-2.4.27-r1 143
MD5 31df0f3fd794f3491bc4d33353e9d310 files/use-pte_alloc_one_fast-r1.patch 633
MD5 e7627db329b9e345d317fbd3bbd7c2b2 files/digest-sparc-sources-2.4.27-r2 143
+MD5 9e5e031b4149825faa227a3fc3969ef5 files/digest-sparc-sources-2.4.28 140
MD5 935f3a9c9a5209ad79a0cdbf9ca4b610 files/U1-hme-lockup.patch 263
MD5 e7627db329b9e345d317fbd3bbd7c2b2 files/digest-sparc-sources-2.4.27-r3 143
MD5 ff260e3c42d263d7ef1a579eaa38e5e6 files/gentoo-sources-2.4.27-binfmt_elf.patch 2237
diff --git a/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.28 b/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.28
new file mode 100644
index 000000000000..1eb12a43ef60
--- /dev/null
+++ b/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.28
@@ -0,0 +1,2 @@
+MD5 ac7735000d185bc7778c08288760a8a3 linux-2.4.28.tar.bz2 31064046
+MD5 2c298a2c8506a550a8420b261e992cd8 patches-2.4.28-sparc.tar.bz2 178262
diff --git a/sys-kernel/sparc-sources/sparc-sources-2.4.28.ebuild b/sys-kernel/sparc-sources/sparc-sources-2.4.28.ebuild
new file mode 100644
index 000000000000..4404703a0907
--- /dev/null
+++ b/sys-kernel/sparc-sources/sparc-sources-2.4.28.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/sparc-sources-2.4.28.ebuild,v 1.1 2004/11/23 17:23:46 joker Exp $
+
+IUSE="ultra1"
+
+# Kernel ebuilds using the kernel.eclass can remove any patch that you
+# do not want to apply by simply setting the KERNEL_EXCLUDE shell
+# variable to the string you want to exclude (for instance
+# KERNEL_EXCLUDE="grsecurity" would not patch any patches whose names match
+# *grsecurity*). Kernels are only tested in the default configuration, but
+# this may be useful if you know that a particular patch is causing a
+# conflict with a patch you personally want to apply, or some other
+# similar situation.
+
+ETYPE="sources"
+inherit kernel eutils
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+[ "$OKV" == "" ] && OKV="${PV}"
+
+EXTRAVERSION="-${PN/-*/}"
+[ ! "${PR}" == "r0" ] && EXTRAVERSION="${EXTRAVERSION}-${PR}"
+KV="${OKV}${EXTRAVERSION}"
+
+PATCH_VERSION="${KV}"
+
+# Documentation on the patches contained in this kernel will be installed
+# to /usr/share/doc/sparc-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="Full sources for the Gentoo Sparc Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ mirror://gentoo/patches-${PATCH_VERSION}.tar.bz2"
+
+S=${WORKDIR}/linux-${KV}
+KEYWORDS="~x86 -ppc ~sparc"
+SLOT="${KV}"
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die "Error moving kernel source tree to linux-${KV}"
+ cd ${PATCH_VERSION} || die "Unable to cd into ${PATCH_VERSION}"
+
+ kernel_src_unpack
+
+ # Patch the HME driver only on Ultra1 machines.
+ use ultra1 && epatch ${FILESDIR}/U1-hme-lockup.patch
+}
+
+pkg_postinst() {
+
+ kernel_pkg_postinst
+
+ # Display SUN Ultra 1 HME warning if it can be detected or if the machinetype is unknown.
+ if [ ! -r "/proc/openprom/name" -o "`cat /proc/openprom/name 2>/dev/null`" = "'SUNW,Ultra-1'" ]; then
+ einfo
+ einfo "For users with an Enterprise model Ultra 1 using the HME network interface,"
+ einfo "please emerge the kernel using the following command:"
+ einfo
+ einfo "USE=ultra1 emerge sparc-sources"
+ einfo
+ fi
+}