summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/hotplug')
-rw-r--r--sys-apps/hotplug/ChangeLog5
-rw-r--r--sys-apps/hotplug/Manifest20
-rw-r--r--sys-apps/hotplug/files/hotplug.rc6
3 files changed, 18 insertions, 13 deletions
diff --git a/sys-apps/hotplug/ChangeLog b/sys-apps/hotplug/ChangeLog
index 39156fa0dede..4237279eb11d 100644
--- a/sys-apps/hotplug/ChangeLog
+++ b/sys-apps/hotplug/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/hotplug
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hotplug/ChangeLog,v 1.50 2004/10/14 18:30:47 gregkh Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hotplug/ChangeLog,v 1.51 2004/10/22 04:57:54 wolf31o2 Exp $
+
+ 22 Oct 2004; Chris Gianelloni <wolf31o2@gentoo.org> files/hotplug.rc:
+ Added a check for livecd firmware tarball on disk.
14 Oct 2004; Greg Kroah-Hartman <gregkh@gentoo.org>
hotplug-20040923.ebuild:
diff --git a/sys-apps/hotplug/Manifest b/sys-apps/hotplug/Manifest
index 239aebe3cb06..587423143d20 100644
--- a/sys-apps/hotplug/Manifest
+++ b/sys-apps/hotplug/Manifest
@@ -1,22 +1,22 @@
-MD5 91774349ac277e7c558ba5f1ea2e5dbf ChangeLog 8629
-MD5 4683c6dc9a50b72986c12349ea35d22f hotplug-20040923.ebuild 2141
-MD5 0632c150f5e144e0d542b93aaf21e939 hotplug-20040920.ebuild 1837
MD5 34941ac9da8e298070b69145a9aefe52 hotplug-20040401.ebuild 1520
MD5 1f70c719d6a669a311cdc1d8fe804866 hotplug-20030805-r2.ebuild 1882
-MD5 74aabd09369956f95593d208d6b38adb hotplug-20030805-r3.ebuild 1922
+MD5 4683c6dc9a50b72986c12349ea35d22f hotplug-20040923.ebuild 2141
MD5 fe6609fa5c00549e997a01bb0b2d487c hotplug-20040105.ebuild 1719
+MD5 0632c150f5e144e0d542b93aaf21e939 hotplug-20040920.ebuild 1837
+MD5 cc18cdd30b5cfe7d256ceb671f60b816 ChangeLog 8757
MD5 075d5a933d6175160a02ddf15bd4f454 metadata.xml 260
-MD5 2fdc27ccc01d4fca5e045531e0c96eb7 files/hotplug.rc.empty 878
+MD5 74aabd09369956f95593d208d6b38adb hotplug-20030805-r3.ebuild 1922
+MD5 f9303a2467242ed310370ddcd63414b6 files/digest-hotplug-20040105 151
+MD5 5be3a96d844a1f0db96e2268b94f6094 files/digest-hotplug-20040401 69
MD5 6038bb8c3af43a0e6f0aa876e4307df6 files/digest-hotplug-20040920 69
MD5 8cecfadba72f89724706c45119b15e49 files/digest-hotplug-20040923 69
+MD5 2fdc27ccc01d4fca5e045531e0c96eb7 files/hotplug.rc.empty 878
+MD5 9f13f3363b85caac03bfb623c652b4fa files/kernel-26-fix.patch 816
MD5 d41d8cd98f00b204e9800998ecf8427e files/isapnp.rc.empty 0
+MD5 1bd9ddb0959318fe56dec239c8265fb1 files/usb.confd 291
MD5 a3281f5b866be688f79d9a46d060180a files/digest-hotplug-20030805-r2 151
MD5 a3281f5b866be688f79d9a46d060180a files/digest-hotplug-20030805-r3 151
-MD5 f9303a2467242ed310370ddcd63414b6 files/digest-hotplug-20040105 151
MD5 d8a0d8878d8904a779bda401d86268b1 files/firmware.agent 1188
MD5 7c4681458effb34f299cbc4b9245098c files/hotplug.functions.patch 522
-MD5 9e8f03a1ff1b97ad47b38b337d13064f files/hotplug.rc 836
-MD5 9f13f3363b85caac03bfb623c652b4fa files/kernel-26-fix.patch 816
+MD5 a43c83992e1dfe7cab4924a9a248e031 files/hotplug.rc 957
MD5 92547b2263d5423d874565504d2324f7 files/usb.agent.diff 886
-MD5 1bd9ddb0959318fe56dec239c8265fb1 files/usb.confd 291
-MD5 5be3a96d844a1f0db96e2268b94f6094 files/digest-hotplug-20040401 69
diff --git a/sys-apps/hotplug/files/hotplug.rc b/sys-apps/hotplug/files/hotplug.rc
index 376aa4ae102e..030d34381b39 100644
--- a/sys-apps/hotplug/files/hotplug.rc
+++ b/sys-apps/hotplug/files/hotplug.rc
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hotplug/files/hotplug.rc,v 1.9 2004/07/15 00:43:30 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hotplug/files/hotplug.rc,v 1.10 2004/10/22 04:57:54 wolf31o2 Exp $
depend() {
need modules
@@ -16,7 +16,9 @@ checkconfig() {
start() {
checkconfig || return 1
-
+ [ -e /usr/lib/hotplug/firmware.tar.bz2 ] && \
+ tar xjf /usr/lib/hotplug/firmware.tar.bz2 -C \
+ /usr/lib/hotplug/firmware
for RC in /etc/hotplug/*.rc
do
NAME=`basename $RC .rc`