summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/validation')
-rw-r--r--sci-chemistry/validation/ChangeLog10
-rw-r--r--sci-chemistry/validation/files/README14
-rw-r--r--sci-chemistry/validation/files/README-source150
-rw-r--r--sci-chemistry/validation/files/digest-validation-6.21
-rw-r--r--sci-chemistry/validation/files/digest-validation-8.0611
-rw-r--r--sci-chemistry/validation/files/respect-cflags-and-fix-install.patch167
-rw-r--r--sci-chemistry/validation/files/respect-flags-and-add-gcc4.patch302
-rw-r--r--sci-chemistry/validation/validation-6.2.ebuild53
-rw-r--r--sci-chemistry/validation/validation-8.061.ebuild52
9 files changed, 394 insertions, 356 deletions
diff --git a/sci-chemistry/validation/ChangeLog b/sci-chemistry/validation/ChangeLog
index bcc3f5033059..0545ed93e672 100644
--- a/sci-chemistry/validation/ChangeLog
+++ b/sci-chemistry/validation/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-chemistry/validation
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/validation/ChangeLog,v 1.2 2005/12/19 01:28:25 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/validation/ChangeLog,v 1.3 2005/12/20 04:12:59 spyderous Exp $
+
+*validation-6.2 (20 Dec 2005)
+
+ 20 Dec 2005; Donnie Berkholz <spyderous@gentoo.org>; +files/README,
+ +files/README-source, +files/respect-cflags-and-fix-install.patch,
+ -files/respect-flags-and-add-gcc4.patch, +validation-6.2.ebuild,
+ -validation-8.061.ebuild:
+ Add a fixed version; works with other RCSB apps and libraries.
19 Dec 2005; Donnie Berkholz <spyderous@gentoo.org>;
validation-8.061.ebuild:
diff --git a/sci-chemistry/validation/files/README b/sci-chemistry/validation/files/README
new file mode 100644
index 000000000000..a0d2fbc07b11
--- /dev/null
+++ b/sci-chemistry/validation/files/README
@@ -0,0 +1,14 @@
+The PDB Validation Suite is a set of applications programs that create
+validation reports about 3D structure data. It is designed to work
+with files in mmCIF or PDB format.
+
+This is the same software used in the Validation step of ADIT (AutoDep
+Input Tool) at http://pdb.rutgers.edu/adit/.
+
+Note: Binary distribution of this tool contains an additional submodule
+"procheck", which does additional structure checking. This submodule is
+not part of the source distribution. Therefore the users are advised to
+use the binary distribution, if possible.
+
+Refer to README-source or README-binary, depending on the distribution, for
+details on installation, build, demos and application usage.
diff --git a/sci-chemistry/validation/files/README-source b/sci-chemistry/validation/files/README-source
new file mode 100644
index 000000000000..28ed96b06139
--- /dev/null
+++ b/sci-chemistry/validation/files/README-source
@@ -0,0 +1,150 @@
+ Installation and Usage Notes for the Validation Application
+ (Source Distribution)
+
+Note: It is highly recommended to utilize binary distribution,
+since it contains an additional submodule, called PROCHECK, which does more
+structure checking. This source distribution does not contain PROCHECK.
+
+1. Installation
+
+a. Uncompress and unbundle the distribution using the following command:
+
+ zcat validation-vX.XXX-XXX.tar.gz | tar -xf -
+
+ The result of this command is a subdirectory validation-vX.XXX-XXX in the
+ current directory. It contains subdirectories of various source modules
+ and the following items important for the user:
+
+ bin - subdirectory in which the application executable "validation-v8"
+ will be placed after the build process.
+ data - subdirectory that contains some data files needed by the
+ application.
+
+
+b. Set up the environment variables.
+
+ - Define the RCSBROOT environment variable to point to the installation
+ directory. Note that the RCSBROOT environment is also used for other RCSB
+ applications like ADIT and PDB_EXTRACT. If all these applications are
+ running on a computer, the last instance of setenv command will define the
+ environment. Thus, set the environment at the command line as follows,
+ just prior to running the application. Assuming that the installation
+ directory is
+
+ /home/username/validation-vX.XXX-XXX, execute in the shell:
+
+ For C shell users:
+ setenv RCSBROOT /home/username/validation-vX.XXX-XXX
+
+ For Bourne shell users:
+ RCSBROOT=/home/username/validation-vX.XXX-XXX; export RCSBROOT
+
+ - Add "bin" subdirectory to the PATH environment variable.
+ Execute in the shell:
+
+ For C shell users:
+ setenv PATH "$RCSBROOT/bin:"$PATH
+
+ For Bourne shell users:
+ PATH="$RCSBROOT/bin:"$PATH; export PATH
+
+
+2. Building the Application
+
+a. Position in the validation-vX.XXX-XXX directory and run "make" command:
+
+ cd validation-vX.XXX-XXX
+ make
+
+ The application executable "validation-v8" will be placed in the "bin"
+ subdirectory.
+
+
+ NOTE: The users who are working on Sun platform are strongly advised to
+ check the compiler flags in etc/make.platform.sunos5 file. Depending on
+ the compiler version, users may be required to make modifications to those
+ compiler flags.
+
+b. Make binary data from ASCII data
+
+ - Position in the validation-vX.XXX-XXX directory and run "make" command as
+ follows:
+
+ make binary
+
+ This command will create certain binary data files, using the ASCII data
+ files in data/ascii directory. The resulting files are stored in
+ data/binary directory. Note that it may take several minutes for this
+ step to complete. This step must be executed before the tool can be
+ utilized.
+
+
+3. Application Usage Notes
+
+Usage:
+
+For mmCIF files (Please note, only mmCIF format files downloaded from the PDB
+or generated by PDB_EXTRACT should be used):
+
+ validation-v8 -f file_name -o 2 -adit -exchange -public
+
+For PDB files:
+
+ validation-v8 -f file_name -o 0 -adit
+
+
+For example, to create reports for a file in mmCIF format named 1xyz.cif
+type:
+
+ validation-v8 -f 1xyz.cif -o 2 -adit -exchange -public
+
+Output:
+
+The names of the output files begin with the root identifier <ID>,
+which is followed by an extension that indicates the file type.
+
+For a PDB format file, the program converts the file name without
+extension into uppercase for the <ID>. For an mmCIF format file, the program
+uses data block identifier as the <ID>.
+
+The application creates the following files:
+
+A. <ID>.letter: a text file that contains a summary validation letter.
+
+B. <ID>.ps: a PostScript file that contains molecular graphics of the structure.
+For crystal structures, this includes a view of the asymmetric unit
+and crystal packing. If the mmCIF file was validated and the biological unit
+of the entry is either larger or smaller than the asymmetric unit, and the
+struct_biol_gen category was appropriately completed in the mmCIF
+file, then a view of the biological unit(s) will be included.
+
+For NMR ensemble structures, a view of the first model and the ensemble
+of all models is included. If the NMR entry contains one model, a view
+of the model will be included.
+
+NUCHECK output: If the structure contains nucleic acids, the <ID>.ps file
+also includes plots describing the geometry, torsion, and base morphology of
+the nucleic acids generated by the program NUCHECK.
+
+C. <ID>.html: This html file is an Atlas summary containing the following:
+
+For all structures:
+The sequence of the residues in each chain (from entity_poly for a mmCIF file,
+from SEQRES for a PDB file, or from the coordinates if entity_poly or SEQRES
+are not provided).
+Citation information (if provided).
+Refinement information (if provided).
+
+For crystal structures, additional information is listed:
+Space group and cell constants.
+Crystallization conditions (if provided).
+Refinement information (if provided).
+
+3. REFERENCES
+
+NUCHECK:
+Zukang Feng, John Westbrook, Helen M. Berman. NUCheck: Rutgers University,
+New Brunswick, NJ; 1998. Report No.: NDB-407.
+
+
+
diff --git a/sci-chemistry/validation/files/digest-validation-6.2 b/sci-chemistry/validation/files/digest-validation-6.2
new file mode 100644
index 000000000000..abb82a2a5747
--- /dev/null
+++ b/sci-chemistry/validation/files/digest-validation-6.2
@@ -0,0 +1 @@
+MD5 8023ecb2deb2b4cd6fcc2e8f32e8b21a pdb-extract-v1.700-prod-src.tar.gz 9081548
diff --git a/sci-chemistry/validation/files/digest-validation-8.061 b/sci-chemistry/validation/files/digest-validation-8.061
deleted file mode 100644
index b9c84095bad7..000000000000
--- a/sci-chemistry/validation/files/digest-validation-8.061
+++ /dev/null
@@ -1 +0,0 @@
-MD5 889197a71e0e2048046fb14ac9201fdc validation-v8.061-prod-src.tar.gz 5477579
diff --git a/sci-chemistry/validation/files/respect-cflags-and-fix-install.patch b/sci-chemistry/validation/files/respect-cflags-and-fix-install.patch
new file mode 100644
index 000000000000..623efd194fb9
--- /dev/null
+++ b/sci-chemistry/validation/files/respect-cflags-and-fix-install.patch
@@ -0,0 +1,167 @@
+diff -ur -x Makefile.platform pdb-extract-v1.700-prod-src.orig/etc/make.platform.gnu3 pdb-extract-v1.700-prod-src/etc/make.platform.gnu3
+--- pdb-extract-v1.700-prod-src.orig/etc/make.platform.gnu3 2005-12-19 00:32:21.000000000 -0800
++++ pdb-extract-v1.700-prod-src/etc/make.platform.gnu3 2005-12-19 00:33:04.000000000 -0800
+@@ -6,6 +6,8 @@
+ ##
+ ##########################################################################
+
++LIBDIR= /usr/lib
++
+ #-----Lexer and Parser section-------------------------------------------#
+
+ # Lexer executable
+@@ -89,7 +91,7 @@
+ DEFINES=$(GDEFINES) $(LDEFINES)
+
+ ## Global include directories
+-GINCLUDES=
++GINCLUDES= -I/usr/include/rcsb
+
+ # Collect all include directories from global include directories and
+ # include directories specified in module makefile
+@@ -107,8 +109,8 @@
+ C_WARNINGS=$(WARNINGS)
+
+ # C compiler flags
+-CFLAGS=$(OPT) $(ABI) $(ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) $(INCLUDES)
+-CFLAGS_NONANSI=$(OPT) $(ABI) $(NON_ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) \
++CFLAGS=$(C_OPT) $(ABI) $(ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) $(INCLUDES)
++CFLAGS_NONANSI=$(C_OPT) $(ABI) $(NON_ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) \
+ $(INCLUDES)
+
+ ## C++ compiler
+@@ -128,9 +130,9 @@
+ EXT=C
+
+ # C++ compiler flags
+-C++FLAGS=$(OPT) $(ABI) $(ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) $(DEFINES) \
++C++FLAGS=$(CCC_OPT) $(ABI) $(ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) $(DEFINES) \
+ $(INCLUDES)
+-C++FLAGS_NONANSI=$(OPT) $(ABI) $(NON_ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) \
++C++FLAGS_NONANSI=$(CCC_OPT) $(ABI) $(NON_ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) \
+ $(DEFINES) $(INCLUDES)
+ # C++FLAGS_RELAXED should be set to avoid warnings reported by third party
+ # source code that is not maintained by PDB
+@@ -144,7 +146,7 @@
+ F77=f77
+
+ # Fortran compiler flags
+-FFLAGS=-O -u
++FFLAGS=$(F_OPT)
+
+ # Additional Fortran libraries
+ F77LIBS=
+diff -ur -x Makefile.platform pdb-extract-v1.700-prod-src.orig/etc/make.platform.gnu4 pdb-extract-v1.700-prod-src/etc/make.platform.gnu4
+--- pdb-extract-v1.700-prod-src.orig/etc/make.platform.gnu4 2005-12-19 00:32:21.000000000 -0800
++++ pdb-extract-v1.700-prod-src/etc/make.platform.gnu4 2005-12-19 00:33:04.000000000 -0800
+@@ -6,6 +6,8 @@
+ ##
+ ##########################################################################
+
++LIBDIR= /usr/lib
++
+ #-----Lexer and Parser section-------------------------------------------#
+
+ # Lexer executable
+@@ -34,7 +36,7 @@
+
+ # WARNINGS_AS_ERRORS defines flags to instruct all compilers to treat all
+ # warnings as errors.
+-WARNINGS_AS_ERRORS=-Werror
++WARNINGS_AS_ERRORS=
+
+ # ALL_WARNINGS defines flags to instruct all compilers to report all
+ # warnings.
+@@ -90,7 +92,7 @@
+ DEFINES=$(GDEFINES) $(LDEFINES)
+
+ ## Global include directories
+-GINCLUDES=
++GINCLUDES= -I/usr/include/rcsb
+
+ # Collect all include directories from global include directories and
+ # include directories specified in module makefile
+@@ -108,8 +110,8 @@
+ C_WARNINGS=$(WARNINGS)
+
+ # C compiler flags
+-CFLAGS=$(OPT) $(ABI) $(ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) $(INCLUDES)
+-CFLAGS_NONANSI=$(OPT) $(ABI) $(NON_ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) \
++CFLAGS=$(C_OPT) $(ABI) $(ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) $(INCLUDES)
++CFLAGS_NONANSI=$(C_OPT) $(ABI) $(NON_ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) \
+ $(INCLUDES)
+
+ ## C++ compiler
+@@ -129,9 +131,9 @@
+ EXT=C
+
+ # C++ compiler flags
+-C++FLAGS=$(OPT) $(ABI) $(ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) $(DEFINES) \
++C++FLAGS=$(CCC_OPT) $(ABI) $(ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) $(DEFINES) \
+ $(INCLUDES)
+-C++FLAGS_NONANSI=$(OPT) $(ABI) $(NON_ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) \
++C++FLAGS_NONANSI=$(CCC_OPT) $(ABI) $(NON_ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) \
+ $(DEFINES) $(INCLUDES)
+ # C++FLAGS_RELAXED should be set to avoid warnings reported by third party
+ # source code that is not maintained by PDB
+@@ -145,7 +147,7 @@
+ F77=f77
+
+ # Fortran compiler flags
+-FFLAGS=-O -u
++FFLAGS=$(F_OPT)
+
+ # Additional Fortran libraries
+ F77LIBS=
+diff -ur -x Makefile.platform pdb-extract-v1.700-prod-src.orig/Makefile pdb-extract-v1.700-prod-src/Makefile
+--- pdb-extract-v1.700-prod-src.orig/Makefile 2005-12-19 00:32:21.000000000 -0800
++++ pdb-extract-v1.700-prod-src/Makefile 2005-12-19 00:33:04.000000000 -0800
+@@ -22,10 +22,7 @@
+
+ DATADIRS = data pdb-extract-data
+
+-LIBDIRS = misclib-v2.1 regex-v2.1 ciflib-common-v3.02 cifobj-common-v4.04 \
+- btree-obj-v3.1 cif-table-obj-v6.1 cifparse-obj-v6.3 \
+- htmllib-v3.1 connect-v2.2 filterlib-v8.2 $(EXTRACT) \
+- validation-v6.2 maxit-v8.2
++LIBDIRS = validation-v6.2
+
+ all: compile
+
+@@ -60,7 +57,7 @@
+ echo "------------------------------------------------------------"; \
+ echo "**** Making $$libdir ****"; \
+ echo "------------------------------------------------------------"; \
+- (cd $$libdir && $(MAKE) -f $(MAKEFILE) "OPT=-O" install) || exit 1; \
++ (cd $$libdir && $(MAKE) -f $(MAKEFILE) C_OPT="${CFLAGS}" CCC_OPT="${CXXFLAGS}" F_OPT="${FFLAGS}" install) || exit 1; \
+ done
+
+ binary:
+diff -ur -x Makefile.platform pdb-extract-v1.700-prod-src.orig/validation-v6.2/Makefile pdb-extract-v1.700-prod-src/validation-v6.2/Makefile
+--- pdb-extract-v1.700-prod-src.orig/validation-v6.2/Makefile 2005-12-19 00:32:21.000000000 -0800
++++ pdb-extract-v1.700-prod-src/validation-v6.2/Makefile 2005-12-19 00:33:43.000000000 -0800
+@@ -35,15 +35,15 @@
+ #----------------------------------------------------------------------------
+ # Target definitions.
+ #----------------------------------------------------------------------------
+-LIBS = $(LIBINSTDIR)/libndbfilter.a \
+- $(LIBINSTDIR)/libconnect.a \
+- $(LIBINSTDIR)/libciffileobj.a \
+- $(LIBINSTDIR)/libcifobj.a \
+- $(LIBINSTDIR)/libistable.a \
+- $(LIBINSTDIR)/libregex.a \
+- $(LIBINSTDIR)/libtblindex.a \
+- $(LIBINSTDIR)/libcifstr.a \
+- $(LIBINSTDIR)/libndbmisc.a
++LIBS = $(LIBDIR)/libndbfilter.a \
++ $(LIBDIR)/libconnect.a \
++ $(LIBDIR)/libciffileobj.a \
++ $(LIBDIR)/libcifobj.a \
++ $(LIBDIR)/libistable.a \
++ $(LIBDIR)/libregex.a \
++ $(LIBDIR)/libtblindex.a \
++ $(LIBDIR)/libcifstr.a \
++ $(LIBDIR)/libndbmisc.a
+
+ NDBLIB = $(LIB)/libvalidation.a
+
diff --git a/sci-chemistry/validation/files/respect-flags-and-add-gcc4.patch b/sci-chemistry/validation/files/respect-flags-and-add-gcc4.patch
deleted file mode 100644
index e1304f68c83f..000000000000
--- a/sci-chemistry/validation/files/respect-flags-and-add-gcc4.patch
+++ /dev/null
@@ -1,302 +0,0 @@
-diff -urN -x cifparse-obj-v6.3 -x make.log -x Makefile.platform validation-v8.061-prod-src.orig/etc/make.platform.gnu3 validation-v8.061-prod-src/etc/make.platform.gnu3
---- validation-v8.061-prod-src.orig/etc/make.platform.gnu3 2004-08-20 08:26:48.000000000 -0700
-+++ validation-v8.061-prod-src/etc/make.platform.gnu3 2005-12-18 16:34:18.000000000 -0800
-@@ -107,8 +107,8 @@
- C_WARNINGS=$(WARNINGS)
-
- # C compiler flags
--CFLAGS=$(OPT) $(ABI) $(ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) $(INCLUDES)
--CFLAGS_NONANSI=$(OPT) $(ABI) $(NON_ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) \
-+CFLAGS=$(C_OPT) $(ABI) $(ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) $(INCLUDES)
-+CFLAGS_NONANSI=$(C_OPT) $(ABI) $(NON_ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) \
- $(INCLUDES)
-
- ## C++ compiler
-@@ -125,12 +125,12 @@
- # This variable specifies how to compile the C code. If it is set to C,
- # that indicates that C code will be compiled with the C++ compiler.
- # Otherwise it will be compiled with C compiler.
--EXT=C
-+EXT=c
-
- # C++ compiler flags
--C++FLAGS=$(OPT) $(ABI) $(ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) $(DEFINES) \
-+C++FLAGS=$(CCC_OPT) $(ABI) $(ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) $(DEFINES) \
- $(INCLUDES)
--C++FLAGS_NONANSI=$(OPT) $(ABI) $(NON_ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) \
-+C++FLAGS_NONANSI=$(CCC_OPT) $(ABI) $(NON_ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) \
- $(DEFINES) $(INCLUDES)
- # C++FLAGS_RELAXED should be set to avoid warnings reported by third party
- # source code that is not maintained by PDB
-@@ -144,7 +144,7 @@
- F77=f77
-
- # Fortran compiler flags
--FFLAGS=-O -u
-+FFLAGS=$(F_OPT)
-
- # Additional Fortran libraries
- F77LIBS=
-diff -urN -x cifparse-obj-v6.3 -x make.log -x Makefile.platform validation-v8.061-prod-src.orig/etc/make.platform.gnu4 validation-v8.061-prod-src/etc/make.platform.gnu4
---- validation-v8.061-prod-src.orig/etc/make.platform.gnu4 1969-12-31 16:00:00.000000000 -0800
-+++ validation-v8.061-prod-src/etc/make.platform.gnu4 2005-12-18 16:34:12.000000000 -0800
-@@ -0,0 +1,202 @@
-+##########################################################################
-+##
-+## File: make.plaform.gnu3
-+## Purpose: This file is a Linux platform makefile that supports GNU 3.x
-+## compiler suite.
-+##
-+##########################################################################
-+
-+#-----Lexer and Parser section-------------------------------------------#
-+
-+# Lexer executable
-+LEX=flex
-+
-+# Lexer flags
-+LEXFLAGS=-Cfr -L
-+
-+# Parser executable
-+YACC=bison
-+
-+# Parser flags
-+YACCFLAGS=-d -v -l
-+
-+#------------------------------------------------------------------------#
-+
-+#-----Compilers section--------------------------------------------------#
-+
-+## ABI
-+## This part defines an application binary interface to be used with the
-+## compiler suite.
-+ABI=
-+
-+## Warnings flags
-+## This part defines warnings related flags
-+
-+# WARNINGS_AS_ERRORS defines flags to instruct all compilers to treat all
-+# warnings as errors.
-+
-+# ALL_WARNINGS defines flags to instruct all compilers to report all
-+# warnings.
-+ALL_WARNINGS=-Wall
-+
-+# NO_DEPRECATED defines flags to instruct C++ compiler not to report
-+# warnings about deprecated constructs still used in C++ code.
-+NO_DEPRECATED=-Wno-deprecated
-+
-+# Collect all general warnings related flags
-+WARNINGS=$(WARNINGS_AS_ERRORS) $(ALL_WARNINGS)
-+
-+## Platform specifics
-+## This part defines platform specific information
-+
-+# Endianess.
-+# Should be defined only for big endian platforms. Otherwise
-+# it must be left undefined, which indicates little endian platform.
-+#ENDIANESS=-DBIG_ENDIAN_PLATFORM
-+
-+# OS indicator. Should be defined only if SunOS is the platform
-+#PLATFORM_OS=-DSUN_OS
-+
-+# Collect all platform related flags
-+PLATFORM=$(ENDIANESS) $(PLATFORM_OS)
-+
-+## Compiler capabilities/restrictions related defines
-+## This part defines variables based on the capabilities or restrictions
-+## of the compiler suite used on the platform.
-+
-+# If STRCASECMP_OPTION is defined, that indicates that the compiler
-+# suite/supporting libraries support strcasecmp() function.
-+STRCASECMP_OPTION=-DHAVE_STRCASECMP
-+
-+# If INCL_TEMPLATE_SRC_OPTION is defined, that indicates that
-+# compiler must include template method definition in template
-+# header files in order to properly compile templates.
-+INCL_TEMPLATE_SRC_OPTION=-DINCL_TEMPLATE_SRC
-+
-+# If PLACEMENT_NEW_OPTION is defined, that indicates that the compiler
-+# suite/supporting libraries support placement new/delete operators.
-+PLACEMENT_NEW_OPTION=-DHAVE_PLACEMENT_NEW
-+
-+# Collect all compiler capabilities/restrictions
-+COMPILER=$(STRCASECMP_OPTION) $(INCL_TEMPLATE_SRC_OPTION) \
-+ $(PLACEMENT_NEW_OPTION)
-+
-+# Collect all global defines
-+GDEFINES=$(PLATFORM) $(COMPILER)
-+
-+# Collect all defines from global defines and defines specified in
-+# module makefile
-+DEFINES=$(GDEFINES) $(LDEFINES)
-+
-+## Global include directories
-+GINCLUDES=
-+
-+# Collect all include directories from global include directories and
-+# include directories specified in module makefile
-+INCLUDES=$(LINCLUDES) $(GINCLUDES)
-+
-+## C compiler
-+## This part defines C compiler information
-+
-+# C compiler executable
-+CC=gcc
-+
-+# C compiler ANSI/NON-ANSI flags
-+ANSI_C_FLAG=-ansi
-+NON_ANSI_C_FLAG=
-+C_WARNINGS=$(WARNINGS)
-+
-+# C compiler flags
-+CFLAGS=$(C_OPT) $(ABI) $(ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) $(INCLUDES)
-+CFLAGS_NONANSI=$(C_OPT) $(ABI) $(NON_ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) \
-+ $(INCLUDES)
-+
-+## C++ compiler
-+## This part defines C++ compiler information
-+
-+# C++ compiler executable
-+CCC=g++
-+
-+# C++ compiler ANSI/NON-ANSI flags
-+ANSI_C_PLUS_FLAG=-ansi
-+NON_ANSI_C_PLUS_FLAG=-traditional-cpp
-+C_PLUS_WARNINGS=$(WARNINGS) $(NO_DEPRECATED)
-+
-+# This variable specifies how to compile the C code. If it is set to C,
-+# that indicates that C code will be compiled with the C++ compiler.
-+# Otherwise it will be compiled with C compiler.
-+EXT=c
-+
-+# C++ compiler flags
-+C++FLAGS=$(CCC_OPT) $(ABI) $(ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) $(DEFINES) \
-+ $(INCLUDES)
-+C++FLAGS_NONANSI=$(CCC_OPT) $(ABI) $(NON_ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) \
-+ $(DEFINES) $(INCLUDES)
-+# C++FLAGS_RELAXED should be set to avoid warnings reported by third party
-+# source code that is not maintained by PDB
-+C++FLAGS_RELAXED=$(OPT) $(ABI) $(ANSI_C_PLUS_FLAG) $(NO_DEPRECATED) $(DEFINES) \
-+ $(INCLUDES)
-+
-+## Fortran compiler
-+## This part defines Fortran compiler information
-+
-+# Fortran compiler executable
-+F77=gfortran
-+
-+# Fortran compiler flags
-+FFLAGS=$(F_OPT)
-+
-+# Additional Fortran libraries
-+F77LIBS=
-+
-+#------------------------------------------------------------------------#
-+
-+#-----Linkers section----------------------------------------------------#
-+
-+# Static linking option. If not defined, dynamic linking is used.
-+STATIC_LINKING=-static
-+
-+# Linker flags
-+LDFLAGS=$(ABI) -w $(STATIC_LINKING)
-+LDFLAGS_NO_STATIC=$(ABI) -w
-+
-+# Fortran linker
-+F77_LINKER=gfortran
-+
-+#------------------------------------------------------------------------#
-+
-+#-----Archiver section---------------------------------------------------#
-+
-+# Archiver executable
-+AR=ar
-+
-+# Archiver flags
-+AR_GETFLAGS=xv
-+AR_PUTFLAGS=rcvs
-+
-+#------------------------------------------------------------------------#
-+
-+#-----Ranlib-------------------------------------------------------------#
-+
-+RANLIB=true
-+
-+#------------------------------------------------------------------------#
-+
-+#-----Installer----------------------------------------------------------#
-+
-+INSTALL=../etc/cifinstall
-+INSTALLOPTS=-m 0444
-+
-+#------------------------------------------------------------------------#
-+
-+#-----Stripper-----------------------------------------------------------#
-+
-+STRIP=strip
-+
-+#------------------------------------------------------------------------#
-+
-+#-----Shell--------------------------------------------------------------#
-+
-+SHELL=/bin/sh
-+
-+#------------------------------------------------------------------------#
-diff -urN -x cifparse-obj-v6.3 -x make.log -x Makefile.platform validation-v8.061-prod-src.orig/etc/platform.sh validation-v8.061-prod-src/etc/platform.sh
---- validation-v8.061-prod-src.orig/etc/platform.sh 2004-08-20 08:26:48.000000000 -0700
-+++ validation-v8.061-prod-src/etc/platform.sh 2005-12-18 15:38:53.000000000 -0800
-@@ -39,23 +39,31 @@
- ;;
-
- Linux)
--# Check if it is GCC version 3.x
-- gcc_ver=`gcc --version | grep -e " 3\."`
-+# Check if it is GCC version 4.x
-+ gcc_ver=`gcc --version | grep -e " 4\."`
- if [[ -z $gcc_ver ]]
- then
--# It is not GCC version 3.x. Check if it is GCC version 2.x
-- gcc_ver=`gcc --version | grep -e "2\."`
-+# It is not GCC version 4.x. Check if it is GCC version 3.x
-+ gcc_ver=`gcc --version | grep -e " 3\."`
- if [[ -z $gcc_ver ]]
- then
--# It is not GCC version 2.x either. Production can not be compiled.
-- sysid="unknown"
-+# It is not GCC version 3.x. Check if it is GCC version 2.x
-+ gcc_ver=`gcc --version | grep -e "2\."`
-+ if [[ -z $gcc_ver ]]
-+ then
-+# It is not GCC version 2.x either. Production can not be compiled.
-+ sysid="unknown"
-+ else
-+# It is GCC version 2.x
-+ sysid="gnu2"
-+ fi
- else
--# It is GCC version 2.x
-- sysid="gnu2"
-+# It is GCC version 3.x
-+ sysid="gnu3"
- fi
- else
--# It is GCC version 3.x
-- sysid="gnu3"
-+# It is GCC version 4.x
-+ sysid="gnu4"
- fi
- ;;
-
-diff -urN -x cifparse-obj-v6.3 -x make.log -x Makefile.platform validation-v8.061-prod-src.orig/Makefile validation-v8.061-prod-src/Makefile
---- validation-v8.061-prod-src.orig/Makefile 2004-08-20 08:26:46.000000000 -0700
-+++ validation-v8.061-prod-src/Makefile 2005-12-18 16:32:50.000000000 -0800
-@@ -59,7 +59,7 @@
- echo "------------------------------------------------------------"; \
- echo "**** Making $$libdir ****"; \
- echo "------------------------------------------------------------"; \
-- (cd $$libdir && $(MAKE) -f $(MAKEFILE) "OPT=-O" install) || exit 1; \
-+ (cd $$libdir && $(MAKE) -f $(MAKEFILE) C_OPT="${CFLAGS}" CCC_OPT="${CXXFLAGS}" F_OPT="${FFLAGS}" install) || exit 1; \
- done
-
- binary:
diff --git a/sci-chemistry/validation/validation-6.2.ebuild b/sci-chemistry/validation/validation-6.2.ebuild
new file mode 100644
index 000000000000..3072f54ce0ee
--- /dev/null
+++ b/sci-chemistry/validation/validation-6.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/validation/validation-6.2.ebuild,v 1.1 2005/12/20 04:12:59 spyderous Exp $
+
+inherit eutils toolchain-funcs multilib
+
+# pdb-extract includes a newer 'validation' than 'validation' tarball does,
+# and the filterlib from pdb-extract is incompatible with the validation tarball
+MY_PN="pdb-extract"
+MY_PV="1.700"
+MY_P="${MY_PN}-v${MY_PV}-prod-src"
+DESCRIPTION="Set of tools used by the PDB for processing and checking structure data"
+HOMEPAGE="http://sw-tools.pdb.org/apps/VAL/index.html"
+SRC_URI="http://sw-tools.pdb.org/apps/PDB_EXTRACT/${MY_P}.tar.gz"
+LICENSE="PDB"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+RDEPEND="sci-libs/rcsb-data"
+DEPEND="${RDEPEND}
+ sci-chemistry/pdb-extract"
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/respect-cflags-and-fix-install.patch
+ cd ${S}
+
+ # Get rid of unneeded directories, to make sure we use system files
+ ebegin "Deleting redundant directories"
+ rm -rf btree-obj* ciflib-common* cifobj-common* cif-table-obj* maxit* \
+ misclib* regex* pdb-extract*
+ eend
+
+ sed -i \
+ -e "s:^\(CCC=\).*:\1$(tc-getCXX):g" \
+ -e "s:^\(GINCLUDE=\).*:\1-I${ROOT}usr/include/rcsb:g" \
+ -e "s:^\(LIBDIR=\).*:\1${ROOT}usr/$(get_libdir):g" \
+ ${S}/etc/make.*
+}
+
+src_compile() {
+ emake || die "make failed"
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe bin/*
+ dolib.a lib/*
+ insinto /usr/include/rcsb
+ doins include/*
+ dodoc ${FILESDIR}/README*
+}
diff --git a/sci-chemistry/validation/validation-8.061.ebuild b/sci-chemistry/validation/validation-8.061.ebuild
deleted file mode 100644
index d341a51110d0..000000000000
--- a/sci-chemistry/validation/validation-8.061.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/validation/validation-8.061.ebuild,v 1.2 2005/12/19 01:28:25 spyderous Exp $
-
-inherit eutils toolchain-funcs
-
-MY_P="${PN}-v${PV}-prod-src"
-DESCRIPTION="Set of tools used by the PDB for processing and checking structure data"
-HOMEPAGE="http://sw-tools.pdb.org/apps/VAL/index.html"
-SRC_URI="http://sw-tools.pdb.org/apps/VAL/${MY_P}.tar.gz"
-LICENSE="PDB"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE=""
-RDEPEND=""
-DEPEND="${RDEPEND}"
-S="${WORKDIR}/${MY_P}"
-
-src_unpack() {
- unpack ${A}
- epatch ${FILESDIR}/respect-flags-and-add-gcc4.patch
- cd ${S}
-
- sed -i \
- -e "s:^\(CCC=\).*:\1$(tc-getCXX):g" \
- ${S}/etc/make.*
-}
-
-src_compile() {
- emake || die "make failed"
- emake binary || die "make binary failed"
-}
-
-src_install() {
- exeinto /usr/bin
- doexe bin/*
- insinto /usr/lib/rcsb/data/binary
- doins data/binary/*
- insinto /usr/lib/rcsb/data/ascii
- doins data/ascii/*
-
- echo "RCSBROOT=\"/usr/lib/rcsb\"" > ${T}/env.d
- newenvd ${T}/env.d 50validation
-
- dodoc README-source README
-}
-
-pkg_postinst() {
- einfo "The source version does not install PROCHECK."
- einfo "If you require that, you may download it from"
- einfo "http://www.biochem.ucl.ac.uk/~roman/procheck/procheck.html."
-}