summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-news/yencode')
-rw-r--r--net-news/yencode/ChangeLog14
-rw-r--r--net-news/yencode/files/digest-yencode-0.461
-rw-r--r--net-news/yencode/yencode-0.46.ebuild35
3 files changed, 50 insertions, 0 deletions
diff --git a/net-news/yencode/ChangeLog b/net-news/yencode/ChangeLog
new file mode 100644
index 000000000000..e699b7c63fcf
--- /dev/null
+++ b/net-news/yencode/ChangeLog
@@ -0,0 +1,14 @@
+# ChangeLog for net-news/pan
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/net-news/yencode/ChangeLog,v 1.1 2002/05/02 06:09:27 rphillips Exp $
+
+*yencode-0.46 (1 May 2002)
+
+ 1 May 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
+
diff --git a/net-news/yencode/files/digest-yencode-0.46 b/net-news/yencode/files/digest-yencode-0.46
new file mode 100644
index 000000000000..f0647a788b41
--- /dev/null
+++ b/net-news/yencode/files/digest-yencode-0.46
@@ -0,0 +1 @@
+MD5 6af054f69c781cafa620063878a831ea yencode-0.46.tar.gz 241762
diff --git a/net-news/yencode/yencode-0.46.ebuild b/net-news/yencode/yencode-0.46.ebuild
new file mode 100644
index 000000000000..0f0f00977baf
--- /dev/null
+++ b/net-news/yencode/yencode-0.46.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Per Wigren <wigren@home.se>
+# $Header: /var/cvsroot/gentoo-x86/net-news/yencode/yencode-0.46.ebuild,v 1.1 2002/05/02 06:09:27 rphillips Exp $
+
+S=${WORKDIR}/${P}
+SRC_URI="http://prdownloads.sourceforge.net/yencode/${P}.tar.gz"
+HOMEPAGE="http://www.yencode.org"
+DESCRIPTION="yEnc encoder/decoder package"
+DEPEND=""
+
+src_compile() {
+ local myconf
+ use nls || myconf="--disable-nls"
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ ${myconf} || die "./configure failed"
+
+ emake || die
+}
+
+src_install () {
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ dodoc AUTHORS COPYING NEWS README ChangeLog
+ doman doc/ydecode.1 doc/yencode.1 doc/ypost.1 doc/ypostrc.5
+}