summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/gyach/ChangeLog9
-rw-r--r--net-misc/gyach/files/digest-gyach-0.8.21
-rw-r--r--net-misc/gyach/gyach-0.8.2.ebuild36
3 files changed, 45 insertions, 1 deletions
diff --git a/net-misc/gyach/ChangeLog b/net-misc/gyach/ChangeLog
index fa6ac2ea3dcc..71524eb4fbba 100644
--- a/net-misc/gyach/ChangeLog
+++ b/net-misc/gyach/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/gyach
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-misc/gyach/ChangeLog,v 1.3 2002/07/07 07:47:11 phoenix Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gyach/ChangeLog,v 1.4 2002/09/09 05:08:10 mkennedy Exp $
+
+*gyach-0.8.2 (07 Sep 2002)
+
+ 07 Sep 2002; Matthew Kennedy <mkennedy@gentoo.org>
+ gyach-0.8.2.ebuild, ChangeLog, files/digest-gyach-0.8.2 :
+
+ Minor version bump.
*gyach-0.7.6 (30 Apr 2002)
diff --git a/net-misc/gyach/files/digest-gyach-0.8.2 b/net-misc/gyach/files/digest-gyach-0.8.2
new file mode 100644
index 000000000000..608c8a054d01
--- /dev/null
+++ b/net-misc/gyach/files/digest-gyach-0.8.2
@@ -0,0 +1 @@
+MD5 46c53016a889d58381b442d0c4411e4f gyach-0.8.2.tar.gz 197126
diff --git a/net-misc/gyach/gyach-0.8.2.ebuild b/net-misc/gyach/gyach-0.8.2.ebuild
new file mode 100644
index 000000000000..ec793e36ee37
--- /dev/null
+++ b/net-misc/gyach/gyach-0.8.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gyach/gyach-0.8.2.ebuild,v 1.1 2002/09/09 05:08:10 mkennedy Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="GTK+-based Yahoo! chat client"
+SRC_URI="http://www4.infi.net/~cpinkham/gyach/code/${P}.tar.gz"
+HOMEPAGE="http://www4.infi.net/~cpinkham/gyach/"
+KEYWORDS="x86 sparc sparc64"
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="virtual/glibc
+ =x11-libs/gtk+-1.2*"
+
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ ./configure --host=${CHOST} --prefix=/usr || die
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr install || die
+ dodoc AUTHORS BUGS COPYING ChangeLog INSTALL NEWS README* TODO
+ dodoc sample.*
+
+ # install icon and desktop entry for gnome
+ if [ "`use gnome`" ] ; then
+ insinto /usr/share/pixmaps
+ doins ${D}/usr/share/gyach/pixmaps/gyach-icon.xpm
+ insinto /usr/share/gnome/apps/Internet
+ doins ${FILESDIR}/gyach.desktop
+ fi
+
+}