summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/xsupplicant/xsupplicant-1.0.ebuild')
-rw-r--r--net-misc/xsupplicant/xsupplicant-1.0.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/net-misc/xsupplicant/xsupplicant-1.0.ebuild b/net-misc/xsupplicant/xsupplicant-1.0.ebuild
new file mode 100644
index 000000000000..99418ce220a2
--- /dev/null
+++ b/net-misc/xsupplicant/xsupplicant-1.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/xsupplicant/xsupplicant-1.0.ebuild,v 1.1 2005/01/09 14:46:01 brix Exp $
+
+S="${WORKDIR}/${PN}"
+
+DESCRIPTION="Open Source Implementation of IEEE 802.1x"
+
+HOMEPAGE="http://open1x.sourceforge.net"
+SRC_URI="mirror://sourceforge/open1x/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE=""
+
+DEPEND=">=dev-libs/openssl-0.9.7
+ sys-apps/pcsc-lite"
+
+src_compile() {
+ econf --enable-eap-sim || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die "emake install failed"
+
+ dodoc AUTHORS README README.wireless_cards \
+ doc/README.certificates doc/Open1x-UserGuide.pdf
+
+ docinto examples
+ dodoc etc/*-example.conf
+
+ insinto /etc
+ newins etc/xsupplicant.conf xsupplicant.conf.example
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/xsupplicant.init.d xsupplicant
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/xsupplicant.conf.d xsupplicant
+}
+
+pkg_postinst() {
+ einfo
+ einfo "To use ${P} you must create the configuration file"
+ einfo "/etc/xsupplicant.conf"
+ einfo
+ einfo "An example configuration file has been installed as"
+ einfo "/etc/xsupplicant.conf.example"
+ einfo
+}