summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
Diffstat (limited to 'net-im')
-rw-r--r--net-im/psi/ChangeLog9
-rw-r--r--net-im/psi/files/digest-psi-0.8.51
-rw-r--r--net-im/psi/files/digest-psi-0.8.62
-rw-r--r--net-im/psi/psi-0.8.6.ebuild (renamed from net-im/psi/psi-0.8.5.ebuild)23
4 files changed, 28 insertions, 7 deletions
diff --git a/net-im/psi/ChangeLog b/net-im/psi/ChangeLog
index ba287a47d6ab..475ff9bb966b 100644
--- a/net-im/psi/ChangeLog
+++ b/net-im/psi/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-im/psi
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-im/psi/ChangeLog,v 1.2 2002/04/01 23:25:58 verwilst Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/psi/ChangeLog,v 1.3 2002/07/09 10:47:23 verwilst Exp $
+
+*psi-0.8.6 (9 July 2002)
+
+ 9 July 2002; Bart Verwilst <verwilst@gentoo.org> ChangeLog :
+
+ Emoticons, finally! Proxy support, .... Long Changelog on the site,
+ check it out..
*psi-0.8.5 (1 April 2002)
diff --git a/net-im/psi/files/digest-psi-0.8.5 b/net-im/psi/files/digest-psi-0.8.5
deleted file mode 100644
index 401b2a224591..000000000000
--- a/net-im/psi/files/digest-psi-0.8.5
+++ /dev/null
@@ -1 +0,0 @@
-MD5 74a8f8f3dd329422cbbdb96c8b26b651 psi-0.8.5.tar.bz2 483462
diff --git a/net-im/psi/files/digest-psi-0.8.6 b/net-im/psi/files/digest-psi-0.8.6
new file mode 100644
index 000000000000..5cdd12c61997
--- /dev/null
+++ b/net-im/psi/files/digest-psi-0.8.6
@@ -0,0 +1,2 @@
+MD5 8e624f88c7dde5794ce14c22f978f3ad psi-0.8.6.tar.bz2 448520
+MD5 7dd4e476536fb65d001baad6e440d9d4 qssl-1.0.tar.bz2 13032
diff --git a/net-im/psi/psi-0.8.5.ebuild b/net-im/psi/psi-0.8.6.ebuild
index a483d6883a11..c64b8cdc224b 100644
--- a/net-im/psi/psi-0.8.5.ebuild
+++ b/net-im/psi/psi-0.8.6.ebuild
@@ -1,20 +1,23 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
# Author Bart Verwilst <verwilst@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-im/psi/psi-0.8.5.ebuild,v 1.2 2002/06/08 16:41:48 verwilst Exp $
+# /space/gentoo/cvsroot/gentoo-x86/net-im/psi/psi-0.8.5.ebuild,v 1.2 2002/06/08 16:41:48 verwilst Exp
S=${WORKDIR}/${P}
-SRC_URI="http://www.affinix.com/~justin/programs/psi/${P}.tar.bz2"
+QV="1.0"
+SRC_URI="http://psi.affinix.com/files/${PV}/${P}.tar.bz2
+ http://psi.affinix.com/files/common/qssl-${QV}.tar.bz2"
DESCRIPTION="QT 3.x Jabber Client, with Licq-like interface"
HOMEPAGE="http://www.affinix.com/~justin/programs/psi/"
SLOT="0"
+LICENSE="GPL-2"
DEPEND="virtual/glibc
=x11-libs/qt-3*
ssl? ( >=dev-libs/openssl-0.9.6c )"
src_compile() {
- export QTDIR="/usr/qt/3"
+ export QTDIR="${QTDIR}"
export QMAKESPEC="linux-g++"
cd ${S}/src
mv common.cpp common.cpp.orig
@@ -22,8 +25,11 @@ src_compile() {
/usr/qt/3/bin/qmake psi.pro || die
emake CFLAGS="${CFLAGS} -D_REENTRANT -DQT_NO_DEBUG -DQT_THREAD_SUPPORT" CXXFLAGS="${CXXFLAGS} -D_REENTRANT -DQT_NO_DEBUG -DQT_THREAD_SUPPORT" || die
mv psi ${S}
- cd ${S}
-
+ if [ "`use ssl`" ]; then
+ cd ${WORKDIR}/qssl-${QV}
+ qmake qssl.pro
+ make
+ fi
}
src_install() {
@@ -40,6 +46,13 @@ src_install() {
cp -rf ./image ${D}/usr/share/psi/
cp -rf ./iconsets ${D}/usr/share/psi/
cp -rf ./sound ${D}/usr/share/psi/
+ cp -rf ./certs ${D}/usr/share/psi/
+ if [ "`use ssl`" ]; then
+ cd ${WORKDIR}/qssl-${QV}
+ cp libqssl.so ${D}/usr/share/psi
+ cd ${S}
+ fi
+
cp psi ${D}/usr/share/psi/
cp README ${D}/usr/share/psi/
cp COPYING ${D}/usr/share/psi/