summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/xbomber/xbomber-101.ebuild')
-rw-r--r--games-action/xbomber/xbomber-101.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/games-action/xbomber/xbomber-101.ebuild b/games-action/xbomber/xbomber-101.ebuild
new file mode 100644
index 000000000000..f39cc841afe5
--- /dev/null
+++ b/games-action/xbomber/xbomber-101.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/xbomber/xbomber-101.ebuild,v 1.1 2003/09/10 19:29:16 vapier Exp $
+
+inherit games
+
+DESCRIPTION="Bomberman clone w/multiplayer support"
+SRC_URI="http://www.xdr.com/dash/${P}.tgz"
+HOMEPAGE="http://www.xdr.com/dash/bomber.html"
+
+LICENSE="GPL-2"
+KEYWORDS="x86"
+SLOT="0"
+
+DEPEND="virtual/x11
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i "s:X386:X11R6:" Makefile
+ sed -i "s:data/%s:${GAMES_DATADIR}/${PN}/%s:" bomber.c
+ sed -i "s:=\"data\":=\"${GAMES_DATADIR}/${PN}\":" sound.c
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ dogamesbin matcher bomber
+ dodir ${GAMES_DATADIR}/${PN}
+ cp -r data/* ${D}/${GAMES_DATADIR}/${PN}/
+ dodoc README Changelog
+ prepgamesdirs
+}