summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/gprof2dot')
-rw-r--r--dev-util/gprof2dot/ChangeLog6
-rw-r--r--dev-util/gprof2dot/Manifest5
-rw-r--r--dev-util/gprof2dot/gprof2dot-0_p20100216.ebuild14
3 files changed, 11 insertions, 14 deletions
diff --git a/dev-util/gprof2dot/ChangeLog b/dev-util/gprof2dot/ChangeLog
index 665ce1d39214..4e8580132600 100644
--- a/dev-util/gprof2dot/ChangeLog
+++ b/dev-util/gprof2dot/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/gprof2dot
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gprof2dot/ChangeLog,v 1.2 2010/10/10 18:27:23 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gprof2dot/ChangeLog,v 1.3 2010/10/21 00:45:46 sping Exp $
+
+ 21 Oct 2010; Sebastian Pipping <sping@gentoo.org>
+ gprof2dot-0_p20100216.ebuild:
+ Migrate from mercurial checkout to snapshot tarball (bug #337088)
10 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
gprof2dot-0_p20100216.ebuild:
diff --git a/dev-util/gprof2dot/Manifest b/dev-util/gprof2dot/Manifest
index 7f29a4e6f01e..1f4ec798123b 100644
--- a/dev-util/gprof2dot/Manifest
+++ b/dev-util/gprof2dot/Manifest
@@ -1,3 +1,4 @@
-EBUILD gprof2dot-0_p20100216.ebuild 1198 RMD160 00db89458b3f926a8e6925d18144289aa53088b1 SHA1 7407098b2d7bced7dcc01c0003a6470e7edd9795 SHA256 1595972bfbcdab6ca1082f17994897dfd599df24d309c129f0451479c826057f
-MISC ChangeLog 516 RMD160 26f285947de2cfa4c88b25448f9711abf22d012b SHA1 0c8e63265dffb1b2ba7117bd391bcba63093e77a SHA256 355fc2494b0b510961fa2fc18c83869c04d911e29fc3fd39975cf83d9e773e1e
+DIST gprof2dot-0_p20100216.tar.bz2 266908 RMD160 66577155e61c87f9ce0f9429e78b4224dfd6b8d0 SHA1 74c33269568337214290c5e5060373afc09c7b53 SHA256 696dca5532e2f7317aca298d1e5e906108501bf005c8cb372bb41ed869be9f3b
+EBUILD gprof2dot-0_p20100216.ebuild 1022 RMD160 34f11b72c7f76ca8e9eec26d5874b465221fb30c SHA1 99f17fb64fb74eea266f0691691d9d56407a1c13 SHA256 c61503a3da5538621106dc616ae1acddbe941350e096ef060711f835218850cd
+MISC ChangeLog 666 RMD160 d22401380b70d456ead85fc3c4ee02439b446047 SHA1 22f08c54b889003fa2ab6ed9dd328e13a2437f7b SHA256 f7babf0ed2d0e50e227df91e8f52c073b23eb7752fd0996ffcf5f4d5643e3ca1
MISC metadata.xml 257 RMD160 04e4c6e678ba8e8ffde93f57d06a40b60f9eaa69 SHA1 e3c39bf9a25beebbe626726bb94f6e22db4fa06d SHA256 b4a209de2bfbbcc5ceab61bf458a1ee79da4c60a30e4aabf54b76e9709b56db8
diff --git a/dev-util/gprof2dot/gprof2dot-0_p20100216.ebuild b/dev-util/gprof2dot/gprof2dot-0_p20100216.ebuild
index c70da75ce727..91d5a9d40ca2 100644
--- a/dev-util/gprof2dot/gprof2dot-0_p20100216.ebuild
+++ b/dev-util/gprof2dot/gprof2dot-0_p20100216.ebuild
@@ -1,23 +1,17 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gprof2dot/gprof2dot-0_p20100216.ebuild,v 1.2 2010/10/10 18:27:23 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gprof2dot/gprof2dot-0_p20100216.ebuild,v 1.3 2010/10/21 00:45:46 sping Exp $
EAPI="3"
SUPPORT_PYTHON_ABIS="1"
PYTHON_DEPEND="*"
PYTHON_USE_WITH="xml"
-inherit mercurial python
+inherit python
DESCRIPTION="Converts profiling output to dot graphs"
HOMEPAGE="http://code.google.com/p/jrfonseca/wiki/Gprof2Dot"
-SRC_URI=""
-EHG_REPO_URI="https://gprof2dot.jrfonseca.googlecode.com/hg/"
-EHG_REVISION="9c41dcfc9906"
-
-if [[ ${PV} != 0_p20100216 ]]; then
- die 'Broken bump detected: same \${EHG_REVISION} again'
-fi
+SRC_URI="http://www.hartwork.org/public/${P}.tar.bz2"
LICENSE="GPL-3"
SLOT="0"
@@ -27,8 +21,6 @@ IUSE=""
DEPEND=""
RDEPEND=""
-S="${WORKDIR}/hg"
-
src_install() {
abi_specific_install() {
local code_dir="$(python_get_sitedir)"/${PN}