summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/routes/routes-1.13.ebuild')
-rw-r--r--dev-python/routes/routes-1.13.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-python/routes/routes-1.13.ebuild b/dev-python/routes/routes-1.13.ebuild
deleted file mode 100644
index 674401e8aa9b..000000000000
--- a/dev-python/routes/routes-1.13.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/routes/routes-1.13.ebuild,v 1.3 2014/08/10 21:21:16 slyfox Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-DISTUTILS_SRC_TEST="nosetests"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit distutils
-
-MY_PN="Routes"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A Python re-implementation of the Rails routes system for mapping URL's to Controllers/Actions"
-HOMEPAGE="http://routes.groovie.org http://pypi.python.org/pypi/Routes"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="doc test"
-
-DEPEND="dev-python/setuptools
- dev-python/webob
- dev-python/repoze-lru
- test? ( dev-python/coverage
- dev-python/webtest )"
-RDEPEND=""
-
-S="${WORKDIR}/${MY_P}"
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- cd docs/_build/html
- docinto html
- cp -R [a-z]* _images _static "${ED}usr/share/doc/${PF}/html" || die "Installation of documentation failed"
- fi
-}