summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ocaml/ChangeLog8
-rw-r--r--dev-lang/ocaml/Manifest9
-rw-r--r--dev-lang/ocaml/files/digest-ocaml-3.06-r21
-rw-r--r--dev-lang/ocaml/metadata.xml5
-rw-r--r--dev-lang/ocaml/ocaml-3.06-r2.ebuild63
5 files changed, 82 insertions, 4 deletions
diff --git a/dev-lang/ocaml/ChangeLog b/dev-lang/ocaml/ChangeLog
index a045b9075b55..f9af3aed460b 100644
--- a/dev-lang/ocaml/ChangeLog
+++ b/dev-lang/ocaml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/ocaml
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.12 2003/09/07 02:48:39 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.13 2003/09/09 17:56:01 george Exp $
+
+*ocaml-3.06-r2 (09 Sep 2003)
+
+ 09 Sep 2003; George Shapovalov <george@gentoo.org> ocaml-3.06-r2.ebuild, metadata.xml :
+ ocaml was using uotdated "head -1" construct throughout. Changed this to "head -n 1",
+ see #27835 for details. Also added metadata.xml
06 Sep 2003; Jason Wever <weeve@gentoo.org> ocaml-3.06-r1.ebuild,
ocaml-3.06.ebuild, files/ocaml-3.06-sparc-configure.patch:
diff --git a/dev-lang/ocaml/Manifest b/dev-lang/ocaml/Manifest
index ca2318d52adf..ce9a60f20bbf 100644
--- a/dev-lang/ocaml/Manifest
+++ b/dev-lang/ocaml/Manifest
@@ -1,7 +1,10 @@
-MD5 df34ec69afe7048abef85c1452ff1c44 ChangeLog 2860
MD5 223d025c1d6b20eb13cbe6d6b1fa990b ocaml-3.06-r1.ebuild 1445
MD5 e85fd8053cc693729f0740b2ac855a44 ocaml-3.06.ebuild 1377
-MD5 30ac0d14e37ff0be57927d84e4e7e1c6 files/digest-ocaml-3.06 197
-MD5 13c4abf06e236e8835011a387f90ecc9 files/digest-ocaml-3.06-r1 63
+MD5 4df63628c2b4562b4333746826f47355 ocaml-3.06-r2.ebuild 1548
+MD5 6b8e2b212adb9a6c891e56cbce1326ef ChangeLog 3120
+MD5 8b350f19c06fcabf1053b0421b7c3f5a metadata.xml 155
MD5 4df214d6cd74b3c5955d868879dd6cc7 files/ocaml-3.06-tcltk-8.4compat-patch.bz2 639
+MD5 13c4abf06e236e8835011a387f90ecc9 files/digest-ocaml-3.06-r1 63
+MD5 13c4abf06e236e8835011a387f90ecc9 files/digest-ocaml-3.06-r2 63
+MD5 30ac0d14e37ff0be57927d84e4e7e1c6 files/digest-ocaml-3.06 197
MD5 91579cecf8659312c2324d8d40709433 files/ocaml-3.06-sparc-configure.patch 1660
diff --git a/dev-lang/ocaml/files/digest-ocaml-3.06-r2 b/dev-lang/ocaml/files/digest-ocaml-3.06-r2
new file mode 100644
index 000000000000..9f9f472447f2
--- /dev/null
+++ b/dev-lang/ocaml/files/digest-ocaml-3.06-r2
@@ -0,0 +1 @@
+MD5 51530ed183b511ce19fed325c8ab1b43 ocaml-3.06.tar.gz 2436887
diff --git a/dev-lang/ocaml/metadata.xml b/dev-lang/ocaml/metadata.xml
new file mode 100644
index 000000000000..2193d772e351
--- /dev/null
+++ b/dev-lang/ocaml/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+</pkgmetadata>
diff --git a/dev-lang/ocaml/ocaml-3.06-r2.ebuild b/dev-lang/ocaml/ocaml-3.06-r2.ebuild
new file mode 100644
index 000000000000..c604655c428d
--- /dev/null
+++ b/dev-lang/ocaml/ocaml-3.06-r2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.06-r2.ebuild,v 1.1 2003/09/09 17:56:01 george Exp $
+
+inherit flag-o-matic eutils
+filter-flags "-fstack-protector"
+
+DESCRIPTION="fast modern type-inferring functional programming language descended from the ML (Meta Language) family"
+HOMEPAGE="http://www.ocaml.org/"
+SRC_URI="http://caml.inria.fr/distrib/${P}/${P}.tar.gz"
+
+LICENSE="QPL-1.0 LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc"
+IUSE="tcltk"
+
+DEPEND="virtual/glibc
+ tcltk? ( >=dev-lang/tk-3.3.3 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ grep -rle "head -1" . | xargs sed -i "s:head -1:head -n 1:g"
+}
+
+src_compile() {
+ local myconf
+ use tcltk || myconf="-no-tk"
+
+ epatch ${FILESDIR}/ocaml-3.06-tcltk-8.4compat-patch.bz2
+
+ # Fix for bug #23767
+ if [ "${ARCH}" = "sparc" ]
+ then
+ # We need a patch and to make sure it builds
+ # for the right host type
+ epatch ${FILESDIR}/ocaml-3.06-sparc-configure.patch
+ myconf="${myconfg} -host sparc-unknown-linux-gnu"
+ fi
+
+ ./configure -prefix /usr \
+ -bindir /usr/bin \
+ -libdir /usr/lib/ocaml \
+ -mandir /usr/share/man \
+ --with-pthread ${myconf} || die
+
+ make world || die
+ make opt || die
+ make opt.opt || die
+}
+
+src_install() {
+ make BINDIR=${D}/usr/bin \
+ LIBDIR=${D}/usr/lib/ocaml \
+ MANDIR=${D}/usr/share/man \
+ install || die
+
+ # silly, silly makefiles
+ dosed "s:${D}::g" /usr/lib/ocaml/ld.conf
+
+ # documentation
+ dodoc Changes INSTALL LICENSE README Upgrading
+}