summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/swig/swig-1.3.21.ebuild')
-rw-r--r--dev-lang/swig/swig-1.3.21.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/dev-lang/swig/swig-1.3.21.ebuild b/dev-lang/swig/swig-1.3.21.ebuild
index 262c1ecb7731..be174de126f3 100644
--- a/dev-lang/swig/swig-1.3.21.ebuild
+++ b/dev-lang/swig/swig-1.3.21.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/swig/swig-1.3.21.ebuild,v 1.16 2004/06/24 02:08:04 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/swig/swig-1.3.21.ebuild,v 1.17 2004/06/24 02:11:48 vapier Exp $
inherit mono #48511
@@ -11,16 +11,16 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="as-is"
SLOT="0"
KEYWORDS="x86 ppc sparc mips alpha arm hppa amd64 ia64 s390"
-IUSE="java guile python tcltk ruby perl"
+IUSE="java guile python tcltk ruby perl php"
DEPEND="virtual/glibc
- >=sys-devel/gcc-2.95.2
python? ( >=dev-lang/python-2.0 )
java? ( virtual/jdk )
ruby? ( virtual/ruby )
guile? ( >=dev-util/guile-1.4 )
tcltk? ( >=dev-lang/tk-8.3 )
- perl? ( >=dev-lang/perl-5.6.1 )"
+ perl? ( >=dev-lang/perl-5.6.1 )
+ !arm? ( !mips? ( php? ( >=dev-php/php-4.0.0 ) ) )"
S=${WORKDIR}/SWIG-${PV}
@@ -39,6 +39,8 @@ src_compile() {
|| myc="$myc --without-tcl"
use perl && myc="$myc --with-perl" \
|| myc="$myc --without-perl"
+ use php && myc="$myc --with-php" \
+ || myc="$myc --without-php"
unset CXXFLAGS
unset CFLAGS