summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/hdbc')
-rw-r--r--dev-haskell/hdbc/ChangeLog9
-rw-r--r--dev-haskell/hdbc/hdbc-2.3.1.1.ebuild64
2 files changed, 71 insertions, 2 deletions
diff --git a/dev-haskell/hdbc/ChangeLog b/dev-haskell/hdbc/ChangeLog
index c8d012ae5ca6..aed4f96aa10d 100644
--- a/dev-haskell/hdbc/ChangeLog
+++ b/dev-haskell/hdbc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/hdbc
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc/ChangeLog,v 1.13 2011/06/12 19:50:10 slyfox Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc/ChangeLog,v 1.14 2012/06/02 05:58:02 gienah Exp $
+
+*hdbc-2.3.1.1 (02 Jun 2012)
+
+ 02 Jun 2012; Mark Wright <gienah@gentoo.org> +hdbc-2.3.1.1.ebuild:
+ Bump hdbc to 2.3.1.1
*hdbc-2.2.7.0 (12 Jun 2011)
diff --git a/dev-haskell/hdbc/hdbc-2.3.1.1.ebuild b/dev-haskell/hdbc/hdbc-2.3.1.1.ebuild
new file mode 100644
index 000000000000..b16c596e82ec
--- /dev/null
+++ b/dev-haskell/hdbc/hdbc-2.3.1.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc/hdbc-2.3.1.1.ebuild,v 1.1 2012/06/02 05:58:02 gienah Exp $
+
+EAPI=4
+
+# ebuild generated by hackport 0.2.18.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal versionator
+
+MY_PN="HDBC"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Haskell Database Connectivity"
+HOMEPAGE="https://github.com/hdbc/hdbc"
+SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE="mysql odbc postgres sqlite3 test"
+
+RDEPEND=">=dev-haskell/convertible-1.0.10.0[profile?]
+ dev-haskell/mtl[profile?]
+ dev-haskell/text[profile?]
+ >=dev-haskell/time-1.1.3[profile?]
+ <=dev-haskell/time-1.5[profile?]
+ dev-haskell/utf8-string[profile?]
+ >=dev-lang/ghc-6.8.2"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hunit
+ dev-haskell/quickcheck
+ dev-haskell/testpack
+ )
+ "
+
+DEPENDV="$(get_version_component_range 1-2)"
+PDEPEND="mysql? ( dev-haskell/hdbc-mysql )
+ odbc? ( =dev-haskell/hdbc-odbc-${DEPENDV}* )
+ postgres? ( =dev-haskell/hdbc-postgresql-${DEPENDV}* )
+ sqlite3? ( >=dev-haskell/hdbc-sqlite-${DEPENDV} )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ cabal_src_configure $(cabal_flag test buildtests)
+}
+
+src_test() {
+ # default tests
+ haskell-cabal_src_test || die "cabal test failed"
+
+ # built custom tests
+ "${S}/dist/build/runtests/runtests" || die "unit tests failed"
+}
+
+src_install() {
+ cabal_src_install
+
+ # if tests were enabled, make sure the unit test driver is deleted
+ rm -f "${ED}/usr/bin/runtests"
+}