summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/monotorrent/ChangeLog9
-rw-r--r--dev-dotnet/monotorrent/Manifest14
-rw-r--r--dev-dotnet/monotorrent/monotorrent-0.80.ebuild49
3 files changed, 69 insertions, 3 deletions
diff --git a/dev-dotnet/monotorrent/ChangeLog b/dev-dotnet/monotorrent/ChangeLog
index c296d5f455c2..d56218f47923 100644
--- a/dev-dotnet/monotorrent/ChangeLog
+++ b/dev-dotnet/monotorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-dotnet/monotorrent
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/monotorrent/ChangeLog,v 1.6 2009/08/31 13:58:26 loki_val Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/monotorrent/ChangeLog,v 1.7 2011/02/27 13:57:23 pacho Exp $
+
+*monotorrent-0.80 (27 Feb 2011)
+
+ 27 Feb 2011; Pacho Ramos <pacho@gentoo.org> +monotorrent-0.80.ebuild:
+ Version bump.
31 Aug 2009; Peter Alfredsen <loki_val@gentoo.org>
-monotorrent-0.70.ebuild, monotorrent-0.72.ebuild, -files/mono.snk:
diff --git a/dev-dotnet/monotorrent/Manifest b/dev-dotnet/monotorrent/Manifest
index 8829e46fdeb2..1d413cffccc5 100644
--- a/dev-dotnet/monotorrent/Manifest
+++ b/dev-dotnet/monotorrent/Manifest
@@ -1,6 +1,18 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
AUX monotorrent.pc.in 159 RMD160 de5efebeeb059bdd1b7101a53f84e20e5af66d20 SHA1 e87063b2f5e09dd95900bcd1ae83820745c64fc6 SHA256 5a8a911bd21e5a79b5b5ba8e4ef0e2f5276e1d8200cf3f8fb57be6c1f2bb17ea
DIST mono.snk.bz2 785 RMD160 2e30f95781501c734073f377f4b2bd1e04db0409 SHA1 9e32703b6ae86db332c73354fb79dcc61a6b7b17 SHA256 0cc2ca58f90773eafa8460dfb8ff4ac6238b68106eb1631348a800091a6ff3de
DIST monotorrent-0.72.tar.gz 269544 RMD160 708aad857fe5dbe79f4dcbccd4dda027bc438e0d SHA1 aecf8e80ec72c0d4a94bf440df08226c8025b204 SHA256 5e68383448ff703522fe8df4f3712bf15a33f1f2245c9ad8249b723d9109d9d4
+DIST monotorrent-0.80.tar.gz 290837 RMD160 164203fdb8c6c91522a081844c38288019f443dd SHA1 6e391bacf9b637bb620a2665ba5540f33bf6ea24 SHA256 d9c079dc4757e637f1e81a4d8b8a153394fcbeff8dd572bb0622e3430c5a34cf
EBUILD monotorrent-0.72.ebuild 1473 RMD160 b37d6b6095786279d60600ac541bb563328f01af SHA1 47369bc661fb61baa5cb29b2afe98430f94089ec SHA256 530074689290c60ceb1bb462e2d8080d0b118ea7aca0196ab59228c092fdab93
-MISC ChangeLog 1060 RMD160 c5c9aa016c9646e1184af285e1f6990e42c2e4f8 SHA1 72874e8eab3f250dc82c18bd3f05a021424c4eb3 SHA256 248f3dab9fbc7c011d7a413cfd4f6697ec862a16e59ce80a5ecea1852b5332da
+EBUILD monotorrent-0.80.ebuild 1472 RMD160 c320c1b9b2deb25fb2b343a864c086354af4da75 SHA1 07a230adde6aaed646c6a0f144613358ab185a60 SHA256 5e4ffc206b2e4499648c5f272b0ba501ecf130b4b3248dba4241d9baeac51dee
+MISC ChangeLog 1179 RMD160 b03d185698b92fe421c7f973ebbfa84110c47ed9 SHA1 08f7da99bfe869b59236aaed2531a8df9d422030 SHA256 bd04ee172c079f84a055ee0b29497f855063b4e8b9e4a4602bee22d1bc18e93b
MISC metadata.xml 160 RMD160 cc10b170ad63a746d8bdfbe5bf1bd9f7065922b8 SHA1 49eaf4246f7502850064d3806cce65d3a404ce1b SHA256 1bc3e313a948415fff0dfa63a5610943327146bfe16bfeca603379bf9706a687
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.17 (GNU/Linux)
+
+iEYEARECAAYFAk1qWEkACgkQCaWpQKGI+9RB/ACfcLoh82l9U9LtOq/yptgiLVXf
+ml4AoIY/U4x/VY1CORMkw6Se2+nlLE72
+=65pb
+-----END PGP SIGNATURE-----
diff --git a/dev-dotnet/monotorrent/monotorrent-0.80.ebuild b/dev-dotnet/monotorrent/monotorrent-0.80.ebuild
new file mode 100644
index 000000000000..e0bffcabd207
--- /dev/null
+++ b/dev-dotnet/monotorrent/monotorrent-0.80.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/monotorrent/monotorrent-0.80.ebuild,v 1.1 2011/02/27 13:57:23 pacho Exp $
+
+EAPI=2
+
+inherit mono multilib
+
+DESCRIPTION="Monotorrent is an open source C# bittorrent library"
+HOMEPAGE="http://projects.qnetp.net/projects/show/monotorrent"
+SRC_URI="http://projects.qnetp.net/attachments/download/28/${P}.tar.gz
+ mirror://gentoo/mono.snk.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RDEPEND=">=dev-lang/mono-2.0.1"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.23"
+
+# The hack we do to get the dll installed in the GAC makes the unit-tests
+# defunct.
+RESTRICT="test"
+
+src_prepare() {
+ sed -i \
+ -e "/InternalsVisibleTo/d" \
+ MonoTorrent/AssemblyInfo.cs* || die
+}
+
+src_compile() {
+ emake -j1 ASSEMBLY_COMPILER_COMMAND="/usr/bin/gmcs -keyfile:${WORKDIR}/mono.snk"
+}
+
+src_install() {
+ egacinstall $(find . -name "MonoTorrent.dll")
+ dodir /usr/$(get_libdir)/pkgconfig
+ ebegin "Installing .pc file"
+ sed \
+ -e "s:@LIBDIR@:$(get_libdir):" \
+ -e "s:@PACKAGENAME@:${PN}:" \
+ -e "s:@DESCRIPTION@:${DESCRIPTION}:" \
+ -e "s:@VERSION@:${PV}:" \
+ -e 's;@LIBS@;-r:${libdir}/mono/monotorrent/MonoTorrent.dll;' \
+ "${FILESDIR}"/${PN}.pc.in > "${D}"/usr/$(get_libdir)/pkgconfig/${PN}.pc
+ PKG_CONFIG_PATH="${D}/usr/$(get_libdir)/pkgconfig/" pkg-config --exists monotorrent || die ".pc file failed to validate."
+ eend $?
+}