summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-02-17 19:48:20 +0000
committerAron Griffis <agriffis@gentoo.org>2004-02-17 19:48:20 +0000
commitca00e13345dd83601011dd22d279d8d67785bdee (patch)
treed470d3cfec7a33012a3abe3224502605082856e6 /net-analyzer
parentstable on alpha and ia64 (diff)
downloadhistorical-ca00e13345dd83601011dd22d279d8d67785bdee.tar.gz
historical-ca00e13345dd83601011dd22d279d8d67785bdee.tar.bz2
historical-ca00e13345dd83601011dd22d279d8d67785bdee.zip
Fix up some stupid mistakes in this ebuild, clean up the USE handling, and fix bugs 41167 (libtool probs) and 41859 (missing dep on pkgconfig)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/ethereal/ChangeLog6
-rw-r--r--net-analyzer/ethereal/Manifest14
-rw-r--r--net-analyzer/ethereal/ethereal-0.10.0a.ebuild60
-rw-r--r--net-analyzer/fping/Manifest4
4 files changed, 40 insertions, 44 deletions
diff --git a/net-analyzer/ethereal/ChangeLog b/net-analyzer/ethereal/ChangeLog
index 0885dde2f0c7..942b359df349 100644
--- a/net-analyzer/ethereal/ChangeLog
+++ b/net-analyzer/ethereal/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/ethereal
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethereal/ChangeLog,v 1.47 2004/02/07 02:08:08 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethereal/ChangeLog,v 1.48 2004/02/17 19:48:20 agriffis Exp $
+
+ 17 Feb 2004; Aron Griffis <agriffis@gentoo.org> ethereal-0.10.0a.ebuild:
+ Fix up some stupid mistakes in this ebuild, clean up the USE handling, and fix
+ bugs 41167 (libtool probs) and 41859 (missing dep on pkgconfig)
07 Feb 2004; Lars Weiler <pylon@gentoo.org> ethereal-0.9.16.ebuild:
stable on ppc
diff --git a/net-analyzer/ethereal/Manifest b/net-analyzer/ethereal/Manifest
index 2ea7164b9d66..9ce5346f4d5c 100644
--- a/net-analyzer/ethereal/Manifest
+++ b/net-analyzer/ethereal/Manifest
@@ -1,13 +1,13 @@
-MD5 417c32c8e21f64a654af179867fe77de ChangeLog 7053
-MD5 33ac707975a02a41518c887301ac7727 ethereal-0.9.13.ebuild 2127
-MD5 19ec1748e5528490a7427dd1334807be ethereal-0.9.14.ebuild 2080
+MD5 75871bdb12eb6824d6973b5245fe7bbd ChangeLog 7279
MD5 1da60f9c2cf08aaa5fca2cf91847c3ff ethereal-0.9.15.ebuild 1989
-MD5 2a7d48724259251f6e59f318777adde6 ethereal-0.9.16-r1.ebuild 2332
MD5 0451bcd2ab2f44354f64ab7e57a28180 ethereal-0.9.16.ebuild 2259
-MD5 6010ebca3f0b10398b0211cea866c215 ethereal-0.10.0a.ebuild 2510
-MD5 44dcde01bfc4b986a229fa28dee9f9e7 files/digest-ethereal-0.9.13 69
-MD5 380524e1a6116898080fe64bed810144 files/digest-ethereal-0.9.14 69
+MD5 19ec1748e5528490a7427dd1334807be ethereal-0.9.14.ebuild 2080
+MD5 eb1ae4051514c038c047b281629269ab ethereal-0.10.0a.ebuild 2138
+MD5 2a7d48724259251f6e59f318777adde6 ethereal-0.9.16-r1.ebuild 2332
+MD5 33ac707975a02a41518c887301ac7727 ethereal-0.9.13.ebuild 2127
MD5 cd9ac6e867607636581cf2e0c8652210 files/digest-ethereal-0.9.15 69
MD5 3ce13570e210d6dc1669b91936d2f051 files/digest-ethereal-0.9.16 69
+MD5 380524e1a6116898080fe64bed810144 files/digest-ethereal-0.9.14 69
MD5 3ce13570e210d6dc1669b91936d2f051 files/digest-ethereal-0.9.16-r1 69
MD5 b419356a5755f8a51b7d2ac12bc5d91a files/digest-ethereal-0.10.0a 70
+MD5 44dcde01bfc4b986a229fa28dee9f9e7 files/digest-ethereal-0.9.13 69
diff --git a/net-analyzer/ethereal/ethereal-0.10.0a.ebuild b/net-analyzer/ethereal/ethereal-0.10.0a.ebuild
index 8cf373745918..b4d236d6c7c8 100644
--- a/net-analyzer/ethereal/ethereal-0.10.0a.ebuild
+++ b/net-analyzer/ethereal/ethereal-0.10.0a.ebuild
@@ -1,21 +1,21 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethereal/ethereal-0.10.0a.ebuild,v 1.1 2004/01/18 13:54:13 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethereal/ethereal-0.10.0a.ebuild,v 1.2 2004/02/17 19:48:20 agriffis Exp $
IUSE="adns gtk ipv6 snmp ssl gtk2"
+
inherit libtool
-S=${WORKDIR}/${P}
+
DESCRIPTION="A commercial-quality network protocol analyzer"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-RESTRICT="nomirror"
HOMEPAGE="http://www.ethereal.com/"
-
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~x86 ~sparc ~ppc ~alpha ~amd64"
+KEYWORDS="~x86 ~sparc ~ppc ~alpha ~amd64 ~ia64"
RDEPEND=">=sys-libs/zlib-1.1.4
snmp? ( virtual/snmp )
+ >=dev-util/pkgconfig-0.15.0
gtk? (
gtk2? ( >=dev-libs/glib-2.0.4 =x11-libs/gtk+-2* )
!gtk2? ( =x11-libs/gtk+-1.2* )
@@ -32,50 +32,42 @@ DEPEND="${RDEPEND}
sys-devel/flex"
src_unpack() {
- unpack ${A}
- cd ${S}
- # re-declaring functions is no good idea
- sed -i 's/getline/packet_giop_getline/g' packet-giop.c || sed failed
- elibtoolize
- # gcc related configure script braindamage
- sed -i "s|-I/usr/local/include||" configure || sed failed
- chmod +x ./configure
- sed -i "s|@PCAP_LIBS@ @SOCKET_LIBS@ @NSL_LIBS@|@PCAP_LIBS@ @SOCKET_LIBS@ @NSL_LIBS@ @ADNS_LIBS@|" \
- Makefile.am || sed failed
+ unpack ${A} && cd ${S} || die
+
+ # running a full elibtoolize seems to break things in this
+ # package... see bug 41831 (17 Feb 2004 agriffis)
+ elibtoolize --patch-only
}
src_compile() {
- local myconf
+ local myconf="
+ $(use_with ssl)
+ $(use_enable ipv6)
+ $(use_with adns)"
- if [ -z "`use gtk`" ] && [ -z "`use gtk2`" ]; then
+ if use gtk; then
+ myconf="${myconf} $(use_enable gtk2)"
+ else
myconf="${myconf} --disable-ethereal"
# the asn1 plugin needs gtk
- sed -i -e '/plugins\/asn1/c\' Makefile.in || sed failed
- sed -i -e 's/\(^SUBDIRS.*\)asn1\(.*\)/\1\2/' \
- plugins/Makefile.in || sed failed
+ sed -i -e '/plugins.asn1/d' Makefile.in || die "sed failed"
+ sed -i -e '/^SUBDIRS/s/asn1//' plugins/Makefile.in || die "sed failed"
fi
- use gtk2 && myconf="${myconf} --enable-gtk2"
- use ssl || myconf="${myconf} --without-ssl"
- use snmp || myconf="${myconf} --without-ucd-snmp --without-net-snmp"
- myconf="${myconf} $(use_enable ipv6)"
- myconf="${myconf} $(use_with adns)"
+ # if USE=snmp, then one of the snmp libraries will be available,
+ # thanks to virtual/snmp. In that case, let Ethereal use
+ # whichever it finds.
+ if ! use snmp; then
+ myconf="${myconf} --without-ucd-snmp --without-net-snmp"
+ fi
econf \
- --enable-pcap \
- --enable-zlib \
- --enable-tethereal \
- --enable-editcap \
- --enable-mergecap \
- --enable-text2cap \
- --enable-idl2eth \
--enable-dftest \
--enable-randpkt \
--sysconfdir=/etc/ethereal \
- --with-plugindir=/usr/lib/ethereal/plugins/${PV} \
${myconf} || die "bad ./configure"
- addwrite "/usr/share/snmp/mibs/.index"
+ addwrite "/usr/share/snmp/mibs/.index"
emake || die "compile problem"
}
diff --git a/net-analyzer/fping/Manifest b/net-analyzer/fping/Manifest
index b85ad3da9a7f..40b3d6910ffc 100644
--- a/net-analyzer/fping/Manifest
+++ b/net-analyzer/fping/Manifest
@@ -1,5 +1,5 @@
-MD5 18fd62f3e376e329c294565193665a09 ChangeLog 1236
-MD5 bdbad997982e61f2a8cfd2cee38d8deb fping-2.4_beta2-r1.ebuild 606
+MD5 e0ee996d45a88110184e0ec2bc50dbf3 ChangeLog 1343
+MD5 fcf2bb831de99c0ff9d51c08c92ed133 fping-2.4_beta2-r1.ebuild 619
MD5 e7d30cc0d1e0c7404adea0f207cf8f97 fping-2.4_beta2.ebuild 598
MD5 3fc4637fca91307d9fe148cb1924a508 files/digest-fping-2.4_beta2 70
MD5 d6a3fe0582b016b9ce82c2ef6b07ba55 files/digest-fping-2.4_beta2-r1 65