summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-08-05 14:56:27 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-08-05 14:56:27 +0000
commit4a7e5037765d77cbc679b96b5b2426d909c709fb (patch)
tree6b75f6ff2f445643ad65a0c3aeb69500f3322114 /dev-libs/rasqal
parentVersion bump (diff)
downloadhistorical-4a7e5037765d77cbc679b96b5b2426d909c709fb.tar.gz
historical-4a7e5037765d77cbc679b96b5b2426d909c709fb.tar.bz2
historical-4a7e5037765d77cbc679b96b5b2426d909c709fb.zip
version bump
Package-Manager: portage-2.2_rc6/cvs/Linux 2.6.25.7 x86_64
Diffstat (limited to 'dev-libs/rasqal')
-rw-r--r--dev-libs/rasqal/ChangeLog7
-rw-r--r--dev-libs/rasqal/rasqal-0.9.16.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/dev-libs/rasqal/ChangeLog b/dev-libs/rasqal/ChangeLog
index 34bf5b2e08ec..3dc0edebbb31 100644
--- a/dev-libs/rasqal/ChangeLog
+++ b/dev-libs/rasqal/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/rasqal
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/rasqal/ChangeLog,v 1.20 2008/05/12 09:29:01 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/rasqal/ChangeLog,v 1.21 2008/08/05 14:53:27 aballier Exp $
+
+*rasqal-0.9.16 (05 Aug 2008)
+
+ 05 Aug 2008; Alexis Ballier <aballier@gentoo.org> +rasqal-0.9.16.ebuild:
+ version bump
12 May 2008; Alexis Ballier <aballier@gentoo.org> rasqal-0.9.10.ebuild,
rasqal-0.9.15.ebuild:
diff --git a/dev-libs/rasqal/rasqal-0.9.16.ebuild b/dev-libs/rasqal/rasqal-0.9.16.ebuild
new file mode 100644
index 000000000000..fc1818878a4e
--- /dev/null
+++ b/dev-libs/rasqal/rasqal-0.9.16.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/rasqal/rasqal-0.9.16.ebuild,v 1.1 2008/08/05 14:53:27 aballier Exp $
+
+inherit libtool
+
+DESCRIPTION="library that handles Resource Description Framework (RDF)"
+HOMEPAGE="http://librdf.org/rasqal"
+SRC_URI="http://download.librdf.org/source/${P}.tar.gz"
+
+LICENSE="LGPL-2.1 Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="debug gmp pcre test xml"
+
+RDEPEND=">=media-libs/raptor-1.4.16
+ pcre? ( dev-libs/libpcre )
+ xml? ( dev-libs/libxml2 )
+ !gmp? ( dev-libs/mpfr )
+ gmp? ( dev-libs/gmp )
+ debug? ( >=dev-libs/dmalloc-5.5.2-r2 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/flex
+ test? ( dev-perl/XML-DOM )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ elibtoolize
+}
+
+src_compile() {
+ local regex
+ local decimal
+
+ if use pcre; then
+ regex="pcre"
+ else
+ regex="posix"
+ fi
+
+ if use gmp; then
+ decimal="gmp"
+ else
+ decimal="mpfr"
+ fi
+
+ econf $(use_enable pcre) $(use_enable xml xml2) $(use_with debug dmalloc) \
+ $(use_enable debug maintainer-mode) --with-regex-library=${regex} \
+ --with-decimal=${decimal} --with-raptor=system
+
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog* NEWS README
+}