From 56bd759df1d0c750a065b8c845e93d5dfa6b549d Mon Sep 17 00:00:00 2001
From: "Robin H. Johnson" <robbat2@gentoo.org>
Date: Sat, 8 Aug 2015 13:49:04 -0700
Subject: proj/gentoo: Initial commit
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

This commit represents a new era for Gentoo:
Storing the gentoo-x86 tree in Git, as converted from CVS.

This commit is the start of the NEW history.
Any historical data is intended to be grafted onto this point.

Creation process:
1. Take final CVS checkout snapshot
2. Remove ALL ChangeLog* files
3. Transform all Manifests to thin
4. Remove empty Manifests
5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$
5.1. Do not touch files with -kb/-ko keyword flags.

Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests
X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project
X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration
X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn
X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts
X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration
X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging
X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
---
 sys-libs/libnih/Manifest                           |  1 +
 .../libnih/files/libnih-1.0.3-optional-dbus.patch  | 40 +++++++++++++++
 .../libnih/files/libnih-1.0.3-pkg-config.patch     | 56 ++++++++++++++++++++
 .../libnih/files/libnih-1.0.3-signal-race.patch    | 60 ++++++++++++++++++++++
 sys-libs/libnih/libnih-1.0.3-r1.ebuild             | 45 ++++++++++++++++
 sys-libs/libnih/libnih-1.0.3-r2.ebuild             | 46 +++++++++++++++++
 sys-libs/libnih/libnih-1.0.3-r3.ebuild             | 47 +++++++++++++++++
 sys-libs/libnih/libnih-1.0.3.ebuild                | 47 +++++++++++++++++
 sys-libs/libnih/metadata.xml                       | 11 ++++
 9 files changed, 353 insertions(+)
 create mode 100644 sys-libs/libnih/Manifest
 create mode 100644 sys-libs/libnih/files/libnih-1.0.3-optional-dbus.patch
 create mode 100644 sys-libs/libnih/files/libnih-1.0.3-pkg-config.patch
 create mode 100644 sys-libs/libnih/files/libnih-1.0.3-signal-race.patch
 create mode 100644 sys-libs/libnih/libnih-1.0.3-r1.ebuild
 create mode 100644 sys-libs/libnih/libnih-1.0.3-r2.ebuild
 create mode 100644 sys-libs/libnih/libnih-1.0.3-r3.ebuild
 create mode 100644 sys-libs/libnih/libnih-1.0.3.ebuild
 create mode 100644 sys-libs/libnih/metadata.xml

(limited to 'sys-libs/libnih')

diff --git a/sys-libs/libnih/Manifest b/sys-libs/libnih/Manifest
new file mode 100644
index 000000000000..110e84d8276e
--- /dev/null
+++ b/sys-libs/libnih/Manifest
@@ -0,0 +1 @@
+DIST libnih-1.0.3.tar.gz 1187624 SHA256 897572df7565c0a90a81532671e23c63f99b4efde2eecbbf11e7857fbc61f405 SHA512 fce40d2445b28c27b8838631681ca3206a4f053b2dd4fc488fc9ef98bbd3d933e3d62b82cf346be2ef1677f6457f692cf5544cd915a6bb1e5c618f98ffa101b4 WHIRLPOOL da001ba05111d3a654e6800cf283e11b5508e53d6d91b37ed277df5a889a1138e90ae13161e0af81bdcac929b105bf889e4dcdc443789f28417c6e3f61530d8c
diff --git a/sys-libs/libnih/files/libnih-1.0.3-optional-dbus.patch b/sys-libs/libnih/files/libnih-1.0.3-optional-dbus.patch
new file mode 100644
index 000000000000..afe43749b6b0
--- /dev/null
+++ b/sys-libs/libnih/files/libnih-1.0.3-optional-dbus.patch
@@ -0,0 +1,40 @@
+--- libnih-1.0.1/configure.ac
++++ libnih-1.0.1/configure.ac
+@@ -23,12 +23,21 @@
+ PKG_PROG_PKG_CONFIG([0.22])
+ 
+ # Checks for libraries.
+-PKG_CHECK_MODULES([DBUS], [dbus-1 >= 1.2.16])
+-AC_CHECK_LIB([expat], [XML_ParserCreate],
++AC_ARG_WITH([dbus],
++  [AS_HELP_STRING([--without-dbus],
++    [disable support for dbus])],
++  [],
++  [with_dbus=yes])
++
++AS_IF([test "x$with_dbus" != xno],[
++	PKG_CHECK_MODULES([DBUS], [dbus-1 >= 1.2.16])
++	AC_CHECK_LIB([expat], [XML_ParserCreate],
+ 	     [AC_CHECK_LIB([expat], [XML_StopParser],
+ 	     		   [AC_SUBST([EXPAT_LIBS], [-lexpat])],
+ 			   [AC_MSG_ERROR([expat >= 2.0.0 required])])],
+-	     [AC_MSG_ERROR([expat library not found])])
++	     [AC_MSG_ERROR([expat library not found])])])
++
++AM_CONDITIONAL([DBUS_SUPPORT], [test "x$with_dbus" != xno])
+ 
+ # Checks for header files.
+ AC_CHECK_HEADERS([valgrind/valgrind.h])
+--- libnih-1.0.1.orig/Makefile.am
++++ libnih-1.0.1/Makefile.am
+@@ -1,6 +1,9 @@
+ ## Process this file with automake to produce Makefile.in
+ 
+-SUBDIRS = m4 intl nih nih-dbus nih-dbus-tool po
++SUBDIRS = m4 intl nih po
++if DBUS_SUPPORT
++SUBDIRS += nih-dbus nih-dbus-tool
++endif
+ 
+ EXTRA_DIST = HACKING
+ 
diff --git a/sys-libs/libnih/files/libnih-1.0.3-pkg-config.patch b/sys-libs/libnih/files/libnih-1.0.3-pkg-config.patch
new file mode 100644
index 000000000000..979e363f2157
--- /dev/null
+++ b/sys-libs/libnih/files/libnih-1.0.3-pkg-config.patch
@@ -0,0 +1,56 @@
+# Bazaar merge directive format 2 (Bazaar 0.90)
+# revision_id: vapier@gentoo.org-20111019170935-fheqs03szv6mhh3o
+# target_branch: http://bazaar.launchpad.net/~scott/libnih/trunk/
+# testament_sha1: 84b368e08fdd9f8276611cdfe97d34f51cd90598
+# timestamp: 2011-10-19 13:13:52 -0400
+# base_revision_id: scott@netsplit.com-20110901184103-d2xbvc5hbt0vqxf0
+# 
+# Begin patch
+=== modified file 'nih-dbus/Makefile.am'
+--- nih-dbus/Makefile.am	2009-11-21 21:44:23 +0000
++++ nih-dbus/Makefile.am	2011-10-19 17:09:35 +0000
+@@ -49,7 +49,7 @@
+ 	test_dbus.h
+ 
+ 
+-pkgconfigdir = $(prefix)/lib/pkgconfig
++pkgconfigdir = $(libdir)/pkgconfig
+ pkgconfig_DATA = libnih-dbus.pc
+ 
+ 
+
+=== modified file 'nih/Makefile.am'
+--- nih/Makefile.am	2009-11-21 21:44:23 +0000
++++ nih/Makefile.am	2011-10-19 17:09:35 +0000
+@@ -71,7 +71,7 @@
+ 	test_hash.h
+ 
+ 
+-pkgconfigdir = $(prefix)/lib/pkgconfig
++pkgconfigdir = $(libdir)/pkgconfig
+ pkgconfig_DATA = libnih.pc
+ 
+ 
+
+# Begin bundle
+IyBCYXphYXIgcmV2aXNpb24gYnVuZGxlIHY0CiMKQlpoOTFBWSZTWerAspcAAhZfgAAQVGf/93Mi
+DAC/7//wUASW8VttRtyKRaUhJU00ZTUab1GBT9JpNNqeiAADEEpDUwp5Gk9KeiZAANAAABIo0hE9
+GTTJJ5AMo8oB6IwmmMNDQAAAaAAAAAEkgQBGTCGmmoZQPSIxoCJYV1m4Z59VmltTEiVlNBLfEBWL
+DPUvZdcke3iHe+YuVhuGNtnl+0Xxmwcuy+RkTlRw9Ct83uYaZ7PH3vOd/AqYc6mhoKnwOCJD7ej5
+jS/rj7FmeOwxohzIMw9Ftarf11sHFhfFyWQEWL15gMctp9IL8d5sOYp0YoMOIw5htiyuYikcaPZ+
+xeB0ZI+IpppnCWQD3qlFKeI1NHACFmRBrQ2Sn1nmVurFZLNeqWK2Xy7eKAJK1SuguZhs8DekVjKE
+YGJwURdteHklA3WkfNMdKKNMQHQqnTtxAg1ShnXAzzkjnDtTSCwNhnuoY0WM1bLLCJlFM6NphCLS
+CGV+ZxUbN6YirSh9tVJWBzJKQaE5HEstAsAuqdVKlAlNKIrkYPSb3oy9WkKNsyyLYUiplUvi8C3i
+ioz+SscYWhwHzkxL/k0TPk8tL6l5FzzBa8FCKRWbDCTa0nbGzEhoJmaYEfwBog+pmXpsuVNUZmF4
+OreOMqF7JyNA1HJJ14+yxa6SRpJ51jBFyaNAojQK2ai7BtxEVZFoG3TYZiaTnR8LwZPDCtw7GqpA
+6mKFWiqtj/KxW+zQNmQbh9XE5eCCdFBTQzJmb7H3fDQpKW1njIoLHI+HeAXGDxYmu7HJ3DoZtH3Z
+7UfYYlEO8WoZpHZIMdDSCTWUE41kdp0nBWlshTuqcODflplwgnc03YlpZF9eBKQsUJi4gRvOhwmO
+XzuHW8qzc+JojHueBjZGJRiZQktKmJFoSD3k4+SOEue4uOh88jC0uRC8zDtbDCuz1fd6m5nsBrXh
+4KCGR5mWo4953Ie6CdWVops43mZdcboGGpUVirZZC+SPwwvwVSDuTAzASyFMevBBdbmdy3y0L0Y2
+oqRD3LY5+RqPM9R4/XEkdVuXmAxvF7GgrzRSIuDsTD2MANhmBxuF+EEbTKN/ciAzAUxnOdie1hol
+lqAkHxA44ja0WMKzYlmGU28kSdqB1i6h4nLevOVCnK+WtEKLpuOy6eZFThX5IsRrjenja/BSN2iu
+FFE+cHoYwJzGRI9yFKvpRUQ+H0qqaIoI5lP18lEqsPiBhRHMkpPIHqMuoiGiZyQxSXC0ynqSTYNX
+80VoGbTVLspApI9vo8XZBOScj6oHLR6qkjlnhkwwNQ8/wZdSfNBI0NSKLNasgKl6LF7FVbx4MCcj
+jYREWWzVEEVd81rloiAfu+h8H33/8DPhciqmx3QHdcdLEOKQ1mHIp8NQLYDAhQjJPmRA4hvGfSG+
+dwTBj1rKUFKGB7BYiKJ+C3dZ91NewHQ8kxHGlS0rSLioLvwrlwNSrRgtyZzWVFTWB8C7kinChIdW
+BZS4
diff --git a/sys-libs/libnih/files/libnih-1.0.3-signal-race.patch b/sys-libs/libnih/files/libnih-1.0.3-signal-race.patch
new file mode 100644
index 000000000000..4cba5ae4ded3
--- /dev/null
+++ b/sys-libs/libnih/files/libnih-1.0.3-signal-race.patch
@@ -0,0 +1,60 @@
+https://bugs.launchpad.net/libnih/+bug/518921
+
+fix race in signal processing leading to lost signals
+
+The current loop will walk all signals one by one and run the handler
+for it if any signals were pending.  Then it clears the array.  But if
+a signal comes in for an earlier checked signal, it will get clobbered
+when the final clear runs.
+
+Change the logic so that we only clear entries for signals whose handler
+we explicitly call.  If a different signal comes in, we'll process it
+the next time around.
+
+This was discovered & triaged by Jeffy Chen from Rockchip.
+
+=== modified file 'nih/signal.c'
+--- nih/signal.c	2009-06-23 09:29:37 +0000
++++ nih/signal.c	2015-05-21 08:12:11 +0000
+@@ -337,17 +337,37 @@
+ 
+ 	nih_signal_init ();
+ 
++	/* Since this poller runs w/out signals masked, we do not want to try
++	 * and clear any other signals (like zeroing the caught array at the
++	 * end).  If we do that, we open a race:
++	 * - Walk the list of signals.
++	 * - First one is not set so we move on to the second one.
++	 * - First signal comes in while processing second and increments the
++	 *   caught array entry.
++	 * - Finish walking the whole list.
++	 * - Zero out the whole list and thus throw away the first signal.
++	 * Since the signal handlers can take any length of time, this race
++	 * can be open for a variable amount of time.
++	 */
++
+ 	NIH_LIST_FOREACH_SAFE (nih_signals, iter) {
+ 		NihSignal *signal = (NihSignal *)iter;
+ 
+ 		if (! signals_caught[signal->signum])
+ 			continue;
+ 
++		/* Now that we know we're going to process this signal, clear
++		 * out all pending counts for it.  There is a slight race here
++		 * where the same signal can come in, but the API has never
++		 * guaranteed exact coverage since POSIX does not provide it --
++		 * more than one signal can be collapsed into one event.  All
++		 * we can guarantee is that we'll notice signals that come in
++		 * once the handler runs.
++		 */
++		signals_caught[signal->signum] = 0;
++
+ 		signal->handler (signal->data, signal);
+ 	}
+-
+-	for (s = 0; s < NUM_SIGNALS; s++)
+-		signals_caught[s] = 0;
+ }
+ 
+ 
+
diff --git a/sys-libs/libnih/libnih-1.0.3-r1.ebuild b/sys-libs/libnih/libnih-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..f8d37791181e
--- /dev/null
+++ b/sys-libs/libnih/libnih-1.0.3-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit versionator eutils autotools toolchain-funcs multilib
+
+DESCRIPTION="Light-weight 'standard library' of C functions"
+HOMEPAGE="https://launchpad.net/libnih"
+SRC_URI="http://launchpad.net/${PN}/$(get_version_component_range 1-2)/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+dbus nls static-libs test +threads"
+
+RDEPEND="dbus? ( dev-libs/expat >=sys-apps/dbus-1.2.16 )"
+DEPEND="${RDEPEND}
+	sys-devel/gettext
+	virtual/pkgconfig
+	test? ( dev-util/valgrind )"
+
+src_prepare() {
+	epatch "${FILESDIR}"/${PN}-1.0.3-optional-dbus.patch
+	epatch "${FILESDIR}"/${PN}-1.0.3-pkg-config.patch
+	eautoreconf
+}
+
+src_configure() {
+	econf \
+		$(use_with dbus) \
+		$(use_enable nls) \
+		$(use_enable static-libs static) \
+		$(use_enable threads) \
+		$(use_enable threads threading)
+}
+
+src_install() {
+	default
+
+	# we need to be in / because upstart needs libnih
+	gen_usr_ldscript -a nih $(use dbus && echo nih-dbus)
+	use static-libs || rm "${ED}"/usr/$(get_libdir)/*.la
+}
diff --git a/sys-libs/libnih/libnih-1.0.3-r2.ebuild b/sys-libs/libnih/libnih-1.0.3-r2.ebuild
new file mode 100644
index 000000000000..2ce8380ac9f1
--- /dev/null
+++ b/sys-libs/libnih/libnih-1.0.3-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit versionator eutils autotools toolchain-funcs multilib flag-o-matic
+
+DESCRIPTION="Light-weight 'standard library' of C functions"
+HOMEPAGE="https://launchpad.net/libnih"
+SRC_URI="http://launchpad.net/${PN}/$(get_version_component_range 1-2)/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+dbus nls static-libs test +threads"
+
+RDEPEND="dbus? ( dev-libs/expat >=sys-apps/dbus-1.2.16 )"
+DEPEND="${RDEPEND}
+	sys-devel/gettext
+	virtual/pkgconfig
+	test? ( dev-util/valgrind )"
+
+src_prepare() {
+	epatch "${FILESDIR}"/${PN}-1.0.3-optional-dbus.patch
+	epatch "${FILESDIR}"/${PN}-1.0.3-pkg-config.patch
+	eautoreconf
+}
+
+src_configure() {
+	append-lfs-flags
+	econf \
+		$(use_with dbus) \
+		$(use_enable nls) \
+		$(use_enable static-libs static) \
+		$(use_enable threads) \
+		$(use_enable threads threading)
+}
+
+src_install() {
+	default
+
+	# we need to be in / because upstart needs libnih
+	gen_usr_ldscript -a nih $(use dbus && echo nih-dbus)
+	use static-libs || rm "${ED}"/usr/$(get_libdir)/*.la
+}
diff --git a/sys-libs/libnih/libnih-1.0.3-r3.ebuild b/sys-libs/libnih/libnih-1.0.3-r3.ebuild
new file mode 100644
index 000000000000..74473d4ef49d
--- /dev/null
+++ b/sys-libs/libnih/libnih-1.0.3-r3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit versionator eutils autotools toolchain-funcs multilib flag-o-matic
+
+DESCRIPTION="Light-weight 'standard library' of C functions"
+HOMEPAGE="https://launchpad.net/libnih"
+SRC_URI="http://launchpad.net/${PN}/$(get_version_component_range 1-2)/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+IUSE="+dbus nls static-libs test +threads"
+
+RDEPEND="dbus? ( dev-libs/expat >=sys-apps/dbus-1.2.16 )"
+DEPEND="${RDEPEND}
+	sys-devel/gettext
+	virtual/pkgconfig
+	test? ( dev-util/valgrind )"
+
+src_prepare() {
+	epatch "${FILESDIR}"/${PN}-1.0.3-optional-dbus.patch
+	epatch "${FILESDIR}"/${PN}-1.0.3-pkg-config.patch
+	epatch "${FILESDIR}"/${PN}-1.0.3-signal-race.patch
+	eautoreconf
+}
+
+src_configure() {
+	append-lfs-flags
+	econf \
+		$(use_with dbus) \
+		$(use_enable nls) \
+		$(use_enable static-libs static) \
+		$(use_enable threads) \
+		$(use_enable threads threading)
+}
+
+src_install() {
+	default
+
+	# we need to be in / because upstart needs libnih
+	gen_usr_ldscript -a nih $(use dbus && echo nih-dbus)
+	use static-libs || rm "${ED}"/usr/$(get_libdir)/*.la
+}
diff --git a/sys-libs/libnih/libnih-1.0.3.ebuild b/sys-libs/libnih/libnih-1.0.3.ebuild
new file mode 100644
index 000000000000..4a1301950083
--- /dev/null
+++ b/sys-libs/libnih/libnih-1.0.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit versionator eutils autotools toolchain-funcs
+
+DESCRIPTION="Light-weight 'standard library' of C functions"
+HOMEPAGE="https://launchpad.net/libnih"
+SRC_URI="http://launchpad.net/${PN}/$(get_version_component_range 1-2)/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+dbus nls static-libs test +threads"
+
+RDEPEND="dbus? ( dev-libs/expat >=sys-apps/dbus-1.2.16 )"
+DEPEND="${RDEPEND}
+	sys-devel/gettext
+	virtual/pkgconfig
+	test? ( dev-util/valgrind )"
+
+src_prepare() {
+	epatch "${FILESDIR}"/${PN}-1.0.3-optional-dbus.patch
+	epatch "${FILESDIR}"/${PN}-1.0.3-pkg-config.patch
+	eautoreconf
+}
+
+src_configure() {
+	econf \
+		$(use_with dbus) \
+		$(use_enable nls) \
+		$(use_enable static-libs static) \
+		$(use_enable threads) \
+		$(use_enable threads threading)
+}
+
+src_install() {
+	emake DESTDIR="${D}" install || die
+
+	# we need to be in / because upstart needs libnih
+	gen_usr_ldscript -a nih $(use dbus && echo nih-dbus)
+	use static-libs || rm "${D}"/usr/lib*/*.la
+
+	dodoc AUTHORS ChangeLog HACKING NEWS README TODO
+}
diff --git a/sys-libs/libnih/metadata.xml b/sys-libs/libnih/metadata.xml
new file mode 100644
index 000000000000..4ef875497dfd
--- /dev/null
+++ b/sys-libs/libnih/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+	<maintainer>
+		<email>vapier@gentoo.org</email>
+		<description>feel free to update however you like</description>
+	</maintainer>
+	<upstream>
+		<remote-id type="launchpad">libnih</remote-id>
+	</upstream>
+</pkgmetadata>
-- 
cgit v1.2.3-65-gdbad