From 04ef276178e9a35474cefee8615b774e4e698867 Mon Sep 17 00:00:00 2001
From: Pacho Ramos <pacho@gentoo.org>
Date: Tue, 19 Oct 2021 22:10:46 +0200
Subject: sci-chemistry/chemex: Version bump

Package-Manager: Portage-3.0.24, Repoman-3.0.3
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
---
 sci-chemistry/chemex/Manifest                  |  1 +
 sci-chemistry/chemex/chemex-2021.4.0_p4.ebuild | 46 ++++++++++++++++++++++++++
 2 files changed, 47 insertions(+)
 create mode 100644 sci-chemistry/chemex/chemex-2021.4.0_p4.ebuild

(limited to 'sci-chemistry')

diff --git a/sci-chemistry/chemex/Manifest b/sci-chemistry/chemex/Manifest
index f94b55c1cebf..9766b1db6838 100644
--- a/sci-chemistry/chemex/Manifest
+++ b/sci-chemistry/chemex/Manifest
@@ -1,2 +1,3 @@
 DIST chemex-2018.10.3.tar.gz 546696 BLAKE2B d283cfb94118686f1974780249641e0ea6f86cdb854c4a256897e361a300a94506813a5035ee2f300fca13263e8452b77e7a0817436cbd620ba16d801a541af7 SHA512 784bd03b354724d6aa52d663c6f661f865d4ef7ca345573bc8aae9ef63e5dbb3e65abba364de3ff441b78adfa588344c718809c5880b3fc70d8ed24be06a0826
 DIST chemex-2021.4.0_p2.tar.gz 2384471 BLAKE2B 1eb609c4e4ad9ac0f7cac8ab523e72e8ab9c12d40671fd598cd26b8de2a3d6e68dfdcaee9202521fc583068f591377842b3e7b9f0e1f95e6cba8da9b0c6d63a4 SHA512 568072eaf0d1c666de2aedacc50cd98da15631e0ef15ba60414be671ac97a50967e5b4d6d00340b1263f730b3a803ccc8995fbb86cfc47517b9521c9920641c8
+DIST chemex-2021.4.0_p4.tar.gz 2387888 BLAKE2B 26b4467756ba1b31775c554906a2ce09556e1fb99dd2ff294620a12b92246f441a2daa07e6bad7cedf903bd18e6ecc0613b6473f54d27d89ed9117ddc6a27269 SHA512 7d93f213317e4cb5a987c0b3cfcce146fb02a15ac9efbde74f9d3fc56a5e86c89ca6b606f45013bf08ed10f3de17cc72fa010ce0e42c5cb746119ede0ce4d38f
diff --git a/sci-chemistry/chemex/chemex-2021.4.0_p4.ebuild b/sci-chemistry/chemex/chemex-2021.4.0_p4.ebuild
new file mode 100644
index 000000000000..3a331d48eba7
--- /dev/null
+++ b/sci-chemistry/chemex/chemex-2021.4.0_p4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+DISTUTILS_SINGLE_IMPL="yes"
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+
+inherit distutils-r1
+
+DESCRIPTION="Program to fit chemical exchange induced shift and relaxation data"
+HOMEPAGE="https://github.com/gbouvignies/chemex"
+SRC_URI="https://github.com/gbouvignies/chemex/archive/${PV/_p/-dev}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+IUSE="test"
+
+#RESTRICT="!test? ( test )"
+# FIXME: Restrict until we figure out how to run tests properly, bug #815079
+RESTRICT="test"
+
+RDEPEND="
+	$(python_gen_cond_dep '
+		>=dev-python/asteval-0.9.25[${PYTHON_USEDEP}]
+		>=dev-python/jsonschema-4.1.0[${PYTHON_USEDEP}]
+		>=dev-python/lmfit-1.0.3[${PYTHON_USEDEP}]
+		>=dev-python/matplotlib-3.4.3[${PYTHON_USEDEP}]
+		>=dev-python/numpy-1.21.2[${PYTHON_USEDEP}]
+		dev-python/setuptools_scm[${PYTHON_USEDEP}]
+		>=dev-python/scipy-1.7.0[${PYTHON_USEDEP}]
+		>=dev-python/tomlkit-0.7.2[${PYTHON_USEDEP}]
+		>=dev-python/tqdm-4.61.1[${PYTHON_USEDEP}]
+	')
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest
+
+S="${WORKDIR}/ChemEx-${PV/_p/-dev}"
+
+src_prepare() {
+	export SETUPTOOLS_SCM_PRETEND_VERSION="${PV}"
+	distutils-r1_src_prepare
+}
-- 
cgit v1.2.3-65-gdbad