From 3457d37b444d703d787d030c937a45c13396f04e Mon Sep 17 00:00:00 2001
From: Michał Górny <mgorny@gentoo.org>
Date: Tue, 3 Nov 2020 23:11:23 +0100
Subject: net-misc/youtube-dl: Eliminate dep on flake8
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

Signed-off-by: Michał Górny <mgorny@gentoo.org>
---
 net-misc/youtube-dl/youtube-dl-2020.11.01.1.ebuild | 22 ++++++----------------
 1 file changed, 6 insertions(+), 16 deletions(-)

(limited to 'net-misc')

diff --git a/net-misc/youtube-dl/youtube-dl-2020.11.01.1.ebuild b/net-misc/youtube-dl/youtube-dl-2020.11.01.1.ebuild
index b1b5154480a6..0839988f367d 100644
--- a/net-misc/youtube-dl/youtube-dl-2020.11.01.1.ebuild
+++ b/net-misc/youtube-dl/youtube-dl-2020.11.01.1.ebuild
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-PYTHON_COMPAT=(python3_{6,7,8,9})
+PYTHON_COMPAT=(python3_{6..9})
 
 DISTUTILS_USE_SETUPTOOLS=rdepend
 
@@ -12,31 +12,21 @@ inherit bash-completion-r1 distutils-r1 readme.gentoo-r1
 DESCRIPTION="Download videos from YouTube.com (and more sites...)"
 HOMEPAGE="https://youtube-dl.org/ https://github.com/ytdl-org/youtube-dl/"
 SRC_URI="https://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
-LICENSE="public-domain"
+S=${WORKDIR}/${PN}
 
+LICENSE="public-domain"
 KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
 SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="
-	test? (
-		dev-python/flake8[${PYTHON_USEDEP}]
-	)
-"
 
 RDEPEND="
 	dev-python/pycryptodome[${PYTHON_USEDEP}]
 "
 
-DEPEND="${RDEPEND}"
-
 distutils_enable_tests nose
 
-S=${WORKDIR}/${PN}
-
-src_compile() {
-	distutils-r1_src_compile
+src_prepare() {
+	sed -i -e '/flake8/d' Makefile || die
+	distutils-r1_src_prepare
 }
 
 python_test() {
-- 
cgit v1.2.3-65-gdbad