From da5dea2c0efbd1c2f5222b22f3f1b84b0b686fa0 Mon Sep 17 00:00:00 2001
From: Michał Górny <mgorny@gentoo.org>
Date: Sat, 8 Oct 2022 09:13:56 +0200
Subject: dev-python/boto3: Bump to 1.24.89
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

Signed-off-by: Michał Górny <mgorny@gentoo.org>
---
 dev-python/boto3/Manifest             |  1 +
 dev-python/boto3/boto3-1.24.89.ebuild | 68 +++++++++++++++++++++++++++++++++++
 2 files changed, 69 insertions(+)
 create mode 100644 dev-python/boto3/boto3-1.24.89.ebuild

(limited to 'dev-python/boto3')

diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 4afa833ee35e..cb0b297b3ff5 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -6,3 +6,4 @@ DIST boto3-1.24.84.gh.tar.gz 542495 BLAKE2B dc120011d9e7b01beeb86d90a88f69cc232d
 DIST boto3-1.24.86.gh.tar.gz 543481 BLAKE2B 8b21852f75c4c548dc2389f5d95145b1781a7b19fe5d12fd6a352e298a3e8e4301c9b9b84c2700d8a5b1f58c4343341370c9c88ce2fcae90a3310729cd8bdf19 SHA512 a50bf8601fe479094e2868c6da43f5a6510dca6f99c74920bc7c6629cd083fbabc80e650a3baabe2f749f1dd906bc6aab73042cd269bcbb4bc8072d72707b26a
 DIST boto3-1.24.87.gh.tar.gz 543810 BLAKE2B 37713f39dcca01f9a718880fc410640b289ccc381069d5bdf5fdbef6f6b59b8d25932c5054311f1b46a90bc60ca7bbc54593ea8adcb72d156bc146a40cdc1e80 SHA512 72ba0f59b88775c40a65b59c579ba32eea3c5a8c348111b076f6f5f2dd5587b9c9b93c721fd48a8dcf8c6b419d67cec51f1b5e6a6cafe1553848db53cfaafc8b
 DIST boto3-1.24.88.gh.tar.gz 543896 BLAKE2B 9dd2a18e3fb8d0a9f3a3a1fd7d0cceb491765690f99c7bd4200f37c66cbdb1e86dcdcdd09669d3175b97e762e6faabac3a2e5cba49136f42cba459e45f3ab67f SHA512 676528ca180c23834d1666b69292754e551a339914362da2708ff3f937c2eb04fe3b3dd1d4c6960eb8f5f7f58b1e0bcf13b1f52cc16a7c8d3bd025e9ea4ee109
+DIST boto3-1.24.89.gh.tar.gz 544293 BLAKE2B 53854b91c1c4c677eee743776a67e552bd2e11947839c442d81c1983930d6ff16d6bc5483c29b9a14b99a7cef09f3b9cd74cea9edb1cb76ff5458be3c9743164 SHA512 ef3b503b1313b8b7d84f5e4afdbe4e3d9e95ce3fbba81d400191295c71d4237e764f87ab6ebf2b29536248a520ab1273bee43bedd746596224f7400ce04c2c02
diff --git a/dev-python/boto3/boto3-1.24.89.ebuild b/dev-python/boto3/boto3-1.24.89.ebuild
new file mode 100644
index 000000000000..6edcc751d54b
--- /dev/null
+++ b/dev-python/boto3/boto3-1.24.89.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+	https://github.com/boto/boto3/
+	https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+	EGIT_REPO_URI="https://github.com/boto/boto3"
+	inherit git-r3
+	BOTOCORE_PV=${PV}
+else
+	SRC_URI="
+		https://github.com/boto/boto3/archive/${PV}.tar.gz
+			-> ${P}.gh.tar.gz
+	"
+	KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+	# botocore is x.(y+3).z
+	BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+	>=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+	>=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+	>=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+	test? (
+		dev-python/mock[${PYTHON_USEDEP}]
+		dev-python/pytest-xdist[${PYTHON_USEDEP}]
+	)
+"
+
+distutils_enable_sphinx docs/source \
+	'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+	# don't lock versions to narrow ranges
+	sed -e '/botocore/ d' \
+		-e '/jmespath/ d' \
+		-e '/s3transfer/ d' \
+		-i setup.py || die
+
+	# do not rely on bundled deps in botocore (sic!)
+	find -name '*.py' -exec sed -i \
+		-e 's:from botocore[.]vendored import:import:' \
+		-e 's:from botocore[.]vendored[.]:from :' \
+		{} + || die
+
+	distutils-r1_python_prepare_all
+}
+
+python_test() {
+	epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}
-- 
cgit v1.2.3-65-gdbad