summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/uksmd/Manifest1
-rw-r--r--sys-process/uksmd/files/uksmd-6.4.1-systemd-automagic.patch47
-rw-r--r--sys-process/uksmd/uksmd-6.4.1.ebuild43
3 files changed, 91 insertions, 0 deletions
diff --git a/sys-process/uksmd/Manifest b/sys-process/uksmd/Manifest
index 7d2129381c07..323195096417 100644
--- a/sys-process/uksmd/Manifest
+++ b/sys-process/uksmd/Manifest
@@ -1 +1,2 @@
DIST uksmd-0_pre20220705.tar.gz 15715 BLAKE2B f104a804cff15eb6b3a4ffd71180d67054f4e7c4ebbe10438f76aef96ca3d83740b24390183110a26691ebb832d6740765ab7ca5b7862a8d9afe09d1cacdc4d0 SHA512 a0e99e80e22e988ce98f790d5cc693a5b961e40ffa9650002c4ff39edb148b1586ded6b8321f5ea012f674ef8cbd03daca24dca557a773e23e83a373553f7ba9
+DIST uksmd-6.4.1.tar.gz 16790 BLAKE2B 284302f0a77684fc00d16faf868d857adf539840ea26746dd9774a1501b3361afa58a77dd74bd40680c32a7b1baf632d60d52fae3c031d1be69c8f17e6bbf73d SHA512 ea851a75b7afd4d9c789f31ca473f2c265b0633c86e38b26ec3602dfa3e63e6bea13caca551aba08c5093332cfbb485f40cb96254c39eb083ab66d6256661dd4
diff --git a/sys-process/uksmd/files/uksmd-6.4.1-systemd-automagic.patch b/sys-process/uksmd/files/uksmd-6.4.1-systemd-automagic.patch
new file mode 100644
index 000000000000..7f897731737f
--- /dev/null
+++ b/sys-process/uksmd/files/uksmd-6.4.1-systemd-automagic.patch
@@ -0,0 +1,47 @@
+https://codeberg.org/pf-kernel/uksmd/pulls/5
+
+From 0ed68078ed829ff03f95d01f0079485966e3c07a Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Sun, 3 Sep 2023 07:21:56 +0100
+Subject: [PATCH] meson: add systemd option
+
+We may not always want to link against systemd even if installed - consider
+the case where a user is switching from systemd->another init system, systemd
+may still be installed temporarily but the user wants to rebuild without it.
+
+This perserves the default behaviour of using systemd if available.
+
+Signed-off-by: Sam James <sam@gentoo.org>
+---
+ meson.build | 2 +-
+ meson_options.txt | 6 ++++++
+ 2 files changed, 7 insertions(+), 1 deletion(-)
+ create mode 100644 meson_options.txt
+
+diff --git a/meson.build b/meson.build
+index 7170db8..bf0b119 100644
+--- a/meson.build
++++ b/meson.build
+@@ -18,7 +18,7 @@ build_args = [
+ '-DPROJECT_VERSION="' + meson.project_version() + '"',
+ ]
+
+-systemd = dependency('systemd', required: false)
++systemd = dependency('systemd', required: get_option('systemd'))
+
+ if systemd.found()
+ systemd_system_unit_dir = systemd.get_variable(pkgconfig : 'systemdsystemunitdir')
+diff --git a/meson_options.txt b/meson_options.txt
+new file mode 100644
+index 0000000..3a8cdd4
+--- /dev/null
++++ b/meson_options.txt
+@@ -0,0 +1,6 @@
++option(
++ 'systemd',
++ type: 'feature',
++ value: 'auto',
++ description: 'sd-notify support via libsystemd and install systemd unit files'
++)
+--
+2.30.8
diff --git a/sys-process/uksmd/uksmd-6.4.1.ebuild b/sys-process/uksmd/uksmd-6.4.1.ebuild
new file mode 100644
index 000000000000..3977cb96df11
--- /dev/null
+++ b/sys-process/uksmd/uksmd-6.4.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info meson
+
+DESCRIPTION="Userspace KSM helper daemon"
+HOMEPAGE="https://codeberg.org/pf-kernel/uksmd"
+SRC_URI="https://codeberg.org/pf-kernel/uksmd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="systemd"
+
+DEPEND="
+ sys-libs/libcap-ng
+ >=sys-process/procps-4:=
+ systemd? ( sys-apps/systemd:= )
+"
+RDEPEND="${DEPEND}"
+
+CONFIG_CHECK="~KSM"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.4.1-systemd-automagic.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature systemd)
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ newinitd "${FILESDIR}/uksmd.init" uksmd
+}