summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/system-monitoring-center/system-monitoring-center-2.17.1.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/sys-apps/system-monitoring-center/system-monitoring-center-2.17.1.ebuild b/sys-apps/system-monitoring-center/system-monitoring-center-2.17.1.ebuild
index 1274d6fa96c9..454faee2164e 100644
--- a/sys-apps/system-monitoring-center/system-monitoring-center-2.17.1.ebuild
+++ b/sys-apps/system-monitoring-center/system-monitoring-center-2.17.1.ebuild
@@ -9,12 +9,18 @@ inherit meson python-single-r1 xdg
DESCRIPTION="Multi-featured system monitor GUI written in Python"
HOMEPAGE="https://github.com/hakandundar34coding/system-monitoring-center/"
-SRC_URI="https://github.com/hakandundar34coding/${PN}/archive/v${PV}.tar.gz
- -> ${P}.tar.gz"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/hakandundar34coding/${PN}.git"
+else
+ SRC_URI="https://github.com/hakandundar34coding/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
LICENSE="GPL-3+"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="