summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/tuned/tuned-2.16.0.ebuild')
-rw-r--r--sys-apps/tuned/tuned-2.16.0.ebuild69
1 files changed, 0 insertions, 69 deletions
diff --git a/sys-apps/tuned/tuned-2.16.0.ebuild b/sys-apps/tuned/tuned-2.16.0.ebuild
deleted file mode 100644
index 7ce4188e8394..000000000000
--- a/sys-apps/tuned/tuned-2.16.0.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8,9} )
-
-inherit optfeature python-single-r1 tmpfiles xdg-utils
-
-DESCRIPTION="Daemon for monitoring and adaptive tuning of system devices"
-HOMEPAGE="https://github.com/redhat-performance/tuned"
-SRC_URI="https://github.com/redhat-performance/tuned/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="
- ${PYTHON_DEPS}
- $(python_gen_cond_dep '
- dev-python/configobj[${PYTHON_USEDEP}]
- dev-python/dbus-python[${PYTHON_USEDEP}]
- dev-python/decorator[${PYTHON_USEDEP}]
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- dev-python/python-linux-procfs[${PYTHON_USEDEP}]
- dev-python/pyudev[${PYTHON_USEDEP}]
- ')"
-
-RDEPEND="
- ${DEPEND}
- app-emulation/virt-what
- dev-util/systemtap
- sys-apps/dbus
- sys-apps/ethtool
- sys-power/powertop
- "
-
-RESTRICT="test"
-
-src_prepare() {
- default
-
- sed -i \
- -e "/^PYTHON/s:/usr/bin/python3:${EPREFIX}/usr/bin/${EPYTHON}:" \
- -e "/^export DOCDIR/s/$/&\-\$(VERSION)/g" \
- -e "/\$(DESTDIR)\/run\/tuned/d" \
- -e "/\$(DESTDIR)\/var\/lib\/tuned/d" \
- -e "/\$(DESTDIR)\/var\/log\/tuned/d" \
- Makefile || die
-}
-
-src_install() {
- default
-
- newinitd "${FILESDIR}/${PN}.initd" "${PN}"
- python_fix_shebang "${D}"
- python_optimize
-}
-
-pkg_postinst() {
- tmpfiles_process ${PN}.conf
- xdg_icon_cache_update
-
- optfeature_header
- optfeature "Optimize for power saving by spinning-down rotational disks" sys-apps/hdparm
- optfeature "Get hardware info" sys-apps/dmidecode
-}