summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/yatebts')
-rw-r--r--net-wireless/yatebts/files/yatebts-6.0.0-dont-mess-with-cflags.patch12
-rw-r--r--net-wireless/yatebts/yatebts-6.0.0.ebuild12
-rw-r--r--net-wireless/yatebts/yatebts-9999.ebuild12
3 files changed, 26 insertions, 10 deletions
diff --git a/net-wireless/yatebts/files/yatebts-6.0.0-dont-mess-with-cflags.patch b/net-wireless/yatebts/files/yatebts-6.0.0-dont-mess-with-cflags.patch
new file mode 100644
index 000000000000..c6827eb90952
--- /dev/null
+++ b/net-wireless/yatebts/files/yatebts-6.0.0-dont-mess-with-cflags.patch
@@ -0,0 +1,12 @@
+--- configure.ac 2017-09-07 10:21:08.000000000 -0400
++++ configure-sane.ac 2018-02-16 15:26:43.884257256 -0500
+@@ -38,9 +38,6 @@
+ AC_PROG_CC
+ AC_PROG_AWK
+
+-# Delete -g as we handle debug info at build time
+-CFLAGS=`echo "$CFLAGS" | sed 's/\(^\| \+\)-g[[0-9]]*//' 2>/dev/null`
+-
+ # Helper to check by pkgconfig including local paths
+ function pkgconfig_check()
+ {
diff --git a/net-wireless/yatebts/yatebts-6.0.0.ebuild b/net-wireless/yatebts/yatebts-6.0.0.ebuild
index 3a932f78012c..8dd83f84e584 100644
--- a/net-wireless/yatebts/yatebts-6.0.0.ebuild
+++ b/net-wireless/yatebts/yatebts-6.0.0.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
inherit eutils autotools
@@ -34,15 +34,17 @@ src_prepare() {
#we need more patches or configure flags because things install in really wrong places per FHS
epatch "${FILESDIR}"/${PN}-sgsnggsn-inetutils-hostname-fix.diff
epatch "${FILESDIR}"/${PN}-5.0.0-gcc6.patch
+ epatch "${FILESDIR}"/${P}-dont-mess-with-cflags.patch
+ default
eautoreconf
}
+# $(use_enable rad1) \
+# $(use_enable usrp1) \
+# $(use_enable uhd) \
+# $(use_enable bladerf) \
src_configure() {
econf \
- $(use_enable rad1) \
- $(use_enable usrp1) \
- $(use_enable uhd) \
- $(use_enable bladerf) \
$(use_enable cpu_flags_x86_sse3 sse3) \
$(use_enable cpu_flags_x86_sse4_1 sse41)
diff --git a/net-wireless/yatebts/yatebts-9999.ebuild b/net-wireless/yatebts/yatebts-9999.ebuild
index 3a932f78012c..8dd83f84e584 100644
--- a/net-wireless/yatebts/yatebts-9999.ebuild
+++ b/net-wireless/yatebts/yatebts-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
inherit eutils autotools
@@ -34,15 +34,17 @@ src_prepare() {
#we need more patches or configure flags because things install in really wrong places per FHS
epatch "${FILESDIR}"/${PN}-sgsnggsn-inetutils-hostname-fix.diff
epatch "${FILESDIR}"/${PN}-5.0.0-gcc6.patch
+ epatch "${FILESDIR}"/${P}-dont-mess-with-cflags.patch
+ default
eautoreconf
}
+# $(use_enable rad1) \
+# $(use_enable usrp1) \
+# $(use_enable uhd) \
+# $(use_enable bladerf) \
src_configure() {
econf \
- $(use_enable rad1) \
- $(use_enable usrp1) \
- $(use_enable uhd) \
- $(use_enable bladerf) \
$(use_enable cpu_flags_x86_sse3 sse3) \
$(use_enable cpu_flags_x86_sse4_1 sse41)