summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps/calendarjanitor')
-rw-r--r--kde-apps/calendarjanitor/Manifest1
-rw-r--r--kde-apps/calendarjanitor/calendarjanitor-22.08.3.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/kde-apps/calendarjanitor/Manifest b/kde-apps/calendarjanitor/Manifest
index 73140721317c..83c3b673a419 100644
--- a/kde-apps/calendarjanitor/Manifest
+++ b/kde-apps/calendarjanitor/Manifest
@@ -1,2 +1,3 @@
DIST akonadi-calendar-tools-22.04.3.tar.xz 237900 BLAKE2B 5f9f524a34fc934fcfea44e21584c154770d47408e37140901c14c90527cbb0430fa51d9318711362e572fa8fda710624e076596cb1446e999f978290632ac6b SHA512 781c94f2a4cdd4caec650d74efc0b8c0b2b54fbb5eca7ff6fc22190d7fca600832ac8aa6eb6b62ac3d367916d94a3512cade35b521cb5da19cda69216f06abd0
DIST akonadi-calendar-tools-22.08.2.tar.xz 238304 BLAKE2B 878fcdff9329e8b261dd66296d89b55a75f2e2da7ece29aeedffd7f0c002906c05ca3d028ed7b3904a1d677f247e9612d078ab09110c2aed79142d26d5702e21 SHA512 71e1eb03e655d7cda4e79cb54c9c04f59d137a087da00d0447296b9a257a8a25abc84c0ddeeeb0b89d3185d530a8c34db30badada8cf3586eed3c966d8dea026
+DIST akonadi-calendar-tools-22.08.3.tar.xz 238252 BLAKE2B 5a07fcd1cef621640995f25a90ffea57bcd47d870234e2d763b348bc0d4fa897f14c6efdcf404b03f3af0fa78fe8dfe858f84b1584bf824556e38e247f467980 SHA512 ffcdc6b41d58fbfc438187eab083946d62d73abeffa7d6de75e219eff58ca6d384c9c69413f0cb0d6811e7337eddada34d818f4ea0c079c10a3012ad90c5bc62
diff --git a/kde-apps/calendarjanitor/calendarjanitor-22.08.3.ebuild b/kde-apps/calendarjanitor/calendarjanitor-22.08.3.ebuild
new file mode 100644
index 000000000000..baa283ab21c7
--- /dev/null
+++ b/kde-apps/calendarjanitor/calendarjanitor-22.08.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="forceoptional" # FIXME: Check back for doc in release
+ECM_TEST="false"
+KDE_ORG_NAME="akonadi-calendar-tools"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.96.0
+QTMIN=5.15.5
+inherit ecm gear.kde.org
+
+DESCRIPTION="Tool to scan calendar data for buggy instances"
+
+LICENSE="GPL-2+ handbook? ( FDL-1.2+ )"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-apps/akonadi-${PVCUT}:5
+ >=kde-apps/akonadi-calendar-${PVCUT}:5
+ >=kde-apps/calendarsupport-${PVCUT}:5
+ >=kde-frameworks/kcalendarcore-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ ecm_src_prepare
+
+ cmake_comment_add_subdirectory doc konsolekalendar
+ sed -i -e "/console\.categories/ s/^/#DONT/" CMakeLists.txt || die
+
+ # delete colliding konsolekalendar translations
+ if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ rm -f po/*/konsolekalendar.po || die
+ rm -rf po/*/docs/konsolekalendar || die
+ fi
+}