summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/freezegun/Manifest1
-rw-r--r--dev-python/freezegun/freezegun-1.5.1.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/freezegun/Manifest b/dev-python/freezegun/Manifest
index 26de7f74da1e..c3803c16290a 100644
--- a/dev-python/freezegun/Manifest
+++ b/dev-python/freezegun/Manifest
@@ -1 +1,2 @@
DIST freezegun-1.5.0.tar.gz 33167 BLAKE2B 3cf05a41c4d66ded61a67385faa07ad80348ad7620db6076f1371d1707b9f6229d85bf2f87ff3533a9529f9d6c30e5f5bcdaf0a499b1e73760070ee5706936b9 SHA512 65d3c95e4992d80c104d52e1164662308aea0884e4a0bb1343f028e514519548dd295dca7dd97d06aaa57a61c0c71fae0bd040f944936858e0f72b2a08860694
+DIST freezegun-1.5.1.tar.gz 33697 BLAKE2B bb08703a7e6f6f4a2145c4dc7b10245af3ced5d1a0a9355df74acd03bfe1687ee22e54ffbbd791204a497b50d4a2c578eb531379dd9e55d274ede72785bb39fa SHA512 384122e31c1db90d4c30cc60ad6d693209c933538e4d507a45c6ff116dcfe2f5f2602116c31aae4576da876ea327d502b01f651414d41b6cb11cc6e98d2aacbc
diff --git a/dev-python/freezegun/freezegun-1.5.1.ebuild b/dev-python/freezegun/freezegun-1.5.1.ebuild
new file mode 100644
index 000000000000..63b9ab74ac9a
--- /dev/null
+++ b/dev-python/freezegun/freezegun-1.5.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Let your Python tests travel through time"
+HOMEPAGE="
+ https://github.com/spulec/freezegun/
+ https://pypi.org/project/freezegun/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+RDEPEND="
+ >dev-python/python-dateutil-2.7[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ case ${EPYTHON} in
+ python3.13)
+ EPYTEST_DESELECT+=(
+ # https://github.com/spulec/freezegun/issues/547
+ tests/test_datetimes.py::TestUnitTestMethodDecorator::test_method_decorator_works_on_unittest_kwarg_frozen_time
+ tests/test_datetimes.py::TestUnitTestMethodDecorator::test_method_decorator_works_on_unittest_kwarg_frozen_time_with_func
+ tests/test_datetimes.py::TestUnitTestMethodDecorator::test_method_decorator_works_on_unittest_kwarg_hello
+ )
+ ;;
+ esac
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}