summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/venusian/venusian-1.0.ebuild')
-rw-r--r--dev-python/venusian/venusian-1.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/venusian/venusian-1.0.ebuild b/dev-python/venusian/venusian-1.0.ebuild
new file mode 100644
index 000000000000..c9129cf24138
--- /dev/null
+++ b/dev-python/venusian/venusian-1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+#RESTRICT="test"
+
+inherit distutils-r1
+
+DESCRIPTION="A library for deferring decorator actions"
+HOMEPAGE="http://www.pylonsproject.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="repoze"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+RDEPEND="
+ "
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ ~dev-python/nose-exclude-0.1.9[${PYTHON_USEDEP}] )
+ "
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}