summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/mypy_extensions')
-rw-r--r--dev-python/mypy_extensions/Manifest1
-rw-r--r--dev-python/mypy_extensions/mypy_extensions-0.4.4.ebuild34
2 files changed, 0 insertions, 35 deletions
diff --git a/dev-python/mypy_extensions/Manifest b/dev-python/mypy_extensions/Manifest
index 0840369f50a1..edb1536892fa 100644
--- a/dev-python/mypy_extensions/Manifest
+++ b/dev-python/mypy_extensions/Manifest
@@ -1,2 +1 @@
-DIST mypy_extensions-0.4.4.gh.tar.gz 5555 BLAKE2B 89852229a2c37994aac1bdb0026a14489ea51b44286371d6b4711ad9b9df9a9827fd9b32bc7f2768b7e5890481560bd7221e1262f3e27b69fe964f9e0eb081e0 SHA512 86fe3cc95b856476e2f8df7f64084277411435a17726407fbd9a114e5684b8ffb0da1cf9eb3a17e19152e7958efcfaf57bf7236bcefe6eb7f4098b14ed302949
DIST mypy_extensions-1.0.0.gh.tar.gz 6097 BLAKE2B 099616ee0bacad62d9ce642c3adb1eebe27546f7c567d1e0fa6ec04d9e6cbcda2966fff9769940cfda8b7d6cc9f33100af9d6f416ab2def26079668a16c354b3 SHA512 ac89a9f60a2c3df3457d5a6ab7ed47b72dd173646ef57f1450556051617e62046405a69fadeb40d2c24e68ce6ffed56d9182365e3203477facdc935e1a807847
diff --git a/dev-python/mypy_extensions/mypy_extensions-0.4.4.ebuild b/dev-python/mypy_extensions/mypy_extensions-0.4.4.ebuild
deleted file mode 100644
index 774c63b65ce9..000000000000
--- a/dev-python/mypy_extensions/mypy_extensions-0.4.4.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-DISTUTILS_USE_PEP517=setuptools
-
-inherit distutils-r1
-
-DESCRIPTION="Optional static typing for Python"
-HOMEPAGE="
- https://www.mypy-lang.org/
- https://github.com/python/mypy_extensions/
-"
-SRC_URI="
- https://github.com/python/mypy_extensions/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # This test assumes we get a TypeError, but that is no longer true in 3.11
- "tests/testextensions.py::TypedDictTests::test_typeddict_errors"
-)
-
-python_test() {
- epytest tests/*.py
-}