summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/OpenGL/files/OpenGL-0.66-no-display.patch')
-rw-r--r--dev-perl/OpenGL/files/OpenGL-0.66-no-display.patch50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-perl/OpenGL/files/OpenGL-0.66-no-display.patch b/dev-perl/OpenGL/files/OpenGL-0.66-no-display.patch
new file mode 100644
index 000000000000..6bdc334ba0b1
--- /dev/null
+++ b/dev-perl/OpenGL/files/OpenGL-0.66-no-display.patch
@@ -0,0 +1,50 @@
+Don't check current display for extensions, build all.
+
+diff -up OpenGL-0.62/Makefile.PL.dist OpenGL-0.62/Makefile.PL
+--- OpenGL-0.62/Makefile.PL.dist 2009-12-11 01:10:00.000000000 +0100
++++ OpenGL-0.62/Makefile.PL 2010-01-07 13:00:26.000000000 +0100
+@@ -579,9 +579,9 @@ my $build_config =
+ {
+ FILES =>
+ "Config.pm ".
+- "utils/glversion.txt ".
+- "utils/glversion$Config{exe_ext} ".
+- "utils/glversion$Config{obj_ext}"
++ "utils/glversion.txt "
++ #"utils/glversion$Config{exe_ext} ".
++ #"utils/glversion$Config{obj_ext}"
+ }
+ };
+
+@@ -790,6 +790,7 @@ sub get_extensions
+ print "GLUT not found\n";
+ }
+
++=cut
+ # Platform-specific makefiles for glversion
+ my $make_ver;
+ if ($IS_MINGW)
+@@ -848,7 +849,9 @@ sub get_extensions
+ print "get_extensions: no extensions found in $glv_file\n" if $verbose;
+ return '';
+ }
+-
++=cut
++ use Config;
++ my $gldata = { };
+
+ # Parse glext_procs.h file
+ return '' if (!open(GLEXT,"glext_procs.h"));
+@@ -867,10 +870,12 @@ sub get_extensions
+
+ # Create gl_exclude.h
+ die "Unable to write to $exc_file\n" if (!open(GLEXC,">$exc_file"));
++=cut
+ print GLEXC "// OpenGL Extension Exclusions - may be modified before building.\n";
+ print GLEXC "//\n";
+ print GLEXC "// Generated for ".$gldata->{VENDOR}.", ".$gldata->{RENDERER}."\n";
+ print GLEXC "// OpenGL v".$gldata->{VERSION}.", using ";
++=cut
+
+ # Fix GLUT flags based on results
+ if ($gldata->{GLUT} > 0)