summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/hoauth2/hoauth2-0.4.6.ebuild')
-rw-r--r--dev-haskell/hoauth2/hoauth2-0.4.6.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-haskell/hoauth2/hoauth2-0.4.6.ebuild b/dev-haskell/hoauth2/hoauth2-0.4.6.ebuild
new file mode 100644
index 000000000000..81339caefaa4
--- /dev/null
+++ b/dev-haskell/hoauth2/hoauth2-0.4.6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Haskell OAuth2 authentication"
+HOMEPAGE="https://github.com/freizl/hoauth2"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RESTRICT=test # missing files
+
+RDEPEND=">=dev-haskell/aeson-0.7:=[profile?] <dev-haskell/aeson-0.9:=[profile?]
+ >=dev-haskell/http-conduit-2.0:=[profile?] <dev-haskell/http-conduit-2.2:=[profile?]
+ >=dev-haskell/http-types-0.8:=[profile?] <dev-haskell/http-types-0.9:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+"
+
+src_prepare() {
+ cabal_chdeps \
+ 'bytestring >= 0.10.4 && < 0.10.5' 'bytestring >= 0.10.4'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag test test)
+}