summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/glib/glib-0.12.3.1.ebuild')
-rw-r--r--dev-haskell/glib/glib-0.12.3.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-haskell/glib/glib-0.12.3.1.ebuild b/dev-haskell/glib/glib-0.12.3.1.ebuild
new file mode 100644
index 000000000000..40f617e54d3a
--- /dev/null
+++ b/dev-haskell/glib/glib-0.12.3.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+#nocabaldep is for the fancy cabal-detection feature at build-time
+CABAL_FEATURES="lib profile haddock hscolour hoogle nocabaldep"
+inherit haskell-cabal
+
+DESCRIPTION="Binding to the GLIB library for Gtk2Hs"
+HOMEPAGE="http://projects.haskell.org/gtk2hs/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.10.1
+ dev-libs/glib:2"
+DEPEND="${RDEPEND}
+ dev-haskell/gtk2hs-buildtools:0"
+
+src_prepare() {
+ # c2hs ignores #if __GLASGOW_HASKELL__ >= 706
+ # I do not know which earlier ghc versions the patch submitted upstream works with
+ if has_version ">=dev-lang/ghc-7.6.1"; then
+ epatch "${FILESDIR}/${PN}-0.12.3.1-ghc-7.6.patch"
+ fi
+}