summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/filebeat-bin/filebeat-bin-1.0.0.ebuild6
-rw-r--r--app-admin/filebeat-bin/files/filebeat.yml.example14
2 files changed, 3 insertions, 17 deletions
diff --git a/app-admin/filebeat-bin/filebeat-bin-1.0.0.ebuild b/app-admin/filebeat-bin/filebeat-bin-1.0.0.ebuild
index 9d5192573345..a6d18e4ed2ce 100644
--- a/app-admin/filebeat-bin/filebeat-bin-1.0.0.ebuild
+++ b/app-admin/filebeat-bin/filebeat-bin-1.0.0.ebuild
@@ -36,12 +36,12 @@ src_install() {
fperms 0750 /var/lib/${MY_PN}
- insinto /etc/${MY_PN}
- doins "${FILESDIR}/filebeat.yml.example"
-
newconfd "${FILESDIR}/${MY_PN}.confd" ${MY_PN}
newinitd "${FILESDIR}/${MY_PN}.initd" ${MY_PN}
+ insinto /etc/${MY_PN}
+ newins ${MY_PN}.yml ${MY_PN}.yml.example
+
dobin ${MY_PN}
}
diff --git a/app-admin/filebeat-bin/files/filebeat.yml.example b/app-admin/filebeat-bin/files/filebeat.yml.example
deleted file mode 100644
index 06c599cc6f37..000000000000
--- a/app-admin/filebeat-bin/files/filebeat.yml.example
+++ /dev/null
@@ -1,14 +0,0 @@
-filebeat:
- prospectors:
- -
- paths:
- - /var/log/*.log
- - /var/log/debug
- - /var/log/messages
- - /var/log/syslog
- input_type: log
-
-output:
- elasticsearch:
- hosts: ["localhost:9200"]
- index: "logstash"