summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2023-05-19 08:49:20 -0400
committerCraig Andrews <candrews@gentoo.org>2023-05-19 08:50:02 -0400
commit95056771f68ab72469964a6ed849c2314df891eb (patch)
tree8cacac08ba52035094c6ba41ed9e9076e7ebc49b /www-apache
parentdev-games/godot: add 4.0.3 (diff)
downloadgentoo-95056771f68ab72469964a6ed849c2314df891eb.tar.gz
gentoo-95056771f68ab72469964a6ed849c2314df891eb.tar.bz2
gentoo-95056771f68ab72469964a6ed849c2314df891eb.zip
www-apache/mod_qos: add 11.74
Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_qos/Manifest1
-rw-r--r--www-apache/mod_qos/mod_qos-11.74.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/www-apache/mod_qos/Manifest b/www-apache/mod_qos/Manifest
index 1efb04766656..5dac670c3844 100644
--- a/www-apache/mod_qos/Manifest
+++ b/www-apache/mod_qos/Manifest
@@ -3,3 +3,4 @@ DIST mod_qos-11.70.tar.gz 1283241 BLAKE2B 516dc8ec0228956c374845e10ed2533291544c
DIST mod_qos-11.71.tar.gz 1282858 BLAKE2B 92061497a6f31c009c5dbd7d0bf9042272b679e7b2f1bf5fdf9a52dc3b9cf9ea13fae6a6bd422d652466a5d1ac4355b7cc33f2d183900a64eddce3de97e96e82 SHA512 2550d868a03b7add5a48a4cd43a5287317142c879777e6d38c15270a8bbef1e2a639f938d996645bb2cace40dc6806094fc4a80e2a9b5b4e5ccc60bd35244cc8
DIST mod_qos-11.72.tar.gz 1283276 BLAKE2B 1769a7198f5569b2c205a0939928f6949e950d41f54765ee1a055606df139c7e7dad4ad7d6161dbf07003a93d54b966b15d20fc721a6ba05cba221e1cae126d8 SHA512 0e5af2c702bade096101f20fcf12b90a2a538665cfbec4183608acdfdc99552304ad4a42f63ad3111b570bfd42b17ce7acb16f6bc86a0380c79fae84a5124715
DIST mod_qos-11.73.tar.gz 1288540 BLAKE2B 74953216f8dd1e5cacda09dfbeb8901a09f2c1d7929db2846f8576a4ae00123a7120385e6d77438c2d4fb33c5602e84a4737033281b7c647ba249629da0b26ce SHA512 67099a7efe2cb99191e4af1eb2f23ce9ba609425520c95360ae064dd9b88cd7ce6b3a3af21ee5805d3e26721637433a0436c1b1633d109e98613593544767ebd
+DIST mod_qos-11.74.tar.gz 1288870 BLAKE2B b61622c89c797b567744f557c9cbbf791db3f19d6fa736197d5ac95929aa7a93989c804edd6a8c8f5d567ca7ba43203003654a9d47e18cc228da95fbeafc60f4 SHA512 107eab22336741ab9415d9f6925ff2b38edf9cdfa81dd76f782a5388420c19f554e1280e0fe26788014bc0f24b2906c812fb2fcf04ce4b08d06c5770bf158d48
diff --git a/www-apache/mod_qos/mod_qos-11.74.ebuild b/www-apache/mod_qos/mod_qos-11.74.ebuild
new file mode 100644
index 000000000000..1c3182af2600
--- /dev/null
+++ b/www-apache/mod_qos/mod_qos-11.74.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools apache-module
+
+DESCRIPTION="A QOS module for the apache webserver"
+HOMEPAGE="http://mod-qos.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mod-qos/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/libpcre2
+ dev-libs/openssl:0=
+ media-libs/libpng:0=
+ sys-libs/zlib:0=
+"
+DEPEND="${RDEPEND}"
+
+APXS2_S="${S}/apache2"
+APACHE2_MOD_CONF="10_${PN}"
+APACHE2_MOD_DEFINE="QOS"
+DOCFILES="${S}/doc/*.txt ${S}/README.TXT"
+
+need_apache2
+
+pkg_setup() {
+ _init_apache2
+ _init_apache2_late
+}
+src_prepare() {
+ default
+
+ pushd "${S}"/tools &>/dev/null || die
+ eautoreconf
+ popd &>/dev/null || die
+}
+
+src_configure() {
+ pushd "${S}"/tools &>/dev/null || die
+ econf
+ popd &>/dev/null || die
+}
+
+src_compile() {
+ apache-module_src_compile
+ emake -C "${S}"/tools
+}
+
+src_install() {
+ einfo "Installing Apache module ..."
+ pushd "${S}"/tools &>/dev/null || die
+ apache-module_src_install
+ popd &>/dev/null || die
+
+ einfo "Installing module utilities ..."
+ emake -C "${S}"/tools install DESTDIR="${D}"
+}