summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2023-12-03 06:12:25 -0500
committerMike Pagano <mpagano@gentoo.org>2023-12-03 06:12:25 -0500
commit2c169c38da335a1adca4eb51fa02a3d9c1bc0b0b (patch)
tree1e2d58c44de2583d9a13e9b423c5e01b3e0be3e0 /sys-kernel/git-sources
parentnet-misc/dhcpcd: Stabilize 10.0.5-r1 ppc, #919111 (diff)
downloadgentoo-2c169c38da335a1adca4eb51fa02a3d9c1bc0b0b.tar.gz
gentoo-2c169c38da335a1adca4eb51fa02a3d9c1bc0b0b.tar.bz2
gentoo-2c169c38da335a1adca4eb51fa02a3d9c1bc0b0b.zip
sys-kernel/git-sources: add 6.7_rc4
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'sys-kernel/git-sources')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-6.7_rc4.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index 2342f2f7a621..6ad911017ff1 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -2,3 +2,4 @@ DIST linux-6.6.tar.xz 140064536 BLAKE2B 5f02fd8696d42f7ec8c5fbadec8e7270bdcfcb1f
DIST patch-6.7-rc1.patch 71642632 BLAKE2B ee6626c1474208c5f2874a626bac389bf9581a57787db66e4e92fa0a651d74eee8f1476899e01f5732f4236aead6eda529ac7cebf63510f954cc18dbc0a4c970 SHA512 709c6008267440d1633651733923f625944aef633e4243dc59cf631cf42439dee53811be62ee8b8126d1ba477f13fec799a670cdbdb228e433c29cb31224b942
DIST patch-6.7-rc2.patch 72006720 BLAKE2B 3c6fa7423f67b81d45edb526205dd53bc23d9ffa5f785711af8350c86421b5989e0468ea54831e2c3065a4f3bfd6e46ce82752a7a562edc4d639468549e21a9d SHA512 16f3ba44a741b33aa160b401df766dc6d928ebf671b178fe854abb6b05912033fddbdbbb9b80e9e8399f523b2905aa96456ee3cd0018b72391e445590a6f4ccd
DIST patch-6.7-rc3.patch 72363721 BLAKE2B 1afb63acd48364195e876515e11b71b19b5415c80ccea7cfc199265ad16a9b639d0580bcff35170da38b37d3fd2996c25872c0091c1d4c755f936ebced9d5c08 SHA512 e21b1597864babee6cd0a641c1ffb36d7262650937c0c7ad234ce33ad22ca1ad1969cb9ec8652395e109904c0b66898dd36c19e761bef6cabaa80d57b552cf03
+DIST patch-6.7-rc4.patch 72676847 BLAKE2B f81414a35d846b7cca8192d7c0b5df98555f1a7d83c386ce73c0d4a47774c93703e6de01e68e9df8f826b9fcf376924108d119c490efa155a76f3333fee187f5 SHA512 4f6ea1d3f15108ddf3a291079024debccded77d91819e30488a945f23c93955b06aa3647f93ff224e38a98f1b8736dcc05c3f769b1513d6e577783329545a032
diff --git a/sys-kernel/git-sources/git-sources-6.7_rc4.ebuild b/sys-kernel/git-sources/git-sources-6.7_rc4.ebuild
new file mode 100644
index 000000000000..46873aec3fec
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-6.7_rc4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="6.6"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+K_NODRYRUN="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.6-r4"
+
+pkg_postinst() {
+ postinst_sources
+}