summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-06 16:16:38 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-06 16:34:17 +0100
commit30f64b6f188e74c328f89d8c5b3f7c45ec7b3f76 (patch)
tree2a11252376efaa900151fe9e7c1b7ee50f413d3a /sys-devel
parentllvm.eclass: Allow slot 15 (diff)
downloadgentoo-30f64b6f188e74c328f89d8c5b3f7c45ec7b3f76.tar.gz
gentoo-30f64b6f188e74c328f89d8c5b3f7c45ec7b3f76.tar.bz2
gentoo-30f64b6f188e74c328f89d8c5b3f7c45ec7b3f76.zip
sys-devel/llvm-common: Add 15.x live ebuild
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/llvm-common/llvm-common-15.0.0.9999.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-devel/llvm-common/llvm-common-15.0.0.9999.ebuild b/sys-devel/llvm-common/llvm-common-15.0.0.9999.ebuild
new file mode 100644
index 000000000000..fdadac15eda6
--- /dev/null
+++ b/sys-devel/llvm-common/llvm-common-15.0.0.9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit llvm.org
+
+DESCRIPTION="Common files shared between multiple slots of LLVM"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="!sys-devel/llvm:0"
+
+LLVM_COMPONENTS=( llvm/utils/vim )
+llvm.org_set_globals
+
+src_install() {
+ insinto /usr/share/vim/vimfiles
+ doins -r */
+ # some users may find it useful
+ newdoc README README.vim
+ dodoc vimrc
+}