summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-08-04 16:45:47 +0200
committerDavid Seifert <soap@gentoo.org>2021-08-04 16:45:47 +0200
commit707e13168685bb9866b0cf05bfb1d875f59cbea8 (patch)
tree86981d6fa59848b2a6afdd468f2a52d770468915 /net-misc/shigofumi
parentnet-misc/shigofumi: add 0.9 (diff)
downloadgentoo-707e13168685bb9866b0cf05bfb1d875f59cbea8.tar.gz
gentoo-707e13168685bb9866b0cf05bfb1d875f59cbea8.tar.bz2
gentoo-707e13168685bb9866b0cf05bfb1d875f59cbea8.zip
net-misc/shigofumi: sync live ebuild
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-misc/shigofumi')
-rw-r--r--net-misc/shigofumi/shigofumi-9999.ebuild57
1 files changed, 31 insertions, 26 deletions
diff --git a/net-misc/shigofumi/shigofumi-9999.ebuild b/net-misc/shigofumi/shigofumi-9999.ebuild
index 8667bb035c0c..398763fed882 100644
--- a/net-misc/shigofumi/shigofumi-9999.ebuild
+++ b/net-misc/shigofumi/shigofumi-9999.ebuild
@@ -1,16 +1,14 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-
-WANT_AUTOMAKE="1.11"
-inherit autotools
+EAPI=8
DESCRIPTION="Command line client for ISDS"
HOMEPAGE="http://xpisar.wz.cz/shigofumi/"
-if [[ ${PV} = 9999* ]]; then
+
+if [[ ${PV} == *9999 ]]; then
EGIT_REPO_URI='https://repo.or.cz/shigofumi.git'
- inherit git-r3
+ inherit autotools git-r3
else
SRC_URI="http://xpisar.wz.cz/${PN}/dist/${P}.tar.bz2"
KEYWORDS="~amd64 ~mips ~x86"
@@ -18,34 +16,41 @@ fi
LICENSE="GPL-3"
SLOT="0"
-IUSE="debug doc nls xattr"
+IUSE="debug nls xattr"
RDEPEND="
- dev-libs/confuse:0=
+ dev-libs/confuse:=
dev-libs/libxml2:2
- sys-libs/readline:0=
- >=net-libs/libisds-0.7
- xattr? ( sys-apps/attr )
-"
-DEPEND="${RDEPEND}
+ net-libs/libisds
+ sys-apps/file
+ sys-libs/readline:="
+DEPEND="${RDEPEND}"
+BDEPEND="
virtual/pkgconfig
- doc? (
- app-text/docbook-xsl-stylesheets
- dev-libs/libxslt
- )
- nls? ( sys-devel/gettext )
-"
+ nls? ( sys-devel/gettext )"
+
+[[ ${PV} == *9999 ]] && BDEPEND+="
+ app-text/docbook-xsl-stylesheets
+ app-text/po4a
+ dev-libs/libxslt"
src_prepare() {
default
- [[ ${PV} = 9999* ]] && eautoreconf
+ [[ ${PV} == *9999 ]] && eautoreconf
}
src_configure() {
- econf \
- --disable-fatalwarnings \
- $(use_enable debug) \
- $(use_enable doc) \
- $(use_enable nls) \
+ local myeconfargs=(
+ --disable-fatalwarnings
+ --enable-doc
+ --without-docbook-xsl-stylesheets
+ $(use_enable debug)
+ $(use_enable nls)
$(use_enable xattr)
+ )
+ [[ ${PV} == *9999 ]] && myeconfargs+=(
+ --with-docbook-xsl-stylesheets
+ )
+
+ econf "${myeconfargs[@]}"
}