summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-09-12 06:41:45 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-09-12 08:37:44 +0200
commitf36e527e097d6c7a42ffc11650e3f6ffa120f881 (patch)
tree12215c2d73dbd146dd5d77e5c0b52a281ced0d0f /net-libs/nghttp2
parentapp-misc/mtail: Add back missing patch. (diff)
downloadgentoo-f36e527e097d6c7a42ffc11650e3f6ffa120f881.tar.gz
gentoo-f36e527e097d6c7a42ffc11650e3f6ffa120f881.tar.bz2
gentoo-f36e527e097d6c7a42ffc11650e3f6ffa120f881.zip
net-libs/nghttp2: Bump to version 1.14.1
Package-Manager: portage-2.3.0 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-libs/nghttp2')
-rw-r--r--net-libs/nghttp2/Manifest1
-rw-r--r--net-libs/nghttp2/nghttp2-1.14.1.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/net-libs/nghttp2/Manifest b/net-libs/nghttp2/Manifest
index 0bd1c2b73370..4d235c5b46a4 100644
--- a/net-libs/nghttp2/Manifest
+++ b/net-libs/nghttp2/Manifest
@@ -1,4 +1,5 @@
DIST nghttp2-1.10.0.tar.gz 2086580 SHA256 192dc031e71e182240079befae9db7e64c9951da3a83c7a438f57cf76145b6a8 SHA512 4341f76ead38ba30e0dfda492e2e0f4c842f453e235fa90ee55b1e556092828236f21c6b212d0099cea005f149e4be3e63ad007009dd5228999101e563009a6f WHIRLPOOL 603391b0d15883cd9db734a0e4bb7d994c17ae4209d5251504e29cc59e0ccf67488b9340acefdb6d6603e9e7d3b0a0491ed18330edce4d20adb0ed19ffc5b975
DIST nghttp2-1.13.0.tar.gz 2115480 SHA256 2b169beaca27e04300762f4409d3322d7ed9d49eceb5b6b3e9ee277991521c66 SHA512 c70eca637b2e75957eb41d9b3f8261a595e753063f1fcfcf48cc78618f9bcb3a0fbcf991e482ceb01854f09aea8486262e9bb436d35cc098f3f6e2c72a0cc435 WHIRLPOOL 21a85c4512da820236ca9c1ac4071c46e13a9c724f6d0a542a7462e9d16745019ed5b95fad529eddbab9c00c2760d9bfc14b39e9c2b0a5270192f1951502250e
DIST nghttp2-1.14.0.tar.gz 2127562 SHA256 608197dbe32022c7ac568ea386bbc80c70f362bff123ab481dab24eb2b24b2ca SHA512 2fef440b4732ed1292a6190b81390829f21ccd8078ff981a1bb99ad9bd96dfab766b22ba9f7e1f000b8732a0747c16c7932474c73977e7f70fa2d753a8b4b68a WHIRLPOOL 55d1cf935c23be7666a2854d9e11936715c0583ce9699c93e9dd8cb62adce3e97b0f56f1a29c6ebfd353ee19f0e859384ff5ac69fae453808a0b6eadbeffa4a7
+DIST nghttp2-1.14.1.tar.gz 2122458 SHA256 1e1d36a7717373daa8f5049b8e1327e72e77acb961424cbd05a6619501374fb9 SHA512 a4ec88fa4636f540a7a15d97b87415be951ce094ec431eec3c54e82fc0da82cb9173dd0167cb5f21fa252554987de3c682a94fd65779c4c73fa0c81995eb3b2e WHIRLPOOL af16f80e23ed02b6120f67052d56223579cacf7bdc24976b0b3a0fc2c5050fe2362615b2f85e2d49893bd8378c34642d0a48c0c3a26e44f8bbdbdb7e119ccd9a
DIST nghttp2-1.7.1.tar.gz 1993320 SHA256 d83858464c03555828bb603288b66a48680bf164b376d2459a5407c102098a14 SHA512 3a71153d2b30a69e79115402b7db9a04bc812025ccb67b918079f33690f18eb5b286095b8bc161df91abf6466b6bb822ecc13c49bee54265a06ba9ab7c289b54 WHIRLPOOL 41d0afd43878029069d2c339e22b8aec77fedbd1b0fb45da96b9592525c760731e2eec567999af704d63cf94c913b1d0c52063380e69170e1f2d2b928c1d70f3
diff --git a/net-libs/nghttp2/nghttp2-1.14.1.ebuild b/net-libs/nghttp2/nghttp2-1.14.1.ebuild
new file mode 100644
index 000000000000..7d892241bc29
--- /dev/null
+++ b/net-libs/nghttp2/nghttp2-1.14.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# TODO: Add python support.
+
+EAPI=6
+
+inherit multilib-minimal
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/tatsuhiro-t/nghttp2.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/tatsuhiro-t/nghttp2/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+DESCRIPTION="HTTP/2 C Library"
+HOMEPAGE="https://nghttp2.org/"
+
+LICENSE="MIT"
+SLOT="0/1.14" # <C++>.<C> SONAMEs
+IUSE="cxx debug hpack-tools jemalloc libressl static-libs test +threads utils xml"
+
+RDEPEND="
+ cxx? ( dev-libs/boost:=[${MULTILIB_USEDEP},threads] )
+ hpack-tools? ( >=dev-libs/jansson-2.5 )
+ jemalloc? ( dev-libs/jemalloc )
+ utils? (
+ >=dev-libs/libev-4.15
+ !libressl? ( >=dev-libs/openssl-1.0.2:0[-bindist] )
+ libressl? ( dev-libs/libressl )
+ >=sys-libs/zlib-1.2.3
+ )
+ xml? ( >=dev-libs/libxml2-2.7.7:2 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ --disable-examples \
+ --disable-failmalloc \
+ --disable-werror \
+ --without-cython \
+ --disable-python-bindings \
+ --without-spdylay \
+ $(use_enable cxx asio-lib) \
+ $(use_enable debug) \
+ $(multilib_native_use_enable hpack-tools) \
+ $(use_enable static-libs static) \
+ $(use_enable threads) \
+ $(multilib_native_use_enable utils app) \
+ $(multilib_native_use_with jemalloc) \
+ $(multilib_native_use_with xml libxml2)
+}
+
+multilib_src_install_all() {
+ use static-libs || find "${ED}"/usr -name '*.la' -delete
+}