summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2022-12-26 09:03:25 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2022-12-26 09:03:25 +0100
commitcf5d7e070dc5231cfa79ec85cda692974b0d92f2 (patch)
tree996d90a78a6a7d814934a39941876e0ff5c4c3b8 /media-sound/din
parentmedia-sound/picard: dropped obsolete 2.8.3 (diff)
downloadgentoo-cf5d7e070dc5231cfa79ec85cda692974b0d92f2.tar.gz
gentoo-cf5d7e070dc5231cfa79ec85cda692974b0d92f2.tar.bz2
gentoo-cf5d7e070dc5231cfa79ec85cda692974b0d92f2.zip
media-sound/din: bump to 56
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/din')
-rw-r--r--media-sound/din/Manifest1
-rw-r--r--media-sound/din/din-56.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/media-sound/din/Manifest b/media-sound/din/Manifest
index 5f5caf546b33..8d7d83e74b97 100644
--- a/media-sound/din/Manifest
+++ b/media-sound/din/Manifest
@@ -1 +1,2 @@
DIST din-55.tar.gz 3711327 BLAKE2B 2c6ba4a877c512a950fb7c731f20d285019da1c7cd4ab5c7ff8d75e3c25eaa4ea08ca865b37e12fa1cefc1175baaa1c7ce27a44c7fa7c0b6c59b0ccbf6ab7a39 SHA512 432a53e71d1cf96c9ed62694fb23d1264d2e80b34620ebf0f1f33f3d4787cc7358c42038b2a45aa9d3ba9f59828eaaebd521a046fd5a51919a13f1bffad16a22
+DIST din-56.tar.gz 3716779 BLAKE2B 3fc2af445ef5cfa7a3ec56f841e62baf1832573a0ef085855f2f875961e8be24d43881c3394a39dbc5c3524a1d1c0033ac57ffa0b5487cadc1a189f9f49108b4 SHA512 2e3e985abec9f0f097d51fb4cff5e991c5f80091586c0a4c47533c623dc9c13bae6b7f8a3d18bed1fc150e6527482b4ae03a9d1d9c444ae92b88204892ce7e04
diff --git a/media-sound/din/din-56.ebuild b/media-sound/din/din-56.ebuild
new file mode 100644
index 000000000000..b6c0c95c276d
--- /dev/null
+++ b/media-sound/din/din-56.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools edos2unix xdg
+
+DESCRIPTION="a software musical instrument and audio synthesizer"
+HOMEPAGE="https://dinisnoise.org/"
+SRC_URI="https://archive.org/download/dinisnoise_source_code/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+alsa jack"
+
+RDEPEND="
+ dev-lang/tcl:0=
+ media-libs/libsdl:=
+ virtual/glu
+ virtual/opengl
+ alsa? ( media-libs/alsa-lib )
+ jack? ( virtual/jack )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/boost
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+REQUIRED_USE="|| ( alsa jack )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-55-makefile.patch"
+ "${FILESDIR}/${PN}-48-fix-random-constants.patch"
+)
+
+src_prepare() {
+ default
+
+ edos2unix pixmaps/${PN}.desktop
+
+ use jack && (sed -i "s/-lasound/-ljack/g" src/Makefile.am || die "Failed to fix jack linking")
+
+ eautoreconf
+}
+
+src_configure() {
+ # Jack takes over alsa.
+ local sound_engine
+
+ use jack && sound_engine="UNIX_JACK" || sound_engine="LINUX_ALSA"
+
+ econf CXXFLAGS="${CXXFLAGS} -D__${sound_engine}__"
+}