summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/mediastreamer-x264
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/mediastreamer-x264')
-rw-r--r--media-plugins/mediastreamer-x264/Manifest2
-rw-r--r--media-plugins/mediastreamer-x264/mediastreamer-x264-1.4.1.ebuild35
-rw-r--r--media-plugins/mediastreamer-x264/mediastreamer-x264-1.4.2-r1.ebuild31
-rw-r--r--media-plugins/mediastreamer-x264/mediastreamer-x264-1.4.2.ebuild30
-rw-r--r--media-plugins/mediastreamer-x264/metadata.xml8
5 files changed, 106 insertions, 0 deletions
diff --git a/media-plugins/mediastreamer-x264/Manifest b/media-plugins/mediastreamer-x264/Manifest
new file mode 100644
index 000000000000..f1ecca0c9dc6
--- /dev/null
+++ b/media-plugins/mediastreamer-x264/Manifest
@@ -0,0 +1,2 @@
+DIST msx264-1.4.1.tar.gz 291662 SHA256 3427168e0936d1d46b58e2e3da606e51ba463b1e6d6586e9ff6c2d1f2a539b75 SHA512 3d73fcea259af5d8c4cb9637538bdc40e0ea197a36eada5184390bda9277b43dfec8b2412edc44bbac2500664d7c007182b0b06f4a702bb22aecc54484fc115f WHIRLPOOL bab948086fb2febfedb89d2b3431e6ad23e2d114a6e1f387ab0739a25a2de8ba790eede1ba95fbe1dfd11d5abd88dea78795065737d97987ebda61f80ceb90e8
+DIST msx264-1.4.2.tar.gz 298631 SHA256 a84418465e0cc7185f66e14b04ac0e0c2e5ee7ee68fb201d0d697eb866b192b5 SHA512 06416957dcfd5e33418d19c941005a0deb1c18b47cfa8354b0b89f8434d47d649ca3d629bac3e2094ff5b6adc7118f5adc9d32411dd6ec12a8f3a6e96c2e356c WHIRLPOOL c08484438029379d22cdf564a817f8ab135a4e28410633bd2f194f1125eadb3f653068462933e2c47b03a1aece7f88ec42df8e68408a4cf037cfd1e0467a7d9c
diff --git a/media-plugins/mediastreamer-x264/mediastreamer-x264-1.4.1.ebuild b/media-plugins/mediastreamer-x264/mediastreamer-x264-1.4.1.ebuild
new file mode 100644
index 000000000000..7d6f5e55918f
--- /dev/null
+++ b/media-plugins/mediastreamer-x264/mediastreamer-x264-1.4.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit multilib
+
+MY_P="msx264-${PV}"
+
+DESCRIPTION="mediastreamer plugin: add H264 support"
+HOMEPAGE="http://www.linphone.org/"
+SRC_URI="mirror://nongnu/linphone/plugins/sources/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE=""
+
+RDEPEND=">=media-libs/mediastreamer-2.7.0[video]
+ >=media-libs/x264-0.0.20100118
+ virtual/ffmpeg"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="AUTHORS NEWS README"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ # strict: don't want -Werror
+ econf \
+ --libdir=/usr/$(get_libdir) \
+ --disable-strict
+}
diff --git a/media-plugins/mediastreamer-x264/mediastreamer-x264-1.4.2-r1.ebuild b/media-plugins/mediastreamer-x264/mediastreamer-x264-1.4.2-r1.ebuild
new file mode 100644
index 000000000000..6ab4e667fd71
--- /dev/null
+++ b/media-plugins/mediastreamer-x264/mediastreamer-x264-1.4.2-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_P="msx264-${PV}"
+
+DESCRIPTION="mediastreamer plugin: add H264 support"
+HOMEPAGE="http://www.linphone.org/"
+SRC_URI="mirror://nongnu/linphone/plugins/sources/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="libav"
+
+RDEPEND=">=media-libs/mediastreamer-2.7.0:=[video]
+ >=media-libs/x264-0.0.20100118:=
+ libav? ( media-video/libav:0= )
+ !libav? ( media-video/ffmpeg:0= )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ # strict: don't want -Werror
+ econf \
+ --disable-strict
+}
diff --git a/media-plugins/mediastreamer-x264/mediastreamer-x264-1.4.2.ebuild b/media-plugins/mediastreamer-x264/mediastreamer-x264-1.4.2.ebuild
new file mode 100644
index 000000000000..a06ea1e473b2
--- /dev/null
+++ b/media-plugins/mediastreamer-x264/mediastreamer-x264-1.4.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_P="msx264-${PV}"
+
+DESCRIPTION="mediastreamer plugin: add H264 support"
+HOMEPAGE="http://www.linphone.org/"
+SRC_URI="mirror://nongnu/linphone/plugins/sources/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=media-libs/mediastreamer-2.7.0:=[video]
+ >=media-libs/x264-0.0.20100118:=
+ virtual/ffmpeg"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ # strict: don't want -Werror
+ econf \
+ --disable-strict
+}
diff --git a/media-plugins/mediastreamer-x264/metadata.xml b/media-plugins/mediastreamer-x264/metadata.xml
new file mode 100644
index 000000000000..ee2fca9fb255
--- /dev/null
+++ b/media-plugins/mediastreamer-x264/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>bircoph@gentoo.org</email>
+ <name>Andrew Savchenko</name>
+ </maintainer>
+</pkgmetadata>