summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-05-08 22:17:20 +0100
committerSam James <sam@gentoo.org>2024-05-08 22:17:20 +0100
commit501f9e0004f152093fbb4fa19f3abcb3bfc4aa00 (patch)
tree626b3a29370ba6f28151b530bb349ce44e9926e8 /mail-filter
parentgames-strategy/wesnoth: remove unused patch (diff)
downloadgentoo-501f9e0004f152093fbb4fa19f3abcb3bfc4aa00.tar.gz
gentoo-501f9e0004f152093fbb4fa19f3abcb3bfc4aa00.tar.bz2
gentoo-501f9e0004f152093fbb4fa19f3abcb3bfc4aa00.zip
mail-filter/afew: fix build w/ >=sphinx-7
Closes: https://bugs.gentoo.org/906704 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/afew/afew-3.0.1.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/mail-filter/afew/afew-3.0.1.ebuild b/mail-filter/afew/afew-3.0.1.ebuild
index a0e78506c838..7113ba509d4a 100644
--- a/mail-filter/afew/afew-3.0.1.ebuild
+++ b/mail-filter/afew/afew-3.0.1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DISTUTILS_SINGLE_IMPL=1
DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit distutils-r1 pypi
@@ -46,8 +46,11 @@ python_prepare_all() {
}
python_compile_all() {
- esetup.py build_sphinx -b man --build-dir=docs/build
- use doc && esetup.py build_sphinx -b html --build-dir=docs/build
+ sphinx-build -b man docs docs/build/man || die
+
+ if use doc ; then
+ sphinx-build -b html docs docs/build/html || die
+ fi
}
python_install_all() {