summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /mail-filter/spamprobe
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'mail-filter/spamprobe')
-rw-r--r--mail-filter/spamprobe/Manifest1
-rw-r--r--mail-filter/spamprobe/files/spamprobe-1.4b-gcc43.patch150
-rw-r--r--mail-filter/spamprobe/files/spamprobe-1.4d+db-5.0.patch13
-rw-r--r--mail-filter/spamprobe/files/spamprobe-1.4d-gcc47.patch28
-rw-r--r--mail-filter/spamprobe/files/spamprobe-1.4d-libpng14.patch23
-rw-r--r--mail-filter/spamprobe/metadata.xml8
-rw-r--r--mail-filter/spamprobe/spamprobe-1.4d.ebuild42
7 files changed, 265 insertions, 0 deletions
diff --git a/mail-filter/spamprobe/Manifest b/mail-filter/spamprobe/Manifest
new file mode 100644
index 000000000000..ca8c97a8e2e6
--- /dev/null
+++ b/mail-filter/spamprobe/Manifest
@@ -0,0 +1 @@
+DIST spamprobe-1.4d.tar.gz 262761 SHA256 217ce47dcc6f58d8201fbb0a5e2dc38b5b06349fadb1378fb3647ad8a3f44d68 SHA512 176097b7e9de04a26a0a6a2c6b331ff375108ef7eb20cdfbda9abeec7ceb24a52c0edc932d8fcd8a5731f06b891469b4ee328562f4e88fbe6c737b719f45a8d8 WHIRLPOOL 854a8a4b711bcd4d8dccc1f7cfc5ee935eeba1af1b46e9c427da57c4f5a9742b1c49ee0bd6f9a471e42ca5ec7385656f118f8373e220ad45c3dd8031e2f5bd03
diff --git a/mail-filter/spamprobe/files/spamprobe-1.4b-gcc43.patch b/mail-filter/spamprobe/files/spamprobe-1.4b-gcc43.patch
new file mode 100644
index 000000000000..097c5584a816
--- /dev/null
+++ b/mail-filter/spamprobe/files/spamprobe-1.4b-gcc43.patch
@@ -0,0 +1,150 @@
+--- spamprobe-1.4d.orig/src/spamprobe/Command_exec.cc
++++ spamprobe-1.4d/src/spamprobe/Command_exec.cc
+@@ -28,6 +28,7 @@
+ // http://www.cooldevtools.com/qpl.html
+ //
+
++#include <cstdlib>
+ #include "SpamFilter.h"
+ #include "CommandConfig.h"
+ #include "ConfigManager.h"
+--- spamprobe-1.4d.orig/src/spamprobe/Command_edit_term.cc
++++ spamprobe-1.4d/src/spamprobe/Command_edit_term.cc
+@@ -28,6 +28,7 @@
+ // http://www.cooldevtools.com/qpl.html
+ //
+
++#include <cstdlib>
+ #include "SpamFilter.h"
+ #include "FrequencyDB.h"
+ #include "CommandConfig.h"
+--- spamprobe-1.4d.orig/src/spamprobe/Command_cleanup.cc
++++ spamprobe-1.4d/src/spamprobe/Command_cleanup.cc
+@@ -28,6 +28,7 @@
+ // http://www.cooldevtools.com/qpl.html
+ //
+
++#include <cstdlib>
+ #include "CleanupManager.h"
+ #include "SpamFilter.h"
+ #include "FrequencyDB.h"
+--- spamprobe-1.4d.orig/src/spamprobe/spamprobe.cc
++++ spamprobe-1.4d/src/spamprobe/spamprobe.cc
+@@ -28,6 +28,7 @@
+ // http://www.cooldevtools.com/qpl.html
+ //
+
++#include <cstdlib>
+ #include <unistd.h>
+ #include <locale.h>
+ #include <signal.h>
+--- spamprobe-1.4d.orig/src/spamprobe/Command_purge.cc
++++ spamprobe-1.4d/src/spamprobe/Command_purge.cc
+@@ -28,6 +28,7 @@
+ // http://www.cooldevtools.com/qpl.html
+ //
+
++#include <cstdlib>
+ #include "CleanupManager.h"
+ #include "SpamFilter.h"
+ #include "FrequencyDB.h"
+--- spamprobe-1.4d.orig/src/spamprobe/Command_import.cc
++++ spamprobe-1.4d/src/spamprobe/Command_import.cc
+@@ -28,6 +28,7 @@
+ // http://www.cooldevtools.com/qpl.html
+ //
+
++#include <cstdlib>
+ #include <fstream>
+ #include "LineReader.h"
+ #include "IstreamCharReader.h"
+--- spamprobe-1.4d.orig/src/database/DatabaseConfig.cc
++++ spamprobe-1.4d/src/database/DatabaseConfig.cc
+@@ -29,6 +29,7 @@
+ //
+
+ #include <stdexcept>
++#include <cstdlib>
+ #include "File.h"
+ #include "WordData.h"
+ #include "FrequencyDBImpl.h"
+--- spamprobe-1.4d.orig/src/parser/MailMessageReader.cc
++++ spamprobe-1.4d/src/parser/MailMessageReader.cc
+@@ -28,6 +28,7 @@
+ // http://www.cooldevtools.com/qpl.html
+ //
+
++#include <cstdlib>
+ #include "RegularExpression.h"
+ #include "MailMessage.h"
+ #include "MailMessageList.h"
+--- spamprobe-1.4d.orig/src/parser/MbxMailMessageReader.cc
++++ spamprobe-1.4d/src/parser/MbxMailMessageReader.cc
+@@ -28,6 +28,7 @@
+ // http://www.cooldevtools.com/qpl.html
+ //
+
++#include <cstdlib>
+ #include <stdexcept>
+ #include "MailMessage.h"
+ #include "MailMessageList.h"
+--- spamprobe-1.4d.orig/src/parser/AutoTrainMailMessageReader.cc
++++ spamprobe-1.4d/src/parser/AutoTrainMailMessageReader.cc
+@@ -28,6 +28,7 @@
+ // http://www.cooldevtools.com/qpl.html
+ //
+
++#include <cstdlib>
+ #include "MailMessage.h"
+ #include "AutoTrainMailMessageReader.h"
+
+--- spamprobe-1.4d.orig/src/parser/HtmlTokenizer.cc
++++ spamprobe-1.4d/src/parser/HtmlTokenizer.cc
+@@ -28,6 +28,7 @@
+ // http://www.cooldevtools.com/qpl.html
+ //
+
++#include <cstdlib>
+ #include "AbstractTokenReceiver.h"
+ #include "StringReader.h"
+ #include "RegularExpression.h"
+--- spamprobe-1.4d.orig/src/hdl/HdlTokenizer.cc
++++ spamprobe-1.4d/src/hdl/HdlTokenizer.cc
+@@ -28,6 +28,7 @@
+ // http://www.cooldevtools.com/qpl.html
+ //
+
++#include <cstdlib>
+ #include "AbstractCharReader.h"
+ #include "HdlError.h"
+ #include "HdlToken.h"
+--- spamprobe-1.4d.orig/src/includes/util.h
++++ spamprobe-1.4d/src/includes/util.h
+@@ -42,6 +42,7 @@
+ #include <cassert>
+ #include <iostream>
+ #include <cstdio>
++#include <cstring>
+ #include "Ptr.h"
+ #include "Ref.h"
+
+--- spamprobe-1.4d.orig/src/includes/MultiLineSubString.h
++++ spamprobe-1.4d/src/includes/MultiLineSubString.h
+@@ -31,6 +31,7 @@
+ #ifndef _MultiLineSubString_h
+ #define _MultiLineSubString_h
+
++#include <climits>
+ #include "AbstractMultiLineString.h"
+
+ class MultiLineSubString : public AbstractMultiLineString
+--- spamprobe-1.4d.orig/src/includes/Buffer.h
++++ spamprobe-1.4d/src/includes/Buffer.h
+@@ -32,6 +32,7 @@
+ #define _Buffer_h
+
+ #include "Array.h"
++#include <cassert>
+
+ //
+ // Similar to Array but handles variable length.
diff --git a/mail-filter/spamprobe/files/spamprobe-1.4d+db-5.0.patch b/mail-filter/spamprobe/files/spamprobe-1.4d+db-5.0.patch
new file mode 100644
index 000000000000..5ea5db04fff1
--- /dev/null
+++ b/mail-filter/spamprobe/files/spamprobe-1.4d+db-5.0.patch
@@ -0,0 +1,13 @@
+Index: spamprobe-1.4d/src/database/FrequencyDBImpl_bdb.cc
+===================================================================
+--- spamprobe-1.4d.orig/src/database/FrequencyDBImpl_bdb.cc
++++ spamprobe-1.4d/src/database/FrequencyDBImpl_bdb.cc
+@@ -155,7 +155,7 @@ bool FrequencyDBImpl_bdb::openDatabase(c
+ // hideous ifdefs into my code.
+ string filename(m_env ? db_file.getName() : db_file.getPath());
+ int flags = read_only ? DB_RDONLY : DB_CREATE;
+-#if DB_VERSION_MAJOR >= 4 && DB_VERSION_MINOR >= 1
++#if (DB_VERSION_MAJOR == 4 && DB_VERSION_MINOR >= 1) || DB_VERSION_MAJOR >= 5
+ ret = m_file->open(m_file, NULL, filename.c_str(), NULL, DB_BTREE, flags, create_mode);
+ #else
+ ret = m_file->open(m_file, filename.c_str(), NULL, DB_BTREE, flags, create_mode);
diff --git a/mail-filter/spamprobe/files/spamprobe-1.4d-gcc47.patch b/mail-filter/spamprobe/files/spamprobe-1.4d-gcc47.patch
new file mode 100644
index 000000000000..d281f57a3616
--- /dev/null
+++ b/mail-filter/spamprobe/files/spamprobe-1.4d-gcc47.patch
@@ -0,0 +1,28 @@
+ https://bugs.gentoo.org/421769
+
+ ../../src/includes/Ref.h:248:5: error: 'assign' was not declared in this scope, and no declarations were found by argument-dependent lookup at the point of instantiation
+
+
+ src/includes/Ref.h | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+--- a/src/includes/Ref.h
++++ b/src/includes/Ref.h
+@@ -189,7 +189,7 @@ public:
+
+ CRef<T> &operator=(const CRef<T> &other)
+ {
+- assign(other);
++ this->assign(other);
+ return *this;
+ }
+
+@@ -245,7 +245,7 @@ public:
+
+ Ref<T> &operator=(const Ref<T> &other)
+ {
+- assign(other);
++ this->assign(other);
+ return *this;
+ }
+
diff --git a/mail-filter/spamprobe/files/spamprobe-1.4d-libpng14.patch b/mail-filter/spamprobe/files/spamprobe-1.4d-libpng14.patch
new file mode 100644
index 000000000000..c019f39543eb
--- /dev/null
+++ b/mail-filter/spamprobe/files/spamprobe-1.4d-libpng14.patch
@@ -0,0 +1,23 @@
+--- src/parser/PngParser.cc
++++ src/parser/PngParser.cc
+@@ -53,9 +53,9 @@
+ {
+ if (m_initialized) {
+ if (m_infoPtr) {
+- png_destroy_read_struct(&m_pngPtr, &m_infoPtr, png_infopp_NULL);
++ png_destroy_read_struct(&m_pngPtr, &m_infoPtr, NULL);
+ } else {
+- png_destroy_read_struct(&m_pngPtr, png_infopp_NULL, png_infopp_NULL);
++ png_destroy_read_struct(&m_pngPtr, NULL, NULL);
+ }
+ }
+ }
+@@ -104,7 +104,7 @@
+ int bit_depth, color_type, interlace_type;
+
+ png_get_IHDR(m_pngPtr, m_infoPtr, &width, &height, &bit_depth, &color_type,
+- &interlace_type, int_p_NULL, int_p_NULL);
++ &interlace_type, (int *) NULL, (int *) NULL);
+
+ string base_token("image_0");
+ sendToken(base_token + "_height_" + num_to_string((int)width));
diff --git a/mail-filter/spamprobe/metadata.xml b/mail-filter/spamprobe/metadata.xml
new file mode 100644
index 000000000000..bb04a779a54a
--- /dev/null
+++ b/mail-filter/spamprobe/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-mail</herd>
+ <upstream>
+ <remote-id type="sourceforge">spamprobe</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/mail-filter/spamprobe/spamprobe-1.4d.ebuild b/mail-filter/spamprobe/spamprobe-1.4d.ebuild
new file mode 100644
index 000000000000..96dbfbeb38fa
--- /dev/null
+++ b/mail-filter/spamprobe/spamprobe-1.4d.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="Fast, intelligent, automatic spam detector using Bayesian analysis"
+HOMEPAGE="http://spamprobe.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="QPL"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="berkdb gif jpeg png"
+
+DEPEND="berkdb? ( >=sys-libs/db-3.2 )
+ gif? ( media-libs/giflib )
+ jpeg? ( virtual/jpeg )
+ png? ( media-libs/libpng )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.4b-gcc43.patch \
+ "${FILESDIR}"/${P}-libpng14.patch \
+ "${FILESDIR}"/${P}+db-5.0.patch \
+ "${FILESDIR}"/${P}-gcc47.patch
+}
+
+src_configure() {
+ econf \
+ $(use_with gif) \
+ $(use_with jpeg) \
+ $(use_with png)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc ChangeLog README.txt
+
+ insinto /usr/share/${PN}/contrib
+ doins contrib/* || die
+}