summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-base/qtruby
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-base/qtruby')
-rw-r--r--kde-base/qtruby/Manifest1
-rw-r--r--kde-base/qtruby/files/qtruby-4.14.3-ruby20.patch18
-rw-r--r--kde-base/qtruby/metadata.xml12
-rw-r--r--kde-base/qtruby/qtruby-4.14.3-r2.ebuild72
4 files changed, 103 insertions, 0 deletions
diff --git a/kde-base/qtruby/Manifest b/kde-base/qtruby/Manifest
new file mode 100644
index 000000000000..d8de2d6a2e20
--- /dev/null
+++ b/kde-base/qtruby/Manifest
@@ -0,0 +1 @@
+DIST qtruby-4.14.3.tar.xz 529568 SHA256 2050e79b5e116eefef97d9b2dc96b3be635621bcbf856a8009b56dc40f953c9d SHA512 fbca49e91703233c4caab994d98e5244bd27328af76a227745e453aeb554f6a47e55cab6fb994d48d24c063d1d3a9f3c0c35486edb2604df5d090031bf3146de WHIRLPOOL c6c5676b3f3848e540afe7659598522a0bda69b100ce6ba225b5bea72f622fb33ad7be1350e6399fc5f110af6b1bf49956f505c0236baedfcf5b54b628873921
diff --git a/kde-base/qtruby/files/qtruby-4.14.3-ruby20.patch b/kde-base/qtruby/files/qtruby-4.14.3-ruby20.patch
new file mode 100644
index 000000000000..abc41438e2b9
--- /dev/null
+++ b/kde-base/qtruby/files/qtruby-4.14.3-ruby20.patch
@@ -0,0 +1,18 @@
+--- qtruby-4.11.4.orig/src/qtruby.cpp 2013-06-28 19:16:12.057325696 +0200
++++ qtruby-4.11.4/src/qtruby.cpp 2014-01-07 19:22:11.000000000 +0100
+@@ -1398,11 +1391,14 @@
+ return Qfalse;
+ }
+
+-#if RUBY_VERSION >= 0x10900
++#if RUBY_VERSION >= 0x20000
++ QLatin1String signalname(rb_id2name(rb_frame_this_func()));
++#elif RUBY_VERSION >= 0x10900
+ QLatin1String signalname(rb_id2name(rb_frame_callee()));
+ #else
+ QLatin1String signalname(rb_id2name(rb_frame_last_func()));
+ #endif
++
+ VALUE metaObject_value = rb_funcall(qt_internal_module, rb_intern("getMetaObject"), 2, Qnil, self);
+
+ smokeruby_object *ometa = value_obj_info(metaObject_value);
diff --git a/kde-base/qtruby/metadata.xml b/kde-base/qtruby/metadata.xml
new file mode 100644
index 000000000000..4cadec21f08a
--- /dev/null
+++ b/kde-base/qtruby/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>kde</herd>
+<use>
+ <flag name="declarative">Compile bindings for <pkg>dev-qt/qtdeclarative</pkg>.</flag>
+ <flag name="phonon">Compile bindings for Phonon.</flag>
+ <flag name="qscintilla">Compile bindings for <pkg>x11-libs/qscintilla</pkg>.</flag>
+ <flag name="qwt">Compile bindings for <pkg>x11-libs/qwt</pkg>.</flag>
+ <flag name="webkit">Compile bindings for <pkg>dev-qt/qtwebkit</pkg>.</flag>
+</use>
+</pkgmetadata>
diff --git a/kde-base/qtruby/qtruby-4.14.3-r2.ebuild b/kde-base/qtruby/qtruby-4.14.3-r2.ebuild
new file mode 100644
index 000000000000..43ae4aa77135
--- /dev/null
+++ b/kde-base/qtruby/qtruby-4.14.3-r2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OPENGL_REQUIRED="always"
+DECLARATIVE_REQUIRED="optional"
+KDE_REQUIRED="never"
+USE_RUBY="ruby20"
+# Only one ruby version is supported:
+# 1) cmake bails when configuring twice or more - solved with CMAKE_IN_SOURCE_BUILD=1
+# 2) the ebuild can only be installed for one ruby variant, otherwise the compiled
+# files with identical path+name will overwrite each other - difficult :(
+
+inherit kde4-base ruby-ng
+
+DESCRIPTION="Qt Ruby bindings"
+KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="debug phonon qscintilla qwt webkit"
+HOMEPAGE="http://techbase.kde.org/Development/Languages/Ruby"
+
+DEPEND="
+ $(add_kdebase_dep smokeqt 'declarative?,opengl,phonon?,qscintilla?,qwt?,webkit?')
+"
+
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-ruby20.patch" )
+
+pkg_setup() {
+ ruby-ng_pkg_setup
+ kde4-base_pkg_setup
+}
+
+src_unpack() {
+ local S="${WORKDIR}/${P}"
+ kde4-base_src_unpack
+
+ cd "${WORKDIR}"
+ mkdir all
+ mv ${P} all/ || die "Could not move sources"
+}
+
+all_ruby_prepare() {
+ kde4-base_src_prepare
+}
+
+each_ruby_configure() {
+ local CMAKE_USE_DIR=${S}
+ local mycmakeargs=(
+ -DRUBY_LIBRARY=$(ruby_get_libruby)
+ -DRUBY_INCLUDE_PATH=$(ruby_get_hdrdir)
+ -DRUBY_EXECUTABLE=${RUBY}
+ $(cmake-utils_use_disable declarative QtDeclarative)
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_with qscintilla QScintilla)
+ $(cmake-utils_use_with qwt Qwt5)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-base_src_configure
+}
+
+each_ruby_compile() {
+ local CMAKE_USE_DIR=${S}
+ kde4-base_src_compile
+}
+
+each_ruby_install() {
+ local CMAKE_USE_DIR=${S}
+ kde4-base_src_install
+}