summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAbdelrahman Sarhan <abdulrahmanayman1@gmail.com>2024-10-24 18:42:31 -0400
committerSam James <sam@gentoo.org>2024-12-01 12:00:57 +0000
commitdf45f3841d026c6155a4e31815fa0678697c9e3c (patch)
treed225b87d7d7aa60db7e73094c932c8b6e57d3fee /games-fps
parentdev-db/sqlitebrowser: add 3.13.1 (diff)
downloadgentoo-df45f3841d026c6155a4e31815fa0678697c9e3c.tar.gz
gentoo-df45f3841d026c6155a4e31815fa0678697c9e3c.tar.bz2
gentoo-df45f3841d026c6155a4e31815fa0678697c9e3c.zip
games-fps/chocolate-doom: add 3.1.0
Closes: https://bugs.gentoo.org/937108 Signed-off-by: Abdelrahman Sarhan <abdulrahmanayman1@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/chocolate-doom/Manifest1
-rw-r--r--games-fps/chocolate-doom/chocolate-doom-3.1.0.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/games-fps/chocolate-doom/Manifest b/games-fps/chocolate-doom/Manifest
index b2cd839d0fdd..bfa65ef5b2ce 100644
--- a/games-fps/chocolate-doom/Manifest
+++ b/games-fps/chocolate-doom/Manifest
@@ -1,2 +1,3 @@
DIST chocolate-doom-3.0.1-overhaul-manpages-add-parameters.patch 26736 BLAKE2B 3b75eaf6ea38280eb649eb0a35cf72376fc8daafda51a79bb321e1ac9311bd7d7edc6b7740b235288c32142c01fcf346045091783912739317556a78eb07751a SHA512 64512c47d404de1a85f84948bcf780257070f5b22dce6fa7dba66ba65027a15e93e39145424be327de4abd1f1f3b994fcd936e3dcdc564f1f96238b133a3a554
DIST chocolate-doom-3.0.1.tar.gz 2245563 BLAKE2B 0c9babfbc9e52ea7822ca00c0dbf84e471bfe6d6ec94f729d3d0f72243205b060e5a3b5f1f99728da7764e81af735b45d001bb368dd2b5796666554e3c911090 SHA512 2a81905cf619ea2def7e2f9ebe65b38543d01bd83a95e535e88d04a79f2676f8ba0da64031a650bd905e1345cda1b9d28a398ad87c10c92f2d3d50f3253ec214
+DIST chocolate-doom-3.1.0.tar.gz 2256537 BLAKE2B 4e311985e1c20d2d5bf0cc6ef3e860c78a0d1e413ca398800bcdcf86f43727e48f1306e7e9c8878e3313e9ca2e7ba3d48eddd220ef5def06230caf32fe0890fb SHA512 17f65c6f4a48dd1b0aa71bdf495d1036602739f1955d64f7de46157fce912ab4e4344a0f7ad073980f50d67e34f9f5e84402e7f2142cd6364453b71c8d5c2592
diff --git a/games-fps/chocolate-doom/chocolate-doom-3.1.0.ebuild b/games-fps/chocolate-doom/chocolate-doom-3.1.0.ebuild
new file mode 100644
index 000000000000..afb39759009b
--- /dev/null
+++ b/games-fps/chocolate-doom/chocolate-doom-3.1.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+inherit autotools prefix python-any-r1 xdg
+
+DESCRIPTION="A Doom source port that is minimalist and historically accurate"
+HOMEPAGE="https://www.chocolate-doom.org"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${P}.tar.gz"
+S="${WORKDIR}/${PN}-${P}"
+LICENSE="BSD GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="doc libsamplerate +midi png vorbis"
+
+DEPEND="
+ media-libs/libsdl2[video]
+ media-libs/sdl2-mixer[midi?,vorbis?]
+ media-libs/sdl2-net
+ libsamplerate? ( media-libs/libsamplerate )
+ png? ( media-libs/libpng:= )
+"
+
+RDEPEND="
+ ${DEPEND}
+"
+
+# ${PYTHON_DEPS} for bash-completion and docs.
+BDEPEND="
+ ${PYTHON_DEPS}
+"
+
+DOCS=(
+ "AUTHORS"
+ "ChangeLog"
+ "NEWS.md"
+ "NOT-BUGS.md"
+ "PHILOSOPHY.md"
+ "README.md"
+ "README.Music.md"
+ "README.Strife.md"
+)
+
+src_prepare() {
+ default
+
+ hprefixify src/d_iwad.c
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-bash-completion \
+ $(use_enable doc) \
+ --disable-fonts \
+ --disable-icons \
+ $(use_with libsamplerate) \
+ $(use_with png libpng)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # Remove redundant documentation files
+ rm -r "${ED}/usr/share/doc/"* || die
+
+ einstalldocs
+}