summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <kangie@gentoo.org>2024-09-24 14:57:14 +1000
committerMatt Jolly <kangie@gentoo.org>2024-09-24 16:30:36 +1000
commit3a940652a290052650a406a4e387695cb04ca920 (patch)
tree381834c554c0c8d6579c5e7df4851b2832f02625 /games-fps
parentgames-fps/alephone: drop 20230119 (diff)
downloadgentoo-3a940652a290052650a406a4e387695cb04ca920.tar.gz
gentoo-3a940652a290052650a406a4e387695cb04ca920.tar.bz2
gentoo-3a940652a290052650a406a4e387695cb04ca920.zip
games-fps/alephone-marathon: add 20240822
Signed-off-by: Matt Jolly <kangie@gentoo.org>
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/alephone-marathon/Manifest1
-rw-r--r--games-fps/alephone-marathon/alephone-marathon-20240822.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/games-fps/alephone-marathon/Manifest b/games-fps/alephone-marathon/Manifest
index 3f12b7f3582d..d5e7202012b6 100644
--- a/games-fps/alephone-marathon/Manifest
+++ b/games-fps/alephone-marathon/Manifest
@@ -1 +1,2 @@
DIST Marathon-20221126-Data.zip 26473388 BLAKE2B 16e93da81942c77ff399364d16a9b554c9f13320f08604006dc991b0be24db69d2a6496c45053d2ebb66628f3f2024d09953cec565d6fbdf8d6380f593f47e3e SHA512 4fcf16fcf0a04ccb5ce1fc4dc0ef95a09ff9010f444438c830977490401d3ca01e10d1ffe429df804d3ed6683e8b8f5aed982ca5a3e3049a23b074c783fb7c61
+DIST Marathon-20240822-Data.zip 26408514 BLAKE2B 81459b2bd3718fc4b87d8da512da202912847673ee912467d7aee871bede0f5163cccdf0836f39968dd6c93cff443684491189281ad90b10ae9d0a77e45a8f24 SHA512 b834b181c9451d003c1e87844faf7c56e827e48475d66ac644f4387227ec40f5199758c3a517334c10ae3938f51ecf453d40cc99ff0a95614c5888a6b5cfb196
diff --git a/games-fps/alephone-marathon/alephone-marathon-20240822.ebuild b/games-fps/alephone-marathon/alephone-marathon-20240822.ebuild
new file mode 100644
index 000000000000..a1e8facfaa52
--- /dev/null
+++ b/games-fps/alephone-marathon/alephone-marathon-20240822.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop
+
+DESCRIPTION="Aleph One - Marathon (M1A1)"
+HOMEPAGE="https://alephone.lhowon.org/"
+SRC_URI="https://github.com/Aleph-One-Marathon/alephone/releases/download/release-${PV}/Marathon-${PV}-Data.zip"
+S="${WORKDIR}/Marathon"
+
+LICENSE="bungie-marathon"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="mirror"
+
+RDEPEND="games-fps/alephone"
+BDEPEND="app-arch/unzip"
+
+MY_NAME="marathon"
+MY_DIR="/usr/share/alephone-${MY_NAME}"
+
+src_install() {
+ insinto "${MY_DIR}"
+ doins -r *
+
+ make_desktop_entry "alephone.sh ${MY_NAME}" "${DESCRIPTION}"
+
+ # Make sure the extra dirs exist in case the user wants to add some data
+ keepdir "${MY_DIR}"/{Scripts,"Physics Models",Textures,Themes}
+}
+
+pkg_postinst() {
+ elog "To play this scenario, run:"
+ elog "alephone.sh ${MY_NAME}"
+}