summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-10-04 11:59:28 +0200
committerMichał Górny <mgorny@gentoo.org>2015-10-04 12:11:24 +0200
commit8bd3b00dcb0b4e546d6c7cdc43a2122280873c8e (patch)
tree54220d57bcff4d519c8290166f79473999f425a2 /games-emulation/m64py
parentdev-haskell/conduit: amd64 stable wrt bug #550394 (diff)
downloadgentoo-8bd3b00dcb0b4e546d6c7cdc43a2122280873c8e.tar.gz
gentoo-8bd3b00dcb0b4e546d6c7cdc43a2122280873c8e.tar.bz2
gentoo-8bd3b00dcb0b4e546d6c7cdc43a2122280873c8e.zip
games-emulation/mupen64plus*: Version bump to 2.5
Bump mupen64plus to 2.5 which brings a number of bug fixes. Switch to SDL2 as its support become stable and the default. Also switch m64py to SDL2 to match. Package-Manager: portage-2.2.22
Diffstat (limited to 'games-emulation/m64py')
-rw-r--r--games-emulation/m64py/m64py-0.2.3-r1.ebuild (renamed from games-emulation/m64py/m64py-0.2.3.ebuild)15
1 files changed, 5 insertions, 10 deletions
diff --git a/games-emulation/m64py/m64py-0.2.3.ebuild b/games-emulation/m64py/m64py-0.2.3-r1.ebuild
index 18371403589f..6ba5a09fe0c4 100644
--- a/games-emulation/m64py/m64py-0.2.3.ebuild
+++ b/games-emulation/m64py/m64py-0.2.3-r1.ebuild
@@ -6,7 +6,7 @@ EAPI=5
PYTHON_COMPAT=( python3_4 )
-inherit distutils-r1
+inherit distutils-r1 versionator
DESCRIPTION="A frontend for Mupen64Plus"
HOMEPAGE="http://m64py.sourceforge.net/"
@@ -18,9 +18,9 @@ KEYWORDS="~amd64 ~x86"
IUSE=""
# SDL & libmupen64plus are through ctypes, so they rely on specific ABI
-RDEPEND="media-libs/libsdl:0/0[joystick]
+RDEPEND="media-libs/libsdl2:0/0[joystick]
dev-python/PyQt5[opengl,${PYTHON_USEDEP}]
- >=games-emulation/mupen64plus-core-2.0-r1:0/2"
+ >=games-emulation/mupen64plus-core-2.5:0/2-sdl2"
python_prepare_all() {
# set the correct search path
@@ -28,14 +28,9 @@ python_prepare_all() {
SEARCH_DIRS = ["/usr/$(get_libdir)/mupen64plus"]
_EOF_
- # comment out SDL2 support since our mupen64plus uses SDL1
- sed -e '/from m64py\.SDL2/s:^:#:' \
- -e '/QT2SDL2\[/s:^:#:' \
- -e '/KEYCODE2SCANCODE\[/s:^:#:' \
- -e '/SCANCODE2KEYCODE\[/s:^:#:' \
- -i src/m64py/frontend/keymap.py || die
+ # force SDL2 support to match >=mupen64plus-2.5
sed -e '/--sdl2/d' \
- -e '/SDL2/s:=.*$:= False:' \
+ -e '/SDL2/s:=.*$:= True:' \
-i src/m64py/opts.py || die
distutils-r1_python_prepare_all