summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-board/openyahtzee
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-board/openyahtzee')
-rw-r--r--games-board/openyahtzee/Manifest1
-rw-r--r--games-board/openyahtzee/metadata.xml11
-rw-r--r--games-board/openyahtzee/openyahtzee-1.9.1.ebuild39
3 files changed, 51 insertions, 0 deletions
diff --git a/games-board/openyahtzee/Manifest b/games-board/openyahtzee/Manifest
new file mode 100644
index 000000000000..1a1267e26f1b
--- /dev/null
+++ b/games-board/openyahtzee/Manifest
@@ -0,0 +1 @@
+DIST openyahtzee-1.9.1.tar.bz2 159149 SHA256 aa553a248d30ba259abb8dee735d5728bfdbb8d4705805bc716453245f1cb0a0 SHA512 2833a7085bb03d157b58a5e3a95c03b8a51cc8b527aec204188c8f773c492f4822655ec15dbedd4330c25bc4382132694ae7d3935dfb27756e859149ab66ef59 WHIRLPOOL 8c9986f163576d2d5ab31ea4083139645513c6d3e1a171cba9cb7030186a2f022984e8a9925f7524e2b25b9c7ad3a989eb39bb76b13642cef848e66daabfa86d
diff --git a/games-board/openyahtzee/metadata.xml b/games-board/openyahtzee/metadata.xml
new file mode 100644
index 000000000000..ec3a69c721bb
--- /dev/null
+++ b/games-board/openyahtzee/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <longdescription lang="en">
+Open Yhatzee is an open-source (free) version of the classic dice game Yahtzee.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">openyahtzee</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-board/openyahtzee/openyahtzee-1.9.1.ebuild b/games-board/openyahtzee/openyahtzee-1.9.1.ebuild
new file mode 100644
index 000000000000..3fecc1afb4ec
--- /dev/null
+++ b/games-board/openyahtzee/openyahtzee-1.9.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+WX_GTK_VER="2.8"
+inherit wxwidgets toolchain-funcs versionator games
+
+DESCRIPTION="A full-featured wxWidgets version of the classic dice game Yahtzee"
+HOMEPAGE="http://openyahtzee.sourceforge.net/"
+SRC_URI="mirror://sourceforge/openyahtzee/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="x11-libs/wxGTK:2.8[X]"
+DEPEND="${RDEPEND}
+ >=sys-devel/gcc-4.6
+ dev-libs/boost"
+
+pkg_pretend() {
+ local ver=4.6
+ local msg="You need at least GCC ${ver}.x for C++11 range-based 'for' and nullptr support."
+ if ! version_is_at_least ${ver} $(gcc-version); then
+ eerror ${msg}
+ die ${msg}
+ fi
+}
+
+src_configure() {
+ egamesconf --datadir=/usr/share
+}
+
+src_install() {
+ default
+ prepgamesdirs
+}