summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-tex/dvipost
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-tex/dvipost')
-rw-r--r--dev-tex/dvipost/Manifest1
-rw-r--r--dev-tex/dvipost/dvipost-1.1-r2.ebuild39
-rw-r--r--dev-tex/dvipost/files/1.1-ldflags.patch13
-rw-r--r--dev-tex/dvipost/metadata.xml5
4 files changed, 58 insertions, 0 deletions
diff --git a/dev-tex/dvipost/Manifest b/dev-tex/dvipost/Manifest
new file mode 100644
index 000000000000..28f3a3887834
--- /dev/null
+++ b/dev-tex/dvipost/Manifest
@@ -0,0 +1 @@
+DIST dvipost-1.1.tar.gz 46428 SHA256 da05010ec47b7bc6b410d9c1eb7b083eeeed1a96f1986470377e604a64fa425a SHA512 5598dca794b4f1ec38e98128e50a72dfb168423d0302b560ff6d944573031b4f56a78b3ac48fabec3ca33886e350fca63c43fe0bd6892c4bd064d486dd4c25b4 WHIRLPOOL 3b7c7cb0ca97d26f0942d4a67fa639a370eaa9239019bb3e4fe63be08efc367d3036fc5c7d521de87bde9afa492161133fc0a762d819ae898756a798a6258de7
diff --git a/dev-tex/dvipost/dvipost-1.1-r2.ebuild b/dev-tex/dvipost/dvipost-1.1-r2.ebuild
new file mode 100644
index 000000000000..a5508c9f332c
--- /dev/null
+++ b/dev-tex/dvipost/dvipost-1.1-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit latex-package eutils toolchain-funcs
+
+DESCRIPTION="post processor for dvi files"
+HOMEPAGE="http://efeu.cybertec.at/index_en.html"
+SRC_URI="http://efeu.cybertec.at/dist/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x64-macos ~x86-macos"
+IUSE=""
+
+src_prepare() {
+ tc-export CC
+ epatch "${FILESDIR}"/${PV}-ldflags.patch
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ dobin dvipost || die
+ dosym dvipost /usr/bin/pptex || die
+ dosym dvipost /usr/bin/pplatex || die
+
+ insinto ${TEXMF}/tex/latex/misc/
+ insopts -m0644
+ doins dvipost.sty || die
+
+ dodoc dvipost.doc CHANGELOG NOTES README || die
+ dohtml dvipost.html || die
+ newman "${S}"/dvipost.man dvipost.1 || die
+}
diff --git a/dev-tex/dvipost/files/1.1-ldflags.patch b/dev-tex/dvipost/files/1.1-ldflags.patch
new file mode 100644
index 000000000000..b8711b500268
--- /dev/null
+++ b/dev-tex/dvipost/files/1.1-ldflags.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile.in b/Makefile.in
+index cd4758b..bb0af2a 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -74,7 +74,7 @@ clean::; rm -f main.o
+
+ OBJ= main.o $(BASE:.c=.o) $(DVI:.c=.o)
+
+-$(NAME): $(OBJ); $(CC) $(CFLAGS) -o $@ $(OBJ)
++$(NAME): $(OBJ); $(CC) $(LDFLAGS) $(CFLAGS) -o $@ $(OBJ)
+
+ clean::; rm -f $(NAME)
+
diff --git a/dev-tex/dvipost/metadata.xml b/dev-tex/dvipost/metadata.xml
new file mode 100644
index 000000000000..ba6a8a8800d5
--- /dev/null
+++ b/dev-tex/dvipost/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>tex</herd>
+</pkgmetadata>