summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-27 05:53:33 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-27 06:47:06 +0100
commite1ed2057a855e035c49cafa2b9afc2cad10268af (patch)
tree2d7cae6500728ed0eebdb8ac3a734da8687b382c /dev-python
parentdev-python/bandit: Bump to 1.8.0 (diff)
downloadgentoo-e1ed2057a855e035c49cafa2b9afc2cad10268af.tar.gz
gentoo-e1ed2057a855e035c49cafa2b9afc2cad10268af.tar.bz2
gentoo-e1ed2057a855e035c49cafa2b9afc2cad10268af.zip
dev-python/json5: Bump to 0.10.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/json5/Manifest1
-rw-r--r--dev-python/json5/json5-0.10.0.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/json5/Manifest b/dev-python/json5/Manifest
index e6889111355d..cbcd79dcf583 100644
--- a/dev-python/json5/Manifest
+++ b/dev-python/json5/Manifest
@@ -1,2 +1,3 @@
+DIST json5-0.10.0.tar.gz 48202 BLAKE2B 78794c785c5e5636aede6db48e230a5480ac10b8bbab4041cb827deabb1f251b3f2eddc252d5d0f91f358c093feba422575fdd51448c0984195937094227e48b SHA512 1c56def363c268aa256066c8e98b3a9bfba66a3756071bf6ff41929cdd98ccf5435f08103fbbc3b505abe81f39a14fa1ec50d4a984eebc52410cbb31f999b1b9
DIST json5-0.9.25.tar.gz 40332 BLAKE2B 4b24a2f3047c04ce80b0415340ce2d957d319bd45e804147710eb7c1eb0da97b083220839a6e11b852d8c9df5036e2a401060cdec93442245e220fc816d7811f SHA512 0ce3943af45e22415b30a3d43497236a1437adb67b739b97db7bb25b156bb254d0daf613f1f0ba5fafc5904708db81c8a786237ade757267f767afa88d5aa2f2
DIST json5-0.9.28.tar.gz 41853 BLAKE2B 8cc1acb34edfc50d9d95ec812870740bc7cf24ca029f52130759c822bc0c882fab1b620809d780a3fff954be2fd74190d3ad52e6fcab1e3c4279095764253317 SHA512 f9dd8bc14f33c92ebb8cae86f60915cb04880a037c03e8b3bc68d8bbec85e39d1add835bad3e417c1bd5215dd438f63fdb764e858438fdc86aed32cd64fba026
diff --git a/dev-python/json5/json5-0.10.0.ebuild b/dev-python/json5/json5-0.10.0.ebuild
new file mode 100644
index 000000000000..5bdfa4882882
--- /dev/null
+++ b/dev-python/json5/json5-0.10.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Python implementation of the JSON5 data format"
+HOMEPAGE="
+ https://github.com/dpranke/pyjson5/
+ https://pypi.org/project/json5/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+distutils_enable_tests pytest